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chapter 1

Introduction
This guide describes how to transfer audio and 
video from Avid Xpress Pro to Pro Tools for ed-
iting, and then transfer your finished audio 
tracks from Pro Tools back into Avid Xpress Pro 
for integration with your video.

Avid Terminology
This section provides a brief glossary of Avid 
terms and, where applicable, their Pro Tools 
counterparts.

Media Data (Media Files)

Media data represents raw audio or video mate-
rial and is stored in individual media files. Every 
time you record a piece of video or audio mate-
rial into an application, you are creating a media 
file containing media data. Audio media data is 
stored as samples (such as 44,100 or 48,000 sam-
ples per second of recording) while video media 
is typically stored as frames (24, 25, or 30 frames 
per second of recording).

The size of each media file depends on how 
much audio or video material it contains. For 
example, if you record ten minutes of continu-
ous video material at a high resolution, you 
might end up with a video media file that is 

This workflow assumes you have Pro Tools 
and Avid Xpress Pro installed on the same 
computer.
1.8 GB in size, whereas a one minute recording 
at the same resolution might result in a 180 MB 
file. Media files tend to be large, since high qual-
ity audio and video signals are data intensive. 
Video data generally requires considerably more 
storage than audio data.

Metadata

Metadata is used to describe:

• Information about each media file. This 
may include sample rate, bit depth, region 
names, the name of the videotape from 
which the media file was captured, and 
even time code values that specify where a 
file was used in a Pro Tools session.

• Information about Pro Tools sessions or 
other sequences, including what files are 
used, where they appear in a timeline, and 
automation.

• For AAF or OMF sequences, metadata also 
includes information about unrendered 
AudioSuite effects (such as real-time EQ) on 
Avid workstations. Pro Tools skips unren-
dered effects on import. Rendered effects 
are media files, that can be imported or 
skipped on import into Pro Tools.

• For AAF or OMF sequences, information 
about automation (clip-based gain or key-
frame gain).
Chapter 1: Introduction 1
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AAF, OMF, and MXF Basics

AAF and OMF are mechanisms for storing and 
retrieving media data and metadata so that 
projects can be freely exchanged between differ-
ent applications and platforms.

Media data and metadata enable an application 
that receives AAF and OMF sequence files (such 
as Pro Tools) to automatically and quickly reas-
semble the composition. A simple metaphor for 
this approach is that media data files are the 
pieces of a puzzle and metadata is the set of in-
structions for assembling the puzzle.

In the simplest case, only an AAF or OMF se-
quence is exchanged. If this sequence refers to 
external media data, the size of the sequence file 
is relatively small and the export/import process 
is relatively fast. AAF and OMF sequences can 
also have media data embedded in them. This 
creates a single, larger file that is slower to ex-
port and import, but which may be easier to 
manage than thousands of files stored on differ-
ent volumes.

MXF

MXF is a media file format. There are MXF video 
files and MXF audio files only. Pro Tools can 
currently import and play back MXF video files, 
but not MXF audio files.
Avid Xpress Pro Workflow Guide
OMF

OMF is both a media file and sequence format. 
OMF media files can be audio or video, and 
Pro Tools can import and play back OMF audio 
and video. Pro Tools can also export OMF audio, 
but not OMF video. An OMF sequence can refer 
to OMF and/or MXF media files, or have OMF 
and MXF media files embedded within it. 
Pro Tools can import an OMF sequence with 
embedded audio, but not embedded video.

AAF

AAF are only sequences, not audio or video files. 
An AAF sequence can refer to OMF and/or MXF 
media files, or have OMF and MXF media files 
embedded within it. There is no such thing as 
an AAF audio or video media file. Pro Tools will 
import, play back and export an AAF sequence 
that refers to external media files, but it does not 
support AAF sequences with media files embed-
ded within them.



             
Pro Tools and Avid Counterparts

Pro Tools and Avid use different terms to de-
scribe the same items. For example, a Pro Tools 
session is equivalent to an Avid sequence. The 
following table lists common Pro Tools ele-
ments and their Avid equivalents.

Pro Tools and Avid terminology counterparts

Pro Tools Avid (OMF)

session sequence

whole file region master clip

region subclip

plug-ins real-time audio effects

automation automation gain (clip-based 
gain or key-frame gain)

Whole audio files in the Regions List nor-
mally appear in bold type. However, master 
clip audio files imported from AAF or OMF 
sequences into Pro Tools will not appear in 
bold type (indicating regions) in the 
Pro Tools Regions List even though they are 
audio files.
Embedded Media and External 
Media

There are two ways to handle media files when 
exporting OMF files: Embedded Media and Ex-
ternal File References. 

Embedded Media (OMF Only)

Exporting to OMF with embedded media results 
in one large OMF file containing both the meta-
data and all associated media files. However, it is 
important to note that OMF limits file size to 
2 GB.

Pro Tools with DigiTranslator does not sup-
port AAF files with embedded media. 
Pro Tools with DigiTranslator only sup-
ports AAF export with external file refer-
ences.

Pro Tools supports OMF files that contain 
embedded audio, but not OMF files that 
contain embedded video.
Chapter 1: Introduction 3
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Frame-Rate Accurate Video 
Editing and Sample-Rate Accurate 
Audio Editing

Avid Xpress Pro edits with frame accuracy. This 
means that in a 30-fps project, you can edit at 30 
different locations for every one second of 
video. Pro Tools edits with sample rate accuracy. 
In a 48-kHz session, there are potentially 48000 
locations to edit for every second of audio. 

When Pro Tools exports an AAF or OMF compo-
sition, it must ensure that the audio media files 
line up on frame boundaries. To do this, it 
might have to split an existing audio clip into 
three clips. For example, the following illustra-
tion shows a 5-frame video clip and a corre-
sponding audio clip. In Pro Tools, the audio 
clips might not line up on video frame bound-
aries.
Avid Xpress Pro Workflow Guide
In order to export frame accurate audio clips, 
Pro Tools splits the audio media on frame 
boundaries and fills any gaps with silence. The 
following illustration shows the resulting audio 
clips that are exported to Avid Xpress Pro.

When you use Export Selected Tracks as 
OMF/AFF to export tracks from Pro Tools, a 
number of additional media files appear in the 
bin. Some are named Sample accurate edit. 
These are the additional media files that 
Pro Tools creates to make sure that 
Avid Xpress Pro receives frame-accurate audio. 
You also see the sample-accurate edit media files 
if you zoom in on portions of the imported au-
dio in the Timeline.
Figure 1.  Original audio clip

One Pro Tools audio clip

5 frame video clip

The original audio clip does not line up on video frame boundaries
Figure 2.  Exported audio clip

Three exported audio clips

5 frame video clip

Exported audio clips line up on video frame boundaries

New audio clip with 
padded silence

New audio clip with 
padded silence
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Workflow
This workflow assumes you have Pro Tools and 
Avid Xpress Pro installed on the same com-
puter, and involves the following steps:

1  “Exporting Audio and Video from 
Avid Xpress Pro” on page 5

2  “Importing Audio and Video into Pro Tools” 
on page 7

3  “Editing Audio Files in Pro Tools” on page 9

4  “Exporting Audio from Pro Tools for Avid 
Xpress Pro” on page 9

Exporting Audio and Video 
from Avid Xpress Pro
Before you export, create a sequence with audio 
tracks as described in the Avid Xpress Pro Help. 
The following illustration shows a sequence 
with two audio tracks and two unrendered 
video effects.

Sequence with unrendered tracks
Using the Send To Templates

The Send To Templates option lets you create 
one metadata AAF or OMF file that references 
audio and video files used in the sequence, and 
save it to the drive selected in your Avid Prefer-
ences. 

To use the Send To Digidesign Pro Tools 
templates:

1  Start Avid Xpress Pro.

1  Select a sequence in a bin.

AAF exports ignore IN and OUT marks, but 
QuickTime exports do not. The default tem-
plates that create QuickTime movies auto-
matically deselect Use IN and OUT marks 
option.
Chapter 2: Workflow 5
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2  Choose File > Send To > Digidesign Pro Tools 
> Link to Audio and Video. 

3  If you want to view or change export settings, 
click either Options button, and then make any 
changes (such as switching from the default AAF 
to the OMF format). If you make any changes, 
you can use the Save As Template button to cre-
ate a new template.

4  Click Set.

5  Navigate to the location where you want the 
AAF or OMF files to reside.

6  Click OK.

Digidesign Pro Tools dialog

Avid Xpress Pro only recognizes audio and 
video files stored in the OMFI MediaFiles or 
the Avid MediaFiles folder.

This workflow assumes that you use the de-
fault values. This means that you are ex-
porting using the Project sample rate, audio 
file format, and sample bit depth.
Avid Xpress Pro Workflow Guide
Avid Xpress Pro performs the requested opera-
tions and exports the files to the destination 
folder. If Avid Xpress Pro has to render effects or 
perform audio file conversions, a new sequence 
appears in the bin with the name filename.Ex-
port.01, and a new audio master clip appears in 
the bin with the name filename.new.01.

Configuring Audio Settings for 
Your Pro Tools Session

To determine the audio settings to use for your 
Pro Tools session:

1  In Avid Xpress Pro, select the Project window 
and click the Settings tab.

2  Double-click Audio Project.

3  In the Audio Project Settings dialog, note the 
following, which you will need when you set up 
your Pro Tools session:

• Sample Rate

• Audio File Format

• Sample Bit Depth

The default Send To Pro Tools templates 
use the current Audio Project settings for the 
above values. If you changed the values 
when you performed the export, take note of 
those values.



                              
Importing Audio and Video 
into Pro Tools
This section explains the basic steps of import-
ing AAF or OMF sequences (or tracks from those 
sequences) into a Pro Tools session optimized 
for working with those files.

Importing an AAF or OMF 
Sequence as a Pro Tools Session

To open an AAF (or OMF) sequence as a Pro Tools 
session:

1  Launch Pro Tools.

2  Choose File > Open Session.

3  In the Open Session dialog, navigate to the 
AAF or OMF sequence you want to import.

4  Click Open.

5  Name your session in the Save As: field.

6  If you want to create session and audio files 
that can be used in either Windows or Macin-
tosh versions of Pro Tools, select Enforce 
Mac/PC Compatibility.

7  Select the Fader Gain (+12 dB or +6 dB).

Pro Tools New Session dialog
8  Select the I/O Settings to use for the session. 
Several pre-configured I/O Settings are included 
with your system, or you can select a custom I/O 
Setting that you have created.

9  Click Save.

10  In the Import Session Data dialog, do the fol-
lowing:

• Click on the Audio Media Options pop-up 
menu and select “Link to Source Media 
(Where Possible).”

– and –

• Click on the Video Media Options pop-up 
menu and select Link to source media.

11  Change other parameters, as desired. For 
more information, see “Exporting Audio from 
Pro Tools for Avid Xpress Pro” on page 9.

Pro Tools Import Session Data dialog
Chapter 2: Workflow 7
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12  Click OK.

Pro Tools will create a new Audio Files folder, a 
Fade Files folder, a Video Files folder, a 
cache.wfm file, and a session file where you 
have designated their locations. This session 
will match the audio file type, sample rate, and 
bit depth of the audio in the OMF or AMF you 
selected.

Importing Tracks from an AAF or 
OMF Sequence into a Pro Tools 
Session

You can import an AAF or OMF sequence into a 
Pro Tools session if the frame rate of the se-
quence matches the frame rate of the session.

To import tracks from an AAF (or OMF) sequence 
into an existing Pro Tools session:

1  Choose File > Import Session Data.

2  In the Open Session dialog, locate the AAF or 
OMF session you want to import.

Importing video into an existing Pro Tools 
session will replace any older video already 
occupying the session.
Avid Xpress Pro Workflow Guide
3  Click Open.

4  In the Import Session Data dialog, do the fol-
lowing:

• Click on the Audio Media Options pop-up 
menu and select “Link to Source Media 
(Where Possible).”

– and –

• Click on the Video Media Options pop-up 
menu and select Link to source media.

5  For information on other parameters, see “Ex-
porting Audio from Pro Tools for Avid 
Xpress Pro” on page 9.

6  Click OK.

7  If the source media has a different frame rate 
than the session (and if the session does not al-
ready contain any video), Pro Tools prompts 
you to allow it to change the frame rate for the 
session to the media frame rate. (Click OK.)

Pro Tools Import Session Data dialog



                   
8  If your audio source media is on a volume that 
is not suitable for playback (shown as a Transfer 
volume in the Workspace browser), Pro Tools 
displays a dialog that guides you to copy the me-
dia to a volume designated for Playback or 
Record. (Click Yes.)

If you import a video file, Pro Tools creates a 
track for the movie in the timeline and displays 
the movie on your video monitor.

Now you are ready to edit the audio files in 
Pro Tools.

Editing Audio Files in 
Pro Tools
Pro Tools does not alter the original audio files 
created in the Avid Xpress Pro sequence. When 
you use Pro Tools to perform a destructive edit 
(such as using AudioSuite processing to replace 
the original sound) to one of the original files, it 
creates a new copy of the file and leaves the orig-
inal untouched.

Exporting Audio from 
Pro Tools for Avid Xpress Pro
In Pro Tools, you can export audio tracks for use 
in Avid Xpress Pro using any of the following 
commands:

• Export Selected Tracks as OMF/AAF

• Bounce to Disk

• Export Selected as Files

For other export methods, see the Pro Tools Ref-
erence Guide.

See the Pro Tools Reference Guide for de-
tailed information on editing audio files in 
Pro Tools.
Exporting Tracks as AAF/OMF 
Sequences

Use Export Selected Tracks as OMF/AAF to ex-
port individual tracks or an entire Pro Tools ses-
sion in AAF or OMF format.

To export selected audio tracks from Pro Tools as 
an AAF (or OMF) sequence:

1  In Pro Tools, select the tracks in the Pro Tools 
session by Shift-clicking the names of each 
track.

2  Choose File > Export Selected Tracks as 
OMF/AAF.

Tracks are exported in their entirety and 
time selections are ignored.

Volume and pan automation is not retained 
on export if Quantize Edits to Frame Bound-
aries is enabled (Avid Compatibility Mode).

The Movie track cannot be exported to AAF 
or OMF from Pro Tools.

Selecting a track in Pro Tools
Chapter 2: Workflow 9
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3  Under OMF/AAF Options, choose AAF (or 
OMF) from the Export As pop-up menu, and se-
lect Enforce Avid Compatibility.

4  Check that the Target project time code for-
mat is correct for the Avid Xpress Pro project. 

5  Under the Audio Media Options section, en-
sure that the Audio format and Audio bit depth 
match your Avid Xpress Pro Audio settings.

6  Click OK. 

7  In the Publishing Options dialog, type the 
Pro Tools Comment and Sequence Name. 

8  Click OK.

Enforce Avid Compatibility limits the sam-
ple rate options to 44.1 or 48 kHz. Dither-
ing without noise shaping will be applied to 
files being exported from 24-bit to 16-bit.

Pro Tools Export to OMF/AAF dialog

Pro Tools Publishing Options dialog
Avid Xpress Pro Workflow Guide
Pro Tools will create a sequence with the name 
you supply. (The Pro Tools comment appears in 
the Avid Xpress Pro bin in a Pro Tools Com-
ment column.)

9  In the Name the AAF/OMFI File to Export di-
alog, navigate to a folder where you can easily 
locate the Pro Tools composition when it is time 
to import it into Avid Xpress Pro.

10  Click Save.

11  In the Please Choose a Folder for Converted 
Audio Files dialog, navigate to the OMFI Media-
Files folder on an applicable drive.

12  Click Choose.

Pro Tools exports the composition to the de-
sired folder, and exports the related media to the 
OMFI MediaFiles folder.

13  If you are ready to import the files into 
Avid Xpress Pro, exit Pro Tools.

Pro Tools Name the AAF File to Export dialog (OMFI 
dialog not shown)

Navigating to the OMFI MediaFiles folder



To import a sequence into Avid Xpress Pro:

1  Quit Pro Tools if it is open.

2  Start Avid Xpress Pro.

3  Select a bin where you would like to import 
the sequence.

4  Choose File > Import.

5  In the Select Files to Import dialog, choose 
one of the following options from the Enable 
pop-up menu:

• AAF Documents (if you are importing AAF)

– or –

• OMFI Documents (if you are importing 
OMF)

6  Navigate to the folder that contains the ex-
ported Pro Tools composition, and select Files of 
Type > OMFI or AAF.

7  Select the AAF or OMF file.

8  Click Open. 

The new sequence appears in the selected bin, 
along with a number of related audio clips.

9  Drag the sequence to the Source monitor, and 
then play the sequence to listen to the audio. 

10  Drag the original video sequence into the 
Record Monitor (if it is not already there).

You might find it useful to designate a bin 
for imports and then copy the sequence to 
the bin you are working in. This can help re-
duce the number of files in your working 
bin. You can close the bin containing the 
additional media files, but do not delete the 
files because they are needed for the se-
quence.
11  If you need to add more tracks for the im-
ported sequence, choose Clip > New Audio 
Track. 

12  Edit the imported tracks into the Timeline.

Exporting AAF or OMF Files Using 
Bounce to Disk

Use the Bounce to Disk command to create pre-
mixed files of the current Pro Tools session. This 
does not export all of the individual files on the 
Timeline, but it does guarantee that the audio in 
Avid Xpress Pro will be identical to the audio in 
Pro Tools, including all panning, effects and au-
tomation.

To export to AAF (or OMF) using Bounce to Disk:

1  In Pro Tools, finalize the mix.

2  Create and select the time range of the se-
quence that you want to export. (All audible 
tracks in that time range will be included in the 
bounce, whether they are selected or not.)

3  Choose File > Bounce to Disk.

4  Select Publish as OMFI.

5  Select Enforce Avid Compatibility.

6  Click Bounce.

7  In the Publishing Options dialog, type the 
Pro Tools Comment and Clip Name.

You might find it useful to leave the origi-
nal audio tracks in place to compare syn-
chronization with the imported sequence.

Enforce Avid Compatibility limits the sam-
ple rate options to 44.1 or 48 kHz. Dither-
ing without noise shaping will be applied to 
files being exported from 24-bit to 16-bit.
Chapter 2: Workflow 11
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8  Click OK.

All audible audio in the selection will be ex-
ported to two multi-mono audio files.

9  In the Save Bounce As dialog, choose the 
OMFI Media folder on the valid audio drive 
where you want to save the files.

10  Click Save.

To import the files into Avid Xpress Pro using the 
Media Tool:

1  Start Avid Xpress Pro.

2  Select the bin that you want to hold the im-
ported master clip.

3  Choose File > Refresh Media Directories.

Audio Import Bounce window

This command updates the media data-
base. If you do not use this command, the 
clip may not appear in the Media Tool.
Avid Xpress Pro Workflow Guide
4  Choose Tools > Media Tool.

5  In the Media Tool window, select the drive 
that you used to export the files from Pro Tools.

6  Click All Projects, and make sure that Master 
Clips is selected.

7  Click OK.

The Media Tool displays all the master clips on 
the selected drive.

8  Locate the master clip for the files you ex-
ported from Pro Tools.

9  Drag the master clip to your bin.

10  Edit the master clip into your sequence.

Media Tool
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