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chapter 1

Introduction
Digidesign MachineControl™ is special purpose 
software for Pro Tools® TDM systems that en-
ables serial communication with Sony® 9-pin or 
Videomedia® V-LAN™ compatible video or au-
dio machines.

This guide provides installation and operational 
instructions for MachineControl version 2.0 
only (Pro Tools 6.0 and higher on Macintosh, 
and Pro Tools 6.1 and higher on Windows).

If you are using Pro Tools version 5.3.3 or lower, 
see the MachineControl 1.1 Guide included with 
your MachineControl package. 

MachineControl Components

Your MachineControl package includes:

◆ MachineControl Installer CD-ROM

◆ One serial to 9-pin Serial Control cable 
(male 9-pin)

◆ One serial to 9-pin Remote Mode cable
(female 9-pin)

◆ MachineControl iLok License Card 
MachineControl Capabilities
On all supported Pro Tools systems, Machine-
Control provides the following features and 
modes of operation:

Transport Master The Pro Tools Transport win-
dow lets you select Pro Tools or a machine as the 
transport master. 

◆ When Transport = Pro Tools, the machine 
play start point is determined by the current 
Pro Tools timeline location. The machine pre-
roll setting is applied, to ensure Pro Tools locks 
to time code at the timeline location or selec-
tion. 

◆ When Transport = Machine, the machine play 
start point is determined by the current ma-
chine location. The machine pre-roll setting and 
the Pro Tools timeline selection do not affect 
machine location in this mode.

Cueing, Scrubbing, and Pre-Roll Preference set-
tings let you optimize MachineControl opera-
tion, including adjustable machine pre-roll, se-
lectable edit and memory location chasing. 

With Pro Tools|HD, a SYNC I/O is required 
for frame edge-accurate synchronization. 
With Pro Tools|24 MIX, either a SYNC I/O 
or Universal Slave Driver (USD) is required 
for frame edge accuracy. 
Chapter 1: Introduction 1
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Modes of Operation

MachineControl supports two machine com-
munication modes: Serial Control mode and Re-
mote 9-Pin Deck Emulation mode. These modes 
require a Digidesign SYNC I/O or Universal 
Slave Driver (USD). 

Serial Control Mode

When used with a SYNC I/O or USD, Serial Con-
trol mode provides the following features:

Track Arming Lets you arm tracks of external 
machines from within Pro Tools, for layback 
and transfer configuration. Features include in-
dividual record enables for up to 48 external 
tracks, with selectable record protocol and 
mode. Included machine profiles let you pre-
configure track arming for most machine types. 

Serial Time Code Lets Pro Tools not only control 
an external machine, but also receive time code 
position using only the serial cable. (This mode 
requires that the 9-pin device be capable of 
transmitting serial time code.)

Remote 9-Pin Deck Emulation Mode

Remote 9-Pin Deck Emulation mode enables 
Pro Tools to operate in VTR emulation mode. 
This lets an external 9-pin machine control 
playback, cueing, and record-arming of tracks in 
Pro Tools.

Remote 9-pin Deck Emulation mode requires a 
Digidesign SYNC I/O (for Pro Tools|HD systems) 
or USD (for Pro Tools|24 MIX and Pro Tools|24 
systems), and use of the special Remote Mode 
cable. 
MachineControl Guide
System Requirements
◆ Pro Tools|HD-series, Pro Tools|24 MIX-series, 
or Pro Tools|24 system, running on a Digide-
sign-qualified computer and version of Win-
dows or Mac OS

◆ Digidesign SYNC I/O (for Pro Tools|HD, 
Pro Tools|24 MIX, or Pro Tools|24)

– or –

◆ Digidesign USD (for Pro Tools|24 MIX or 
Pro Tools|24)

◆ For Remote 9-Pin Deck Emulation mode, an 
available computer serial port (or COM port) is 
required. All other MachineControl features are 
supported through the 9-pin ports on the 
SYNC I/O.

Computers without a serial port require a USB-
to-Serial adapter.

If you are not using a SYNC I/O or USD with 
Pro Tools, some features of MachineControl can 
be used by connecting to the DigiSerial port on 
a Pro Tools Core card.

Compatibility Information
Digidesign can only assure compatibility and 
provide support for hardware and software it 
has tested and approved. 

For a list of Digidesign-qualified computers, op-
erating systems, hard drives, and third-party de-
vices, refer to the latest compatibility informa-
tion on the Digidesign Web site 
(www.digidesign.com/compato).



                  
About This Guide
This guide assumes:

• You have installed Pro Tools and verified that 
it works properly

• You have a thorough understanding of your 
video deck, external 9-pin decks, mixer, and 
other audio and video equipment

• You have an understanding of your synchro-
nization equipment and requirements

Conventions Used in This Guide

This guide uses the following conventions to in-
dicate menu choices and key commands:

The following symbols are used to highlight im-
portant information:

Convention Action

File > Save Session Choose Save Session from 
the File menu

Control+N Hold down the Control key 
and press the N key

Control-click Hold down the Control key 
and click the mouse button

Right-click (Windows) Click with the right mouse 
button

User Tips are helpful hints for getting the 
most from your system.

Important Notices include information that 
could affect your data or the performance of 
your system.

Cross References point to related sections in 
other Digidesign Guides.
MachineControl and Pro Tools 
Versions
This guide documents features available in 
Pro Tools version 6.0 and later. Though Machi-
neControl can be used with some earlier releases 
of Pro Tools software, not all features are avail-
able in each version. 

The following table lists the versions of 
Pro Tools supported by MachineControl, along 
with the major features added in each Machine-
Control release. 

Digidesign Registration
Make sure to complete and return the registra-
tion card included with MachineControl. Regis-
tered users will receive periodic software update 
and upgrade notices. Refer to the registration 
card for information on technical support.

History of MachineControl Features in Pro Tools

Machine-
Control 

Pro Tools Features Introduced

2.0 6.0 or 
higher

Remote Mode Chase 
LTC, Redefine Current 
Time Code Location, 
Track Arming Profiles

1.1 5.3.1 Support for 
Pro Tools|HD and the 
SYNC I/O

1.0 5.1 or 
higher 

9-pin Remote Deck 
Emulation mode

1.0 5.0 or 
higher

Support for Serial 
TIme Code as posi-
tional reference

1.0 4.3 or 
higher

Track Arming of 
Remote Decks

1.0 4.1.1 or 
higher

Original release
Chapter 1: Introduction 3
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chapter 2

Installing and Configuring MachineControl
Before you Begin

Before you install MachineControl, make sure 
that you have already connected and verified 
operation of your Pro Tools system.

If you are using a SYNC I/O or Universal Slave 
Driver (USD), refer to its guide to make sure your 
equipment is installed and operating correctly. 

Cables and Connections
MachineControl comes with the following two 
cables: 

• Serial Control Cable, a male 8-pin mini-DIN 
to male 9-pin cable, for serial time code and 
all other MachineControl functions.

• Remote Deck Emulation Mode 9-Pin Cable, a 
male 8-pin mini-DIN to female 9-pin cable, re-
quired for VTR emulation.

MachineControl requires its own connections 
between Pro Tools hardware, the computer, and 
external machines. Connections differ depend-
ing on your Pro Tools hardware, and on which 
of the two MachineControl operational modes 
you want to use: Serial Control mode or Remote 
9-Pin Deck Emulation mode. 

Do not substitute 9-pin or serial adaptors 
for either MachineControl cable. Each cable 
is specifically wired for one operation mode.
Serial Control Mode

Serial Control mode supports bi-directional 
communication between Pro Tools and a com-
patible external machine. Features include the 
ability to synchronize to serialized time code, 
arm tracks on the machine remotely, control 
multiple transports from Pro Tools, and config-
ure machine settings and options.

Pro Tools HD

On HD-series systems, you can use a Serial to 9-
pin connection or a 9-pin to 9-pin connection 
for Serial Control Mode. 

Serial to 9-pin connection This type of connec-
tion yields the best performance, especially with 
linear decks. If you are not using a SYNC I/O, 
you can use the included Serial Control cable for 
this type of connection.

9-pin to 9-pin connection This type of connec-
tion is suitable for non-linear decks. If you are 
using a SYNC I/O, as many as two machines can 
be connected to the two 9-pin Out ports on the 
SYNC I/O. You can control one machine at a 
time, and switch between them from within 
Pro Tools. These ports support all MachineCon-
trol modes except Remote 9-Pin Deck Emulation 
mode. 
Chapter 2: Installing and Configuring MachineControl 5
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Pro Tools|24 MIX and Pro Tools|24

On Pro Tools|24 MIX and Pro Tools|24 systems, 
a Serial to 9-pin connection is required for Serial 
Control mode. (Use of the 9-pin Out ports on 
the SYNC I/O is not supported with 
Pro Tools|24 MIX or Pro Tools|24 systems.)

If you are not using a SYNC I/O or USD, you can 
use the included Serial Control cable for Serial 
Control mode.

Remote 9-Pin Deck Emulation 
Mode

This mode enables a form of VTR emulation in 
Pro Tools. When the Remote Deck Emulation 
Mode 9-pin cable is used on a supported system, 
Pro Tools can respond to record-arming, trans-
port, and other standard 9-pin commands from 
an external machine. 

While in Remote 9-Pin Deck Emulation mode, 
Pro Tools always generates time code, and can 
be either the timecode master or a slave device.

Remote 9-pin Deck Emulation mode uses a Se-
rial to 9-pin connection (female). This mode re-
quires a computer serial port (or serial adapter 
connected to a computer USB port), and use of 
the included Remote Deck Emulation Mode 9-
pin cable. See Chapter 4, “Remote 9-Pin Deck 
Emulation Mode” for details.
MachineControl Guide
Connecting Machines
Separate instructions follow for Pro Tools|HD 
and Pro Tools|24 MIX systems. Follow the in-
structions that correspond to your system. 

Pro Tools|HD Systems

Serial Control Mode

To connect a machine for Serial mode, do one of 
the following:

◆ Connect the Serial Control (male 9-pin) cable 
from an available serial or COM port (or serial 
adapter connected to a computer USB port) to 
the 9-pin input on the machine. This configura-
tion usually yields the best performance, espe-
cially with linear decks.

◆ Connect a standard 9-pin cable from one of 
the 9-pin Out ports on the SYNC I/O to the 9-
pin input of the machine. Due to performance 
limitations, this configuration should be used 
primarily with non-linear decks.

Remote 9-Pin Deck Emulation Mode

To connect a machine for Remote 9-Pin Deck 
Emulation mode:

■ Connect the Remote Deck Emulation Mode 9-
Pin cable (male 8-pin mini-DIN to female D9) 
from an available serial or COM port on your 
computer (or serial adapter connected to a com-
puter USB port) to the 9-pin output of the ma-
chine.

Do not use the DigiSerial port on your HD Core 
card for Remote 9-Pin Deck Emulation mode. 
This port should only be used for SYNC I/O con-
nection, using a DigiSerial cable.



   
Pro Tools|24 MIX and Pro Tools|24 
Systems

Serial Control Mode

To connect a machine for Serial mode:

■ Connect the Serial Control (male 9-pin) cable 
from an available serial or COM port (or serial 
adapter connected to a computer USB port) to 
the 9-pin input on the machine.

Remote 9-Pin Deck Emulation Mode

To connect a machine for Remote 9-Pin Deck 
Emulation mode:

■ Connect the Remote Deck Emulation Mode 9-
Pin cable (male 8-pin mini-DIN to female D9) 
from an available serial or COM port on your 
computer (or serial adapter connected to a com-
puter USB port) to the 9-pin output of the ma-
chine.

Do not use the DigiSerial port on your Pro Tools 
Core card for Remote 9-Pin Deck Emulation 
mode. 
Installing MachineControl 
Software 
To install MachineControl, use the Pro Tools In-
staller CD-ROM, the MachineControl Installer 
CD–ROM, or download the installer from the 
Digidesign Web site.

To install MachineControl:

1  Locate and double-click the MachineControl 
Installer.

2  Select the install option for your system 
(Pro Tools|HD or Pro Tools|24 MIX/Pro 
Tools|24).

3  Click Install.

4  Follow the on-screen instructions to complete 
installation.
Chapter 2: Installing and Configuring MachineControl 7
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Starting Up Your System
To ensure that the components of your 
Pro Tools system communicate properly with 
each other and your external machines, start 
them in a particular order.

Start up your Pro Tools system in this order:

1  For systems with an expansion chassis, turn 
on the chassis.

2  Turn on any external hard drives. Wait ap-
proximately ten seconds for them to come up to 
speed.

3  Turn on any external machines (VTR, ATR, 
synchronizer, and monitors). 

4  Turn on any MIDI interfaces, MIDI devices 
and synchronization peripherals.

5  Lower the volume of all output devices in 
your system.

6  Turn on Pro Tools audio interfaces. Wait at 
least fifteen seconds for your system hardware to 
initialize. 

7  Turn on your computer.

8  Launch Pro Tools. 

Machine Local and Remote Modes

Be sure to set your machine-controllable device 
to “remote” or “ext” mode to receive the 9-pin 
or V-LAN information (not “local” or front-
panel mode). With some supported machines, if 
all other communication is established and the 
machine is not in remote mode, Pro Tools will 
indicate machine “local” mode.
MachineControl Guide
Authorizing MachineControl
The MachineControl option is authorized using 
the iLok USB Smart Key from PACE Anti-Piracy. 
The iLok is similar to a dongle, but unlike a don-
gle, it is designed to securely authorize multiple 
software applications from a variety of software 
developers.

One iLok USB Smart Key is included with 
Pro Tools|HD Core systems. This key can hold 
over 100 authorizations for all of your iLok-en-
abled software. Once a software authorization is 
added to an iLok USB Smart Key, you can use the 
iLok to authorize that software on any com-
puter.

Authorizations are added to an iLok using Li-
cense Cards that have a small punch-out GSM 
plastic chip. A License Card is included with Ma-
chineControl software.

If you do not have an iLok USB Smart key, 
you can purchase one from the Digidesign 
online store at www.digidesign.com.



To add an authorization to an iLok:

1  Insert the iLok into an available USB port on 
your computer.

2  Launch Pro Tools. You will be prompted to au-
thorize MachineControl.

3  Follow the on-screen instructions until you 
are prompted to insert the License Card into the 
iLok.

4  Separate the License Card—the smaller GSM 
cutout—from the larger protective card by pull-
ing the cutout up and out with your thumb. 

5  Insert the License Card into the iLok, making 
sure the arrows on the License Card are pointing 
towards the iLok. You should be able to visually 
verify that the License Card makes contact with 
the iLok’s metal card reader.

6  Follow the on-screen instructions to complete 
the authorization process.

7  After authorization is complete, remove the 
License Card from the iLok. (If you have to re-
move the iLok to remove the License Card, be 
sure to re-insert the iLok in any available USB 
port on your computer.)

If you are already using MachineControl in 
Demo mode, launch Pro Tools before you 
insert the iLok, then insert the iLok into any 
available USB port when prompted by 
Pro Tools.

iLok with License Card
Configuring Pro Tools for 
MachineControl
This section covers the basic steps for setting up 
MachineControl in Serial Control mode. For de-
tails on Remote 9-pin Deck Emulation mode, see 
Chapter 4, “Remote 9-Pin Deck Emulation 
Mode.”

To set up a MachineControl device:

1  In Pro Tools, choose Setups > Peripherals, and 
click the Synchronization tab. Configure your 
synchronization peripheral as necessary. If you 
are using a SYNC I/O, it is automatically de-
tected and configured by Pro Tools.

2  Click the Machine Control tab in the Periph-
erals window.

3  In the 9-pin Serial section, click Enable.

4  Use the Port pop-up menu to select the 9-pin 
or V-LAN MachineControl port. The available 
choices will depend on your platform and con-
figuration. 

5  If necessary, select the appropriate machine 
type (Sony 9-pin or V-LAN) from the Machine 
Type pop-up menu.

Configuring MachineControl for 9-pin Serial Control
Chapter 2: Installing and Configuring MachineControl 9
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After you select a port, Pro Tools automatically 
polls the port to see what kind of machine is 
connected. This process is referred to as auto de-
tection. One of the following will occur:

◆ If the machine is recognized, Pro Tools loads 
the corresponding Machine Type and Node. 
This includes the corresponding track layout 
and automatically enters the name of that ma-
chine into the Pro Tools Machine Track Arming 
window. 

◆ If the machine is not recognized, the 
“generic1” personality is automatically loaded. 

6  If you want to choose a different machine pro-
file (for example, to use a different track layout), 
choose it from the Node pop-up menu. 

7  Set the machine pre-roll (see “Machine Pre-
Roll” on page 10 for more information).

8  If you are using a SYNC I/O with 
Pro Tools|HD, and if you have two machines 
connected to the two 9-pin Out ports on the 
SYNC I/O, repeat the above steps for the second 
machine. See “Selecting Machines in Serial Con-
trol Mode” on page 17 for more information.

9  Click OK to close the Peripherals dialog box. 

To configure and use MachineControl features 
in Pro Tools, see Chapter 3, “Serial Control 
Mode and Transport Control.”

Pro Tools lets you define and save custom 
machine profiles. See Chapter 5, “Remote 
Track Arming” for more information. 

Do not use the designated machine port for 
any other function (such as time code or 
MIDI metronome). Make sure that 9-pin or 
V-LAN is the only communication on the 
selected port. 
MachineControl Guide
Machine Pre-Roll

You can set a variable amount of machine pre-
roll to account for the time it may take the ma-
chine to achieve servo lock. Shorter pre-roll val-
ues are usually better for non-linear machines. 
Longer pre-roll values are usually better for older 
tape transports.

The Machine pre-roll value is added to any pre-
roll specified in the Pro Tools Transport window.

To set MachineControl pre-roll:

1  In Pro Tools, choose Setups > Peripherals, and 
click the Machine Control tab.

2  In the 9-pin Serial section, enter the number 
of frames of pre-roll.

3  Click OK. 



Session Setup for MachineControl 

The Session Setup window provides session time code settings and options, as well as session status 
displays. 
Figure 1.  Session Setup window

Clock Source

Session displays 
and settings

SYNC Setup

Time Code 
settings

Session Offsets

click to show/hide 

click to show/hide
Session Setup window controls are organized 
into three sections. The Session controls are al-
ways displayed at the top of the Session Setup 
window. The Synchronization and Session Off-
sets section and the Time Code Settings section 
can be shown or hidden by clicking the corre-
sponding show/hide buttons.

SYNC (or USD) Setup Settings

To show SYNC or USD Setup Settings:

■ Click the SYNC Setup and Session Offsets 
show/hide button. 

This section lets you configure controls of the 
Digidesign SYNC I/O or USD. Settings are pro-
vided for Clock and Positional Reference, Video 
Format, and Variable Speed Override. 
Session Settings and 
MachineControl
Use the steps in this section to quickly configure 
the basic session settings for MachineControl. 
These include session settings (start time, frame 
rate, and video format), as well as synchroniza-
tion settings for clock and positional reference. 
Additional options include multiple time code 
display offsets, generator, freewheel, and pull up 
and pull down settings. 
Chapter 2: Installing and Con
figuring MachineControl 11
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Basic Session Settings

Confirm the following settings for each session. 

To configure a session for MachineControl:

1  Choose Windows > Show Session Setup.

2  In the Status and Display section, do the fol-
lowing: 

• Set a Session start time. 

• Set the appropriate session frame rate.

3  In the SYNC Setup section, set the appropriate 
format for NTSC or PAL using the Frame Rate 
and Video Format selectors. 

Basic session settings in the Session Setup window

Video Format selector

Incoming Time display

Session Start Time

Frame Rate

click to 
show/hide

Video Format
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Clock Source, Clock and Positional 
Reference

The Session Setup window provides selectors for 
the system Clock Source, as well as Clock and 
Positional Reference. These settings must be 
configured based on the signal connections be-
tween Pro Tools, the SYNC I/O, and external de-
vices. 

To configure Clock Source and Reference 
settings, do one of the following:

Pro Tools|HD In Session Setup, choose an appro-
priate Clock Source (the SYNC I/O, or an HD-se-
ries audio interface). Configure the Clock Refer-
ence and Positional Reference menus as 
appropriate. See the SYNC I/O Guide for more in-
formation.

Pro Tools|24 MIX or Pro Tools|24 Set the Ch 1–2 
Input and session Sync Mode as necessary. (Sync 
Mode must be set to analog for the SYNC I/O or 
USD to be clock master.)

Testing Basic Session Settings

To check your session and MachineControl set-
tings, place the machine in Local mode and 
manually start playback on the external ma-
chine. If Pro Tools is receiving time code, the 
current location will be shown in the Incoming 
Time display. Be sure to reset the machine to Re-
mote mode when finished. 

Incoming Time display

Incoming Time display



Session Start Offsets

With Pro Tools 6 and higher, you can offset the 
display of incoming time code in the Pro Tools 
application. This is useful when you want to ad-
just the display of time code to match the start 
time of the session (such as with source material 
that starts at a different time), or compensate for 
source material that is consistently offset by a 
fixed number of frames (such as with some 
color–corrected video masters). 

Pro Tools provides three different types of Ses-
sion Start Time Code Offset settings. These off-
sets include:

• MMC (MIDI Machine Control)

• 9-Pin (Serial machine control)

• Synchronization peripherals such as the 
SYNC I/O, USD, or other peripherals (for ex-
ample, MIDI interfaces that provide MIDI 
Time Code). 

Unique values can be defined for each of these 
three types offsets, or you can link all three to 
adjust in unison. 

Positive and negative offset values can be en-
tered to offset Pro Tools time code display later 
or earlier, respectively. 

Offsets and Time Code Displays

The SYNC I/O (or USD) Time Code Display con-
tinues to display actual incoming time code, re-
gardless of any Session Start Offset applied in 
Pro Tools.
To apply an offset to the session start time:

■ In the Session Setup window, enter a new Ses-
sion Start time in an offset field. 

To apply the same session start time to all 
devices:

■ In the Session Setup window, select Link to 
apply the same offset value to all devices. 

Time Code Settings

The Time Code settings control time code gen-
eration, Freewheel, and session Pull Up and Pull 
Down options.

Configure these settings as appropriate for the 
current project and situation. (For complete in-
structions, refer to the Pro Tools Reference Guide 
and the SYNC I/O Guide.)

Time Code Reader Offset

The Time Code Reader Offset lets you set a “trig-
ger offset” for incoming MIDI Time Code, in 
samples. (In previous versions of Pro Tools, this 
feature was called Sync Offset.) You can use Time 
Code Reader Offset to compensate for the la-
tency of a MIDI sound module or other MIDI de-
vice chain. 

Session Start Offsets in the Session Setup window
Chapter 2: Installing and Configuring MachineControl 13
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Additional Commands and 
Features
The following commands are available in all 
MachineControl operating modes. 

Redefine Current Time Code Position

The Redefine Current Time Code Position com-
mand lets you redefine the session start time. By 
creating an insertion point (or selection) and 
then entering a new time code value for that lo-
cation, the session start time will be recalculated 
based on the new, relative time code location. 

For example, if you place an insertion point at 
01:02:04:11, select Edit > Redefine Current Time 
Code Position, and enter 01:00:08:00 to corre-
spond to the first frame of film, this adjusts the 
session start time such that the insertion point 
location is now 01:00:08:00.

To redefine the current time code location:

1  Enable Link Edit/Timeline. 

2  Locate Pro Tools to the beginning of the rele-
vant material (usually the first audio of a scene, 
a 2 pop, or similar). 

3  If appropriate, cue the external time code 
source to the appropriate location (this will be 
the location to which you want to align the cur-
rent Pro Tools insertion point). Note the time 
code location, or copy it to the clipboard. 
MachineControl Guide
4  Choose Edit > Redefine Current Time Code 
Position. 

5  Enter the new time code position.

6  Click OK. 

Create Machine Track Arming Profile

The Create Machine Track Arming Profile com-
mand lets you create and save machine descrip-
tions as Machine Profiles. Profiles are provided 
for an ever-increasing list of common machines, 
or you can customize profiles for specific situa-
tions and requirements. Options include the 
ability to emulate a different machine type, 
remap and rename audio tracks, and choose to 
include or exclude the video and time code 
tracks, when available. For more information, 
see “Creating a Track Arming Profile” on 
page 30. 

Redefining the current time code position
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Serial Control Mode and Transport Control
Serial Control mode is available whenever Ma-
chineControl is connected using the Serial Con-
trol cable. For more information about connect-
ing and configuring Pro Tools for Serial Control 
mode, see Chapter 2, “Installing and Configur-
ing MachineControl.” 

When connected for Serial Control mode, Ma-
chineControl enables all Pro Tools track arm-
ing, synchronization, and transport features, as 
available on your system. Serial Control mode 
also supports 9-Pin serial time code (see “Serial 
Time Code” on page 20). Some features require 
a SYNC I/O or USD, as noted throughout this 
chapter.

Track arming is explained in Chapter 4, 
“Remote 9-Pin Deck Emulation Mode.”
Online and Offline Operation

Pro Tools can remotely control, or be controlled 
by, any enabled external source or device. That 
device is selected using the Transport Master se-
lector in the Pro Tools Transport window. 

To trigger Pro Tools playback or recording from 
an external source, or to generate time code, the 
Pro Tools Transport needs to be online. There are 
four ways to put the Pro Tools Transport online:

• Click the Online button in the Transport win-
dow.

• Choose Operation > Online.

• Press Control+J (Windows) or Command+J 
(Macintosh).

• Press Alt+Spacebar (Windows) or Option+Spa-
cebar (Macintosh). 

The Online button in the Transport window in-
dicates online status. It flashes while enabled 
and waiting for synchronization, and stays lit 
when lock is achieved. 

Transport controls

Online button

Transport Master and machine Online selectors
Chapter 3: Serial Control Mode and Transport Control 15
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Preferences for Serial Control 
Mode
Preferences are available to specify the following 
aspects of MachineControl behavior. 

Record and Chase Settings

The following Preferences select record and 
chase options available while working with ex-
ternal time code, including:

◆ Preferences for Record Online at Time Code (or 
ADAT) Lock and Record Online at Edit Insertion/Se-
lection. 

◆ Preferences for Machine Chases Memory Loca-
tions and Machine Follows Edit Insertion/Scrub. 

To change Record or Chase Preferences:

1  Choose Setups > Preferences, and click the Op-
eration tab. 

2  Select one of the following options or con-
trols: 

Online Options

Record Online at Time Code (or ADAT) Lock On-
line recording begins as soon as Pro Tools re-
ceives and locks to time code.

Record Online at Edit Insertion/Selection  On-
line recording begins at the current Edit selec-
tion start or playback location. 

Machine preferences, in the Operation tab
MachineControl Guide
Machine Control Options

Machine Chases Memory Location The machine 
chases Pro Tools memory location selections. 
The machine will not locate with pre-roll, but 
will instead park on the desired frame for Auto 
Spotting. 

Machine Follows Edit Insertion/Scrub Pro Tools 
sends locate commands to the external deck 
whenever the timeline selection changes.

Machine Cues Intelligently When enabled, if you 
navigate to a cue point that is more than 10 sec-
onds from the current location, Pro Tools will 
command a connected transport to shuttle to 
the desired location at full speed, to within 10 
seconds of the cue point. Cueing will then slow 
to normal speed until the point is reached. 

Stop At Shuttle Speed Zero When enabled, 
Pro Tools sends a Stop command when shuttle 
speed equals zero. While most machines auto-
matically stop when shuttle speed is equal to 
zero (in other words, whenever you stop shut-
tling), some machines require an explicit stop 
command to park correctly. Consult the manu-
facturer of your machine if you need to deter-
mine its shuttle stop capability. 

Delay before Locking to LTC Lets you enter a 
number of frames for Pro Tools to wait upon re-
ceiving incoming LTC, before attempting to 
lock to the incoming time code signal. This de-
lay gives a variable amount of frames for the 
LTC source to stabilize. This lets Pro Tools lock 
more accurately to any fluctuations that can oc-
cur when some LTC sources are first engaged. 

Other MachineControl Preferences are lo-
cated in the Remote Mode section of the Op-
eration Preferences. These settings are ex-
plained in Chapter 4, “Remote 9-Pin Deck 
Emulation Mode.”



Serial Control Mode

Selecting Machines in Serial 
Control Mode

When using the Digidesign SYNC I/O with two 
machines connected to its 9-pin ports, use the 
Peripherals dialog to choose a deck to control. 

To choose machines for Serial Control mode:

1  In Pro Tools, choose Setups > Peripherals, and 
click the Machine Control tab. 

2  In the 9-Pin Serial section, click Enable to en-
able 9-pin Serial Control mode. 

3  Select the port for your first machine, if neces-
sary (9-pin #1 of the SYNC I/O). MachineCon-
trol will auto-detect and select the machine type 
it finds connected to the selected port. 

4  If necessary, select a different Machine Type 
that better matches your device. 

5  Repeat the above steps to auto-detect and se-
lect any machine connected to 9-pin #2 on the 
SYNC I/O (select 9-pin port #2 in the 9-Pin Serial 
Port selector). 

6  When the appropriate machine is enabled and 
selected, enable Use Serial Time Code for Posi-
tional Reference. 
Transport Controls

With MachineControl, the Pro Tools Transport 
window becomes a multi-function controller. 

Counter Display

The Pro Tools Edit window counter displays the 
current machine (9-pin) or session time code lo-
cation, depending on which device is the trans-
port master, plus any current Session Start Time 
Offsets being applied. (See “Session Start Off-
sets” on page 13 for more information. 

The Incoming Time display in the Session Setup 
window always shows absolute incoming time 
code, without any offsets. 

To select a Transport Master:

1  Click the Transport Master selector (directly 
below the Online button in the Transport win-
dow) to display the Transport Master pop-up 
menu. 

2  From the Transport Master pop-up menu, se-
lect Pro Tools, Machine, or Remote.

Selecting the Transport master

You can also press Control+backslash (\) to 
toggle between Pro Tools, the Machine, and 
Remote transport (or, on a Digidesign con-
trol surface, press EXT TRANS). 

Transport Master Selector

Online button
Chapter 3: Serial Control Mode and Transport Control 17
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Transport = Pro Tools

In this mode, the controls in the Transport win-
dow are focused on Pro Tools playback and re-
cording.

◆ When the transport is online, the machine 
slaves to Pro Tools, and the session locks to the 
machine’s time code. The machine follows Pref-
erences for Machine Chase and Online Record 
(see “Record and Chase Settings” on page 16).

◆ When the transport is offline, the Pro Tools 
Transport window controls Pro Tools only.

Transport = Machine

In this mode, the controls in the Transport win-
dow are focused on the machine connected and 
enabled for Serial Control mode. Record com-
mands are sent to the machine only.

◆ When the transport is online, Pro Tools slaves 
to the machine. The Pro Tools Transport con-
trols the machine, and Pro Tools chases and 
locks to the machine.

In addition, when Auto Spot is turned on, re-
gions are spotted to the current machine time, 
and the Trimmer tool trims to the current ma-
chine time. 

◆ When the transport is offline, the Pro Tools 
Transport window controls the machine only. 

Toggling the Transport while Online

When the transport is online, toggling the 
Transport Master selector between Pro Tools 
and your machine will also toggle their mas-
ter/slave relationship.

Refer to the Pro Tools Reference Guide for 
details on Auto Spotting.
MachineControl Guide
Transport = Remote (or Remote LTC)

◆ In Remote 9-Pin Deck Emulation mode, when 
the transport is online, Pro Tools responds to 
commands sent by the master 9-Pin machine. 
Many Pro Tools commands, including transport 
controls, are inactive. 

Pro Tools can generate time code, or chase LTC 
when online in Remote 9-Pin Deck Emulation 
mode. 

◆ In Remote 9-Pin Deck Emulation mode, when 
the transport is offline, Pro Tools operates in Lo-
cal mode and ignores commands from the 9-pin 
master. Pro Tools responds only to requests from 
the 9-pin master for machine type and status, 
and responds that it is in Local mode.

For more information, see Chapter 4, “Remote 
9-Pin Deck Emulation Mode.” 

Using the Transport

To play or cue your machine independently of 
Pro Tools:

1  Select Transport > Machine in the Pro Tools 
Transport window. 

2  Make sure Pro Tools is not online (the Online 
button in the Transport window is not flashing). 

3  Click any of the buttons in the Pro Tools 
Transport window to control your machine.

Pro Tools always displays incoming LTC or 9-
pin time in the Incoming Time field during fast-
wind, and switches during playback to display 
the current positional reference. 

To synchronize Pro Tools and machine playback 
from the Pro Tools Transport:

1  Select Transport > Pro Tools in the Pro Tools 
Transport window. 

2  Put Pro Tools online.



3  Click Play in the Transport window.

If the tape in the machine is striped with time 
code that matches your Session time, the ma-
chine will locate to the position of the Pro Tools 
on-screen selection/insertion point or memory 
location (plus pre-roll), and begin playing back 
in sync.

Machine Remote Setting

If the Transport Master selector will not stay set 
to Machine, or if it suddenly switches to 
Pro Tools from Machine, check your machine’s 
Local/Remote setting. It should be set to Remote 
to receive commands from the Pro Tools trans-
port. 

Online Display Information

Several display elements of the Edit and Trans-
port windows provide machine status informa-
tion. 

◆ When Pro Tools is online, the Transport on-
line button flashes. “Waiting for Sync” will be 
displayed in the status box in the lower left cor-
ner of the Edit window.

◆ The online button continues to flash until 
you click Play and time code lock occurs (all de-
vices locked and responding in sync). 

◆ The Time Code display in the Edit window 
shows the Machine Time when the machine is 
Master.

◆ Upon lockup, the display switches to show 
the session time. If your system doesn’t lock up 
quickly enough, you may want to adjust your 
machine pre-roll. See “Machine Pre-Roll” on 
page 10 for more information. 
Machine Cueing

MachineControl provides two Cue modes for re-
mote machine operation: Search and Hi-speed. 

◆ In Search mode, the tape remains laced during 
Fast Forward or Rewind. 

◆ In Hi-speed mode, the tape is unlaced before 
fast-forward/rewind. The Pro Tools Transport 
window indicates the status of the tape as de-
scribed below.

Search Mode

In Search mode, the tape is laced against the 
heads when the machine is paused or searching, 
and the Stop button stays lit (it does not flash) 
and the Play button flashes. When cueing in 
this mode, the Fast Forward or Rewind button 
also lights when searching in either direction.

To fast forward and rewind in Search mode: 

1  Select Transport > Machine in the Pro Tools 
Transport window.

2  Click Play in the Transport window or press 
the Spacebar to begin machine playback, then 
press the Spacebar again to pause the machine 
(this is to ensure that the tape is laced).

3  Click Fast Forward or Rewind in the Transport 
window to search the tape.

Some devices, including several popular 
VHS decks, do not support a shuttle mode 
in which the tape stays laced. These decks 
unlace the tape before shuttling. Refer to 
your tape machine’s guide for more infor-
mation. 
Chapter 3: Serial Control Mode and Transport Control 19
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Hi-Speed Mode

In Hi-speed mode, the tape is unlaced, and all 
Transport buttons are dark. While cueing in this 
mode, only the selected Fast Forward or Rewind 
button lights.

To fast forward and rewind in Hi-speed mode:

1  Select Transport > Machine in the Pro Tools 
Transport window.

2  Press Command+period (.) or click Stop in the 
Transport window to unlace the tape.

3  Click Fast Forward or Rewind in the Transport 
window. The Pro Tools cursor indicates the cur-
rent machine location.

4  Press the Spacebar to pause the machine. 

Spotting to the Machine

To spot regions to the machine’s current loca-
tion, use Pro Tools Spot mode and/or Auto Spot 
(if using VITC). Refer to the Pro Tools Reference 
Guide for information on using Spot and Auto 
Spot mode to spot regions to SMPTE locations. 

Some devices may not support all shuttle 
modes, and may not accept the above shut-
tle commands. In these cases, the Fast For-
ward and Rewind buttons in the Pro Tools 
Transport window flash, and clicking them 
places the device in true Fast Forward /Re-
wind mode. 

Auto Spot mode uses incoming VITC for lo-
cation information. Therefore, Auto Spot 
mode will force the Region to be spotted to 
the current incoming machine time code lo-
cation, not the current insertion cursor loca-
tion. To spot your elements directly to the 
current cursor location, Control-drag (Mac-
intosh) or Right-click and drag (Windows) 
the elements.
MachineControl Guide
Serial Time Code
If you are using a Digidesign SYNC I/O or USD 
connected to your DigiSerial port, and your ma-
chine has time code reader capability, you can 
take advantage of serial time code to achieve 
faster lockup times. 

Serial time code can only be supplied by ma-
chines with built-in time code readers which 
can serialize the time code when MachineCon-
trol requests it. Most professional machines 
have such readers (including DA-88, D2, Digi-
Beta, and most 3/4˝ decks).

To enable Serial Time Code:

1  In Pro Tools, choose Setups > Peripherals and 
click Synchronization.

2  Make sure the SYNC I/O (or USD) and DigiSe-
rial port are the selected device and port.

3  Ensure that the both the SYNC I/O (or USD) 
and the external machine are locked to the same 
video reference signal. 

4  Click the Machine Control tab in the Periph-
erals window to open the Machine Control 
page. 

5  Enable Use Serial Time Code for Positional 
Reference. 

Serial TIme Code enabled in the Peripherals dialog



Serial Time Code and SYNC I/O 
Settings

When Serial Time Code is enabled, the 
Pro Tools Clock Reference switches to Video 
Reference. Additionally, the Positional Refer-
ence pop-up is grayed out and displays Serial 
Time Code. (These controls are located in the 
SYNC I/O Settings section of the Session Setup 
window.)

Generate and Serial Time Code

Pro Tools automatically puts the SYNC I/O (or 
USD) in Generate mode and prohibits any 
changes to the Positional and Clock Reference 
settings. While Serial Time Code is being used, 
this Generate mode is engaged to calculate 
frame-edge accuracy in Pro Tools. 
Chapter 3: Serial Control Mode and Transport Control 21
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Remote 9-Pin Deck Emulation Mode
Remote 9-Pin Deck Emulation mode makes 
Pro Tools operate as a virtual tape deck, support-
ing most standard Sony P2 9-pin commands. 
For a list of supported commands, see “9-Pin 
Commands” on page 27. By default, Pro Tools 
emulates a Sony BVW-75 model video deck. You 
can also configure Pro Tools to emulate other 
machines. For more information, see “Alternate 
Machine Types” on page 24. 

Generating Time Code in Remote 9-Pin 
Deck Emulation Mode

Pro Tools with MachineControl and the 
SYNC I/O can generate frame-edge aligned time 
code at 1x play speed while in Remote 9-Pin 
Deck Emulation mode. 

Configuring Remote 9-Pin 
Deck Emulation Mode

To configure Pro Tools for Remote 9-Pin Deck 
Emulation mode:

1  Choose Setups > Peripherals, and click the 
Synchronization tab. 

For instructions on connecting Pro Tools for 
Remote 9-Pin Deck Emulation mode, see 
Chapter 2, “Installing and Configuring 
MachineControl.”
2  Make sure the SYNC I/O (or USD) is the se-
lected Synchronization device, enabled on the 
DigiSerial port. 

3  Click the Machine Control tab at the top of 
the Peripherals dialog. 

4  In the 9-Pin Remote section, click Enable.

5  Choose the appropriate port from the Port 
menu. 

6  Choose the appropriate machine profile from 
the Machine ID pop-up menu. 

7  Do one of the following:

• Select Chase LTC to have Pro Tools chase 
the master time code source. 

• Deselect Chase LTC to have Pro Tools and 
the SYNC I/O provide the master time code 
signal. 

8  Click OK. 

Remote 9-Pin Deck Emulation mode settings

In addition to the option to chase LTC, Re-
mote 9-pin Deck Emulation mode also pro-
vides a preference setting to follow or ignore 
remote track arming commands. For more 
information, see “Ignore Track Arming 
Commands” on page 26. 
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9  In the Session Setup window, Generate Using 
SYNC I/O (or, using USD) is automatically en-
abled. This is required for Pro Tools to lock to 
the video reference with frame edge accuracy. 

10  Make sure Video Reference is selected as the 
SYNC I/O (or USD) clock reference.

11  In the Pro Tools Transport window, select Re-
mote or Remote LTC as the Transport master.

12  Put Pro Tools online. 

13  Begin machine playback. 

Chase LTC

Remote 9-Pin Deck Emulation mode lets a mas-
ter device control Pro Tools track and Transport 
arming. In standard Remote 9-Pin Deck Emula-
tion mode, Pro Tools serves as the time code 
master device while simultaneously responding 
to 9-pin transport and track arming commands. 

When Chase LTC is enabled, Pro Tools can still 
respond to 9-pin track arming and record com-
mands, but chase incoming LTC instead of be-
ing the time code master device. By slaving 
Pro Tools to the LTC source instead of slaving 
the machine to Pro Tools time code, you can 
avoid waiting (and tape wear) while a machine 
transport locates and bumps tape to the cue 
point. 

Remote 9-Pin Deck Emulation mode settings

See also “Optimizing Playback in Remote 9-
Pin Deck Emulation Mode” on page 25. 

Chase LTC enabled

 Chase LTC not enabled
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When Chase LTC is enabled, the Transport mas-
ter selector shows Transport = Remote LTC. 
Pro Tools also communicates record status to 
the machine. 

Receiving Commands While Chase LTC is 
Enabled

When Chase LTC is enabled, and the system is 
online, Pro Tools waits until it receives only spe-
cific transport record and track record com-
mands from the machine. When Chase LTC is 
not enabled, Pro Tools will listen to all transport 
commands arriving through the serial connec-
tion, including bump and crawl commands nec-
essary for a tape machine to locate.

Scrubbing and Chase LTC

The Chase LTC option does not affect scrub-
bing. Pro Tools video playback will always re-
spond to locate and scrubbing command, even 
if Chase LTC is enabled. 

Alternate Machine Types

By default, MachineControl lets Pro Tools emu-
late a Sony BVW-75. If you use a machine that 
follows a different 9-pin command set, you can 
configure Pro Tools for its machine description 
by selecting it as the 9-Pin Remote device in the 
Machine Control page of the Peripherals dialog.



Remote 9-Pin Deck Emulation Mode 
Preferences

Pro Tools provides the following preference set-
tings to configure Remote 9-Pin Deck Emulation 
Mode options. 

To set Remote 9-Pin Deck Emulation mode 
preferences:

1  Choose Setups > Preferences and click the Op-
eration tab. 

2  Set any of the following options:

Punch In Frame Offset Sets an offset in frames to 
compensate for punch in timing advances or de-
lays. 

Punch Out Frame Offset Sets an offset in frames 
to compensate for punch out timing advances 
or delays. 

Delay After Play Command Sets a number of 
frames of delay for Pro Tools to wait before at-
tempting to lock, to compensate for the amount 
of time needed for the master machine to stabi-
lize. This setting can be especially useful in a 
multi-machine environment. 

Ignore Track Arming Lets you record-safe 
Pro Tools from machine track arming. When 
this option is selected, Pro Tools responds to all 
9-pin remote commands except track arming. 

3  Click Done to close the Preferences dialog.

Remote 9-Pin Deck Emulation Operation Preferences
Playback in Remote 9-Pin 
Deck Emulation Mode
Pro Tools will only play back audio when the re-
ceived command requires audio play back at 1X 
speed in the forward direction. Reverse playback 
and varispeed playback are not supported in 
Pro Tools. 

Online Status Display

When online in Remote 9-Pin Deck Emulation 
mode, the Online button flashes until Pro Tools 
and the machine establish communication. 
When MachineControl and Remote 9-Pin Deck 
Emulation Mode are enabled and communica-
tion is established, the Online button will re-
main highlighted. 

Optimizing Playback in Remote 9-Pin 
Deck Emulation Mode

Use the Delay After Play Command preference 
to optimize Pro Tools response in Remote 9-Pin 
Deck Emulation mode. (See “Remote 9-Pin Deck 
Emulation Mode Preferences” on page 25 for in-
structions on how to configure this preference.) 
This setting lets you enter a number of frames 
for Pro Tools to wait, before responding to lo-
cate and play commands. A small delay before 
play allows the time code master device to stabi-
lize before Pro Tools attempts to achieve lock. 
By delaying play in this manner, Pro Tools can 
avoid multiple nudge and bump messages while 
attempting to lock. 
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Recording in Remote 9-Pin 
Deck Emulation Mode
MachineControl lets Pro Tools support Auto 
Edit (selection-based) and Punch-in/Punch-Out 
(QuickPunch) commands. 

Pro Tools must have QuickPunch enabled when 
recording in Remote 9-Pin Deck Emulation 
mode with an edit controller. 
 

Auto Edit Recording

When a machine sends Auto Edit commands to 
Pro Tools in Remote 9-Pin Deck Emulation 
mode, the edit in and out points are converted 
to a Pro Tools Timeline selection. This selection, 
with offsets options, will then be used to record 
on all armed tracks when Pro Tools receives the 
Perform Auto Edit Record command. 

Punch In/Out Recording

Punch-In/Punch-Out Recording supports 
punch-on-the-fly, with Pro Tools in QuickPunch 
mode. In this mode, tracks are armed before the 
record pass, and recording begins and ends 
when Punch-In and Punch-Out commands are 
received form the master machine. 

QuickPunch must be enabled and the required 
voices must be available in Pro Tools for Punch-
In/Punch-Out recording commands to work. 
This mode must be set manually in Pro Tools.

Preview Edit and Record Rehearse modes 
are not supported by Pro Tools.
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Track Arming in Remote 9-Pin 
Deck Emulation Mode
In Remote 9-Pin Deck Emulation mode, 
Pro Tools can be configured to either respond 
to, or ignore, track arming (record enabling) 
commands. Pro Tools communicates track 
record status back to the control machine. 

Ignore Track Arming Commands

You can set Pro Tools to ignore incoming track 
arming (record-enable) commands. Use this to 
record-safe Pro Tools if, for example, you are us-
ing a master 9-pin transport controller to arm 
tracks on several other machines, but not 
Pro Tools tracks. You can still manually arm 
Pro Tools audio tracks, as needed. 

To have Pro Tools ignore remote track arming 
commands:

1  Choose Setups > Preferences, and click the Op-
eration tab. 

2  Under Remote Mode, select Ignore Track Arm-
ing. 

See Chapter 5, “Remote Track Arming” for 
more information.



9-Pin Commands
In Remote 9-Pin Deck Emulation Mode, 
Pro Tools with MachineControl can respond to 
the following 9-pin commands from compatible 
workstations, synchronizers, and other devices:

• Play

• Stop

• Pause

• Rewind

• Forward

• Cue To

• Poll Time Code

• Record Arm Track

• Set In/Out Point (for Auto Edit)

• Set Pre/Post Roll (for Auto Edit)

• Perform Auto Edit Record

• Perform Punch-In/Punch-Out Record (re-
quires QuickPunch mode and voices)

• Return Status-Online, State, Tracks Armed

• Servo Lock

• Clear “In” Point
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Remote Track Arming
Pro Tools with MachineControl provides the 
ability to record-arm audio, video, or time code 
tracks on external decks. 

On MachineControl-equipped systems, the 
Show Machine Track Arming Window com-
mand is available in the Pro Tools Windows 
menu. The Track Arming window lets you con-
figure track arming during sessions, using the 
settings appropriate for the current Track Arm-
ing Profile. (See “Identifying Your Machine” on 
page 30.)

To display the Machine Track Arming window:

■ Choose Windows > Show Machine Track Arm.

Track Arming in Pro Tools 6 and higher

Protocol
and 
Mode

Record 
Arm 
buttons
Configuring Track Arming
Pro Tools provides automatic, direct support for 
track configuration of most common video 
decks. If your deck is supported, MachineCon-
trol identifies and displays your machine’s track 
layout. 

Even if your machine is not directly supported, 
the Track Arming window lets you arm tracks, 
set the Record Protocol and configure the 
Record mode for the machine. 

You can also define, save, and load customized 
device profiles. (See “Creating a Track Arming 
Profile” on page 30.)

Not all machines support independent arm-
ing of their audio tracks locally or remotely, 
and some machines require a separate util-
ity menu selection. Pro Tools remote track 
arming cannot operate in these situations.
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Identifying Your Machine

When you configure Pro Tools for MachineCon-
trol, it automatically loads the track arming pro-
file for the identified machines. For more infor-
mation on basic Pro Tools settings for 
MachineControl, see “Configuring Pro Tools for 
MachineControl” on page 9.

If Pro Tools does not recognize your machine, or 
if you want your machine to emulate a different 
type of device (for example, to use a different 
track layout), you can load a generic machine 
profile. 

For maximum flexibility, use Track Arming Pro-
files to create, customize, and manage multiple 
machine descriptions (see “Creating a Track 
Arming Profile” on page 30). 

If you are using a generic machine profile, 
be sure to double-check record behavior us-
ing non-essential tapes before using Machi-
neControl’s remote track arming functions.
MachineControl Guide
Creating a Track Arming 
Profile
The Create Track Arming Profile window pro-
vides extensive control over Pro Tools Track 
Arming. You can customize arming, track nam-
ing, and mapping, and save configurations for 
different machines as Track Arming Profile files. 
These Profiles can be imported to quickly recon-
figure Track Arming as needed for future 
projects. You can also test track mapping, and 
remap tracks if needed. 

Use the Create Track Arming Profile feature to 
create profiles for machines that may not be in-
cluded with Pro Tools, and to manage multiple 
profiles. 

To create a machine Track Arming Profile:

1  Choose Setups > Create Machine Track Arm-
ing Profile. 

When you create a new Track Arming Pro-
file, a Stop command is sent to any con-
nected machine to protect elements on tape.

Create Track Arming Profile

Load 
Profile

Track 
Arm 
buttons

Save ProfileMachine ID

Profile settings



Choosing a Machine ID

To recognize your machine:

■ Click Identify Machine. 

MachineControl queries the connected ma-
chine for its machine ID, which is then dis-
played below the Identify Machine button. 

You can edit or replace the ID manually if 
needed. See “Entering a New Byte Code” on 
page 32 for more information. 

Configuring a Profile

The Create Track Arming window lets you spec-
ify track names and track mapping. 

Customizing Names for Track Arming 
Buttons

You can rename the Track Arm buttons dis-
played in each Track Arming Profile to better de-
scribes the recording taking place. For example, 
an eight track profile might be easier to use with 
tracks named Dx-L, Dx-R, FX-L, FX-R, Mx-L, Mx-
R, Lt, and Rt, for eight tracks comprised of stereo 
Dialog, stereo FX, stereo Music, and an Lt-Rt 
mix. 

To edit the name of a track arming button:

1  Double-click the Track Arm button you want 
to rename.

2  Enter a new track name in the dialog, and 
click OK.

Entering a custom track name
Remapping Tracks

You can remap track buttons to target different 
tracks on the machine. 

To remap tracks:

1  Click the Track button you want to remap to 
display its remap pop-up menu. 

2  Choose a new target track.

– or –

Choose a different machine profile from the 
Load Configuration selector. 

Reassigning the Byte Value for a Track 

In a remote machine’s firmware, each record 
track on the machine has a unique hexadecimal 
byte code that tells the machine which track 
should be armed when an arm command is re-
ceived from a remote master. The standard pro-
file (the default setup) corresponds to the Sony 
P-2 protocol, but many decks have their own 
unique mapping of byte codes to track numbers 
for a particular deck. 

If an audio or video track, or the deck time code 
track do not arm when you click its correspond-
ing track arming button, you may need to assign 
a different hex value to the button.

To select a different hex value for an individual 
track arm button:

■ Select another hex value byte code from the 
Byte Code sub-menu for the appropriate track 
arm button. 

Remapping a track arming button
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Entering a New Byte Code

As the Sony P2 protocol continues to expand, 
more manufacturers add specific byte code com-
mands that may be listed in the current byte 
code list. Pro Tools lets you create entirely new, 
custom byte codes. This lets you enter addi-
tional byte commands as needed to support new 
features as they are added to decks.

Choosing a Record Protocol 

The Machine Track Arming window provides 
the following two choices for configuring the re-
cording protocol of the target deck:

Auto Edit

This mode is a highly accurate way to ensure 
that the target deck will record only within the 
boundaries of an on-screen selection. (If your 
deck does not support Auto Edit, use Punch 
In/Punch Out, as explained below.) 

In Auto Edit mode, the record start/end times 
are downloaded to the target deck (along with 
any pre- or post-roll), and the deck is responsible 
for performing the insert punch in/out at the 
specified times (see “Rules for On-Screen Selec-
tions” on page 33 for details). 

Because this protocol removes the vagaries of 
CPU timing from the remote recording process, 
Auto Edit is frame-accurate. It is also the best 
way to ensure that your machine will punch out 
correctly and avoid accidental erasure of audio, 
even in the event of a CPU error.

Entering a new byte code
MachineControl Guide
Punch In/Out

This mode uses Pro Tools to control the process 
of punch in/out. Instead of downloading the 
punch points (as in Auto Edit), Pro Tools actu-
ally performs them during the record pass. Be-
cause serial communication has inherent de-
lays, timing with Punch In/Punch Out mode 
cannot guarantee frame-accuracy (though it will 
almost always be within 2 to 3 frames). 

Choosing a Record Mode 

The Machine Track Arming window provides 
two choices for Record mode:

Insert

Insert mode is used to perform insert editing 
(punching in individual tracks) where one or 
more audio tracks is replaced by new material 
and the video material is retained. 

Assemble

Use Assemble mode when you want to:

◆ Begin recording program onto a completely 
blank tape (unformatted)

– or –

◆ Append program to the remainder of a tape 
which already has program you want to keep

Assemble mode is not appropriate for audio lay-
backs to video masters.

Assemble mode should be used carefully be-
cause it arms all tracks on the target deck for re-
cording—including the video track, time code 
track and control track. When performing an 
Assemble edit, all material on all tracks after the 
edit in point will be replaced. Because a break in 
the control track will result at the edit out point, 
any remaining program material after an Assem-
ble edit may be unusable.



To avoid accidentally recording over program 
material, experiment with Assemble and Insert 
modes on a dispensable tape to familiarize your-
self with the edit capabilities of your deck.

Rules for On-Screen Selections

The Record Protocol buttons allow you to 
choose between the two different record proto-
col choices described above (Auto Edit and 
Punch In/Punch Out). Regardless of which 
choice is used, however, Pro Tools follows these 
rules for record selection:

◆ If there is an on-screen selection, recording 
will take place over the period of the selection 
and punch out at the end of the selection. 

◆ If pre- or post-roll is enabled, recording takes 
place only in the selection area, not during pre- 
or post-roll. 

◆ If there is no selection (only a start location), 
recording will continue until it is manually 
stopped.

◆ If you make a selection in Pro Tools that 
crosses the “midnight” boundary (00:00:00:00), 
make sure your deck can handle this situation. 
Experiment with a dispensable tape to familiar-
ize yourself with the crossover capabilities of 
your deck.

Assemble mode replaces all the elements on
the target tape deck—audio, video and time
code. Use this mode with caution. 
Arming Tracks Remotely for 
Layback
To arm tracks remotely for layback, you need to 
first configure Track Arming for your machine. 

To configure Track Arming:

1  Make sure your machine is properly con-
nected and configured to slave to Pro Tools. 

2  Open the Track Arming window.

3  Select a Record Protocol (Auto Edit or Punch 
In/Out).

4  Select a Record mode (Insert or Assemble).

To perform a layback:

1  In Pro Tools, select the audio to lay back, or 
place the playback cursor at a start point. 

2  In the Remote Track Arming window, arm the 
appropriate tracks on the machine.

3  Select Transport > Machine in the Pro Tools 
Transport window. 

4  Make sure the Pro Tools Transport is online. 

5  Click Record in the Transport window to arm 
recording.

6  Click Play in the Transport window.

Your machine will cue to the selection start mi-
nus all relevant pre-roll, then begin to play back. 
Pro Tools will then sync to the deck, and the tar-
get deck will record as determined by your set-
tings for Record Protocol and Record mode. If 
you did not create an on-screen selection, deck 
recording will continue until you manually stop 
playback.

Once the Track Arming options are config-
ured, you can change the Track Arming 
window to “small view” and still see the 
track arm buttons.
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appendix a

MachineControl Key Commands
 

Command Macintosh Windows

Rewind Shift+< Shift+<

Fast Forward Shift+> Shift+>

Shuttle Backward Option+comma Alt+comma

Shuttle Forward Option+period Alt+period

Toggle Transport Master Command+\ Control+\

All Transport Buttons Off/Unthread Tape Command+period Control+period

Search Mode Toggle (Play-Pause/Stop) Spacebar/Com-
mand+period

Spacebar/Ctrl+period

When Transport = Machine:

Locate to Selection Start Command+Left Arrow Control+Left Arrow

Locate to Selection End Command+Right Arrow Control+Right Arrow

Locate to Selection Start Minus Preroll Option+Left Arrow Alt+Left Arrow

Locate to Selection End Minus Preroll Option+Right Arrow Alt+Right Arrow
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appendix b

Troubleshooting
Installation

Problem:

MachineControl options are not available in 
Pro Tools. 

Possible Solution:

Make sure MachineControl is installed and au-
thorized correctly (see Chapter 2, “Installing 
and Configuring MachineControl.”)

Machine Not Recognized

Problem:

The session was saved with MachineControl, 
but now opens without it being selected in the 
Transport window. When opening a session 
saved with MachineControl, a dialog warns that 
there were “problems initializing MachineCon-
trol.” When spotting a region, the “Capture Ma-
chine Time” button is grayed out.
Possible Solutions:

◆ Choose Setups > Peripherals, click the Ma-
chine Control tab, and confirm that the correct 
9-Pin Serial port is chosen for your Machine-
Control operating mode. Make certain that all 
cables are securely connected at both ends.

◆ Verify that the machine and any V-LAN inter-
faces are powered on. Choose Setups > Peripher-
als, click the Machine Control tab. Reset the 9-
Pin Serial port, and close the dialog. This causes 
Pro Tools to scan the serial port for V-LAN or 9-
pin devices. 

Pro Tools Transport Not 
Controlling Machine

Problem:

Though the MachineControl dialog indicates 
that Pro Tools recognizes the machine, nothing 
happens when you use the transport in 
Pro Tools (the machine doesn’t respond to com-
mands). When spotting a region using the 
“Capture Machine Time” button, an incorrect 
time is entered.
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Possible Solutions:

◆ Most machine controllable transports need to 
be placed in a “Remote” or “Ext” mode to allow 
them to be slaved to other devices. Verify that 
the device is in this mode. Refer to the docu-
mentation that came with your device for more 
information on Remote and Local modes. 

◆ In the Transport window, check the status of 
the “Transport = Pro Tools” or 
“Transport = Machine” setting.

◆ If the machine protocol is V-LAN and there 
are multiple machines on the V-LAN network, 
choose Setups > Machine Setup and verify that 
the correct machine is selected in the pop-up 
menu.

Time Code Inaccuracy

Problem:

The time code locations shown in the Selection 
and Position Indicator boxes do not match ma-
chine time code.

Possible Solutions:

◆ For best performance with Serial Control 
mode, connect the machine to an available se-
rial or COM port (or serial adapter connected to 
a USB port) on the host computer. Use the 9-pin 
ports on the SYNC I/O for non-linear video 
decks only. 

◆ In some cases, the Time Code values reported 
by machines are not in sync with the time code 
that gets played out of their time code ports. 
(One example of this is when the machine's 
time code reader is looking at VITC while 
Pro Tools is chasing LTC.)

◆ If the values get progressively farther and far-
ther apart, check the frame rate. Make sure you 
have set Pro Tools to the same frame rate as the 
movie/machine frame rate. Also check the 
frame format (drop or non-drop). 
MachineControl Guide
◆ If the values differ by a significant margin 
(such as an hour or more), the Start Frame num-
ber may be set incorrectly. Open the Session 
Setup window and check the Session Start Frame 
number.

Changing Session Start Time, and 
Dropped Frames

When you change the session frame rate from a 
non-drop to drop rate, or from drop to non-
drop, the session start time and material in the 
timeline may be affected. 

Non-drop changed to Drop: The Session Start 
Time is changed to the next possible supported 
frame if the current one is not supported in DF. 
For example, changing from non-drop to drop 
frame in a session that starts at 00:59:00:00 will 
change the session’s start time to 00:59:00:02 
(due to the method by which frames are 
dropped in each rate and format). 

Every event in the timeline is moved back two 
frames, maintaining each event’s relative time 
code location (relative to the start of the ses-
sion). 

Drop changed to Non-drop When going from 
drop to non-drop, no compensation is applied 
to the session start time. This is done because all 
frames in drop exist in a non-drop timeline (a 
drop rate timeline is a subset of its correspond-
ing non-drop rate timeline). So, when changing 
from a drop rate to a non-drop rate, Pro Tools 
keeps events at the same location relative to the 
start of the session. 



appendix c

Machine IDs
The following table lists the machine profiles 
supported in MachineControl by their Pro Tools 
hexadecimal ID. 

For special IDs to support 48-track arming, see 
“48 Track Profiles” on page 40. 

Machines and Hex ID Numbers

The first 0x signifies hex value. The next four 
numbers signify the machine ID. The name of 
the associated machine follows. 

Machines, by ID number

ID number Machine

0x0000 Generic

0x1000 BVU-800

0x101C BVU-950

0x1019 BVU-920

0x1080 BVU-900

0x104C VO-9850

0x1048 VO-9800

0x102C SVO-9600

0x2000 BVW-10

0x2001 BVW-40

0x2002 BVW-11

0x2003 BVW-15

0x2010 BVW-35

0x2020 BVW-60
0x2021 BVW-65

0x2022 BVW-95

0x2023 BVW-96

0x2024 BVW-70

0x2025 BVW-75

0x2125 BVW-75P

0x4000 DVR-10

0x4003 DVR-18

0x4002 DVRC-10

0x4020 DVR-20

0x4022 DVR-28

0xF019 AJ-D350 (D3)

0x3011 DVR-2100

0x3000 DVR-1000

0x0010 BVH-2000

0x0011 BVH-2000

0x0110 BVH-2000 PS

0x0111 BVH-2000 PS

0x0018 BVH-2180

0x0020 BVH-2500

0x0120 BVH-2500 PS

0x0030 BVH-2700

0x0040 BVH-2800

Machines, by ID number

ID number Machine
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0x0048 BVH-2830

0x0050 BVH-3000 (NTSC)

0x0060 BVH-3100 (NTSC)

0x0150 BVH-3000 PS

0x0160 BVH-3100 PS

0x2041 PVW-2800

0x1211 ASC Virtual Recorder

0x1011 Fostex D-10

0xF027 Otari R-DAT

0x7001 TASCAM DA-88

0xF01D TASCAM DA-88

0x7003 PCM-800

0x7000 PCM-7000

0xA088 AG-DS555

0x2051 UVW-1800

0xB000 DVW-500

0xB010 DVW-500

0xA050 V1

0x2124 BCB-70

0x2101 BVW-40P

0x2141 PVW-2800P

Tascam DA-88 and other decks can be set 
to emulate other machines. If a deck is set to 
emulate another type of machine, the ma-
chine type being emulated will be displayed. 

Machines, by ID number

ID number Machine
MachineControl Guide
48 Track Profiles

The following are special IDs to support 48-track 
arming. 

Machines

Pro Tools

IDs for 48-Track Capable Machines

ID Machine

0x6007 3348HR

0x6005 3348HRV

0x6003 3324

IDs for 48-Track Pro Tools Arming

ID Machine

0xD0 E1 Pro Tools

0XD1 E1 Pro Tools

0XD2 E1 Pro Tools
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9-Pin Cable Pinouts

Serial Control 9-Pin Cable
Figure 1.  MachineControl Serial Control 9-Pin Cable pinout

7

8

3

1 2

n/c n/c

n/c

Serial Control Cable

Mini - 8
1
2
3
4
5
6
7
8

Shield

DB-9
NC
NC
8
1
2
3

NC
7

NC
Shield

Mini - 8
1
2
3
4
5
6
7
8

Shield

DB-9
NC
NC
2
1
8
7

NC
3

NC
Shield

V-Lan Pin Configuration

DIN  Mini 8

9-pin, male D-SUB 

76 8 9

21 43 5
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Remote Deck Emulation Mode 9-Pin Cable
MachineControl Guide
Figure 2.  MachineControl Remote Deck Emulation Mode 9-Pin cable pinout
Remote Deck Emulation Mode 9-Pin cable

Mini - 8 DB - 9

1 NC

2 NC

3 2

4 9, 1

5 8

6 7

7 NC

8 3

Shield NC Shield
Shielding

The outside shielding of the D-Sub 9 (female) 
should be wired to the outside shielding of the 
Mini DIN 8 (male).



9-Pin to 9-Pin
Figure 3.  9-pin to 9-pin cable

1
1
2
7
6
5
3
8
4
9

Shell

DB-9M DB-9M
1
2
7
6
5
3
8
4
9
Shell

NC NC
This is a standard ESBus MachineControl Cable. 

• All pins wired straight through. 

• Pins 2 and 7 are a Twisted Pair with shield 
drain wire on Pin 6.

• Pins 3 and 8 are a Twisted Pair with shield 
drain wire on Pin 4. 
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A
arming

safe (ignore) 26
Assemble mode 32
authorizing Aural Exciter III and Big Bottom Pro 8
authorizing Virus 8
auto detection 9
Auto Edit 32

and Remote mode 26
Auto Spot 18, 20

C
cables 1, 2

wiring diagrams 41, 42, 43
CH 1-2 Input 12
Chase LTC 24
chasing

preferences 16
control track 32
Create Machine Track Arming Profile 30
cueing

hi-speed mode 20
preferences 16
search mode 19

D
delay

preferences 16
Delay After Play Command 25
Delay before Locking to LTC 16

E
emulation

of 9-pin deck via Remote mode 6, 7
ESBus cable 43
F
frame rate 12
frame-edge

and serial time code 21

G
Generate

and serial time code 21
generic machine profiles 10

H
hi-speed mode 20

I
IDs

machine 39
Ignore Track Arming 25
Ignore Track Arming command 26
iLok

adding authorizations 9
iLok hardware key 8
Incoming Time 12
Insert mode 32
Installer CD-ROM 7
installing MachineControl 7

L
layback 33
local mode (machine) 8
Local/Remote 19
locating

preferences 16
LTC

Chase LTC in Remote mode 24
index
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M
machine

pre-roll 10
profiles 39
transport master 18

Machine Chases Memory Location 16
Machine Cues Intelligently 16
Machine Follows Edit Insertion/Scrub 16
machine IDs 39
machine profiles 30
memory locations

and machine chase 16
midnight boundary 33

N
NTSC 12

O
Online

button in Transport 17
toggling 15

On-Screen Selections 33

P
PAL 12
preferences

Delay before Locking to LTC 16
Machine Chases Memory Location 16
Machine Cues Intelligently 16
Machine Follows Edit Insertion/Scrub 16
Record Online at Edit Insertion/Selection 16
Record Online at Time Code (or ADAT) Lock 16
Remote mode 25

pre-roll
compensating 10
machine 10
setting for machine from Pro Tools 10

Pro Tools
transport master 18

Punch In Frame Offset 25
Punch In/Out 32
Punch Out Frame Offset 25
MachineControl Guide
R
record mode 32
record modes

Assemble 32
Insert 32

Record Online at Edit Insertion/Selection 16
Record Online at Time Code (or ADAT) Lock 16
record protocol 32

Auto Edit 32
Punch In/Out 32

recording
preferences 16
Remote mode 26

Redefine Current Time Code Position 14
Remote 9-pin Deck Emulation mode

Chase LTC 24
preferences 25
see also Remote mode

Remote LTC mode
transport master 18

Remote mode
and track arming 26
Auto Edit 26
commands 27
connections for 9-pin deck emulation 6, 7
playback 25
recording 26
transport master 18

remote mode (machine) 8

S
search mode 19

cueing 19
serial time code 20

and Generate mode 21
servo lock 10
start time 12
Stop At Shuttle Speed Zero 16
Sync Mode 12
system requirements 2



T
time code

quick signal test 12
redefine current 14
track 32

track arming
48-track IDs 40
and Remote mode 26
create machine profile 30
IDs 39
ignore 26
remapping tracks 31

track layout 10
tracks

remapping 31
transport master 1, 17

machine 18
Pro Tools 18
Remote 18
Remote LTC 18
selecting 17
toggling 18

Trimmer
when Transport = Machine 18

U
Use Serial Time Code for Positional Reference 20

V
Video Format 12
Video Reference

and serial time code 21
video track 32
VTR emulation 6, 7
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