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Introduction

 

Digidesign MachineControl™ is special purpose 
software for Pro Tools TDM systems that enables 
serial communication with Sony® 9-pin com-
patible video or audio machines.

 

MachineControl Version 2.0

 

This guide provides installation and operational 
instructions for MachineControl version 2.0, for 
Pro Tools systems on Windows XP or Mac OS X.

If you require documentation for other system 
configurations, refer to earlier versions of this 
guide, available on the Digidesign Web site 
(www.digidesign.com).

• For Pro Tools systems using Mac OS 9 and 
MachineControl v2.0, refer to 

 

Machine-
Control 2.0 Guide for Pro Tools 6.0, 6.1, and 
6.2.

 

• For Pro Tools systems that require 
MachineControl v1.1, refer to the 

 

MachineControl 1.1 Guide for Pro Tools 5.3.1

 

.

For Pro Tools systems that support USD, refer-
ences to “SYNC I/O” in this guide can be re-
placed with “SYNC I/O or USD.” Note that USD 
does not support 4% Pull Up and Pull Down, or 
23.976 fps.

 

MachineControl Components

 

Your MachineControl package includes the fol-
lowing, based on your operating system:

 

Windows Systems

 

• MachineControl Installer CD-ROM

• Serial Deck Control cable: RS-232 to RS-422 
cable

• 9-pin Turnaround adapter (for Remote 9-
pin Deck Emulation mode)

• MachineControl iLok License Card 

 

Macintosh Systems

 

Your MachineControl package includes:

• MachineControl Installer CD-ROM

• Serial Deck Control cable: Male 8-pin mini-
DIN to male 9-pin cable

• Remote 9-pin Deck Emulation cable: Male 
8-pin mini-DIN to female 9-pin cable

• MachineControl iLok License Card 
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MachineControl Capabilities

 

MachineControl Machine 
Communication Modes

 

MachineControl supports two machine com-
munication modes: Serial Deck Control and Re-
mote 9-Pin Deck Emulation mode.

 

Serial Deck Control Mode

 

With Serial Deck Control mode (also called 9-
Pin Serial mode or Machine Control), the Pro 
Tools “Transport Window” can control a deck.

 

Transport

 

The setting of the Transport “master” (located in 
the Pro Tools Transport window) determines 
the type of Serial Deck Control, as follows:

 

Transport = Pro Tools 

 

The Transport window 
controls the Pro Tools timeline. When online, 
the deck locates relative to actions taken in the 
Pro Tools timeline.

 

Transport = Machine 

 

The Transport window 
controls the machine. When online, the 
Pro Tools timeline chases the machine.

 

Cueing, Scrubbing, and Pre-Roll

 

Preference settings in Pro Tools let you optimize 
MachineControl operation, including adjust-
able machine pre-roll, selectable edit and mem-
ory location chasing.

 

Track Arming

 

When Transport = Machine, you can arm tracks 
of external machines from within Pro Tools, for 
layback and transfer configuration. Features in-
clude individual record enables for up to 48 ex-

ternal tracks, with selectable record protocol 
and mode. Included machine profiles let you 
preconfigure track arming for most machine 
types.

 

Serial Time Code (or LTC to SYNC I/O)

 

With MachineControl, Pro Tools can control an 
external machine via the Serial Deck Control ca-
ble. This setting also enables Pro Tools to receive 
time code position using only the Serial Deck 
Control cable, instead of using routing into the 
SYNC I/O. This setting appears in Pro Tools as 
Use Serial Time Code for Positional Reference in 
the Machine Control page of the Peripherals 
window.

(This mode requires that the 9-pin device be ca-
pable of transmitting serial time code, via its 9-
pin connection. It also requires that the deck be 
locked to video reference.)

 

Remote 9-Pin Deck Emulation Mode

 

With Remote 9-Pin Deck Emulation mode (also 
called Remote 9-Pin mode), an external ma-
chine device can take control over Pro Tools 
transports and recording functions.

Pro Tools responds to commands sent by the 
master 9-pin machine controller, but because 
Pro Tools is in Remote mode, many of the front 
panel commands are locked out.

 

Transport = Remote or Remote/LTC

 

When controlling Pro Tools from an external 
machine controller, Pro Tools can fully emulate 
either a 9-pin deck in “Full Remote” as either (1) 
the time code master device or (2) a time code 
slave device, or in “Half Remote” mode as (3) a 
device that receives locates plus track and trans-
port arming commands, but does this while 
chasing incoming LTC.
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Full Remote Modes 

 

Pro Tools or the machine is 
the time code master, based on the Delay Before 
Play setting (choose Setups > Preferences, then 
click on the Machine Control tab to display the 
Delay After Play command).

• When Delay After Play is set to zero, 
Pro Tools is set to be the time code master 
device. When online, Pro Tools locates, 
then plays when it gets a play command.

• When Delay After Play is set to 
20–30 frame, Pro Tools is set to work as a 
time code slave device. When Pro Tools lo-
cates and gets a play command, it negoti-
ates its time code position for that 20–30 
frames, lining up with the time code mas-
ter device before it buffers data and going 
into play.

 

Remote/LTC Chase Mode 

 

An external machine 
controls Pro Tools, but Pro Tools is set to syn-
chronize by just chasing incoming LTC time 
code, instead of being bumped into position by 
the machine controller. This mode is enabled by 
selecting the Chase LTC option in Pro Tools 
(choose Setups > Peripherals, then click on the 
Machine Control tab to display the Chase LTC 
option in the 9-Pin Remote section).

 

Track Arming

 

When Transport = Remote/LTC, you can arm 
Pro Tools tracks from an external machine.

Features include remote control of individual 
record enables for up to 48 external tracks, with 
selectable record protocol and mode. Included 
user programmable profiles let you preconfigure 
track arming for any machine type.

 

Time Code Generated from SYNC I/O

 

When in Remote Deck Emulation, Pro Tools 
must always be set to generate time code via the 
SYNC I/O. This enables Pro Tools to properly re-
turn time code position back down the serial 9-
pin cable to the machine controller.

 

System Requirements

 

MachineControl requires the following:

 

◆

 

Digidesign-qualified Pro Tools TDM system, 
running on a Digidesign-qualified computer 
and version of Windows or Macintosh.

Digidesign can only assure compatibility and 
provide support for hardware and software it 
has tested and approved. 

For a list of Digidesign-qualified computers, op-
erating systems, hard drives, machines control-
lers, and third-party devices, refer to the latest 
compatibility information on the Digidesign 
Web site (www.digidesign.com/compato).

 

Serial Deck Control Mode 
Requirements

 

For Tighter Lockups

 

For Serial Deck Control, use of a Digidesign 
SYNC I/O is recommended.

For near sample accurate Serial Deck Control, 
SYNC I/O is required.

If you are not using a SYNC I/O with Pro Tools, 
some features of MachineControl can be used 
by connecting the deck to the DigiSerial port on 
a Pro Tools Core card.

 

For arming tracks during playback, please 
consult the TrackPunch feature descriptions 
in the Pro Tools Reference Guide.

 

With Pro Tools|24 MIX, either a SYNC I/O 
or Universal Slave Driver (USD) can be used 
for frame edge accuracy.
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For Best Serial Deck Control

 

For best serial deck control, connect your deck 
as follows:

 

To connect a deck to a Windows computer:

 

■

 

Connect the computer’s COM port to the ma-
chine, using the provided 9-pin RS-322 to RS-
422 cable.

 

To connect a deck to a Macintosh computer:

 

1  

 

Connect a Keyspan USA28x USB serial adapter 
(not provided) to a USB port on the computer.

 

2  

 

Connect the provided male mini DIN-8 serial 
to male 9-pin D-sub Deck Control cable to the 
end of the adapter.

 

3  

 

Connect the end of the cable to the machine.

 

Remote 9-Pin Deck Emulation 
Requirements

 

SYNC I/O is required when running Machine-
Control 9-Pin Remote Deck Emulation mode, as 
it provides frame accurate LTC time code.

However, Remote 9-Pin Deck Emulation does 
not work via the serial ports on the SYNC I/O or 
via the DigiSerial ports on the Pro Tools|HD 
card. Instead, you must connect the remote con-
troller to your Pro Tools system in one of the fol-
lowing ways:

 

To connect a remote controller to a Windows 
computer:

 

■

 

Connect the Turnaround adapter to the RS-
322 to RS-422 cable, and connect them from an 
available serial or COM port on your computer 
to the 9-pin output of the machine.

 

To connect a remote controller to a Macintosh 
computer:

 

1  

 

Connect a Keyspan USA28x USB serial adapter 
(not provided) to a USB port on the computer.

 

2  

 

Connect the provided male mini DIN-8 serial 
to female 9-pin Deck Emulation cable to the end 
of the adapter.

 

3  

 

Connect the end of the cable to the machine.

 

About This Guide

 

This guide assumes:

• You have installed Pro Tools and verified 
that it works properly

• You have a thorough understanding of 
your video deck, external 9-pin decks, 
mixer, and other audio and video equip-
ment

• You have an understanding of your syn-
chronization equipment and requirements
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Conventions Used in This Guide

 

This guide uses the following conventions to in-
dicate menu choices and key commands:

The following symbols are used to highlight im-
portant information:

 

Digidesign Registration

 

Make sure to complete and return the registra-
tion card included with MachineControl. Regis-
tered users will receive periodic software update 
and upgrade notices. Refer to the registration 
card for information on technical support.

 

Convention Action

 

File > Save Session Choose Save Session from 
the File menu

Control+N Hold down the Control key 
and press the 

 

N 

 

key

Control-click Hold down the Control key 
and click the mouse button

Right-click (Windows) Click with the right mouse 
button

 

User Tips are helpful hints for getting the 
most from your system.

Important Notices include information that 
could affect your data or the performance of 
your system.

Cross References point to related sections in 
other Digidesign Guides.
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Installing MachineControl

Before you Begin

Before you install MachineControl, make sure 
that you have already connected and verified 
operation of your Pro Tools system.

If you are using a SYNC I/O, refer to its guide to 
make sure your equipment is installed and oper-
ating correctly.

Cables and Connections
MachineControl requires its own connections 
between Pro Tools hardware, the computer, and 
external machines. Connections differ depend-
ing on your Pro Tools hardware, computer sys-
tem, and on which of the two MachineControl 
operational modes you want to use: Serial Deck 
Control mode or Remote 9-Pin Deck Emulation 
mode.

Cables

MachineControl comes with the following ca-
bles and adapters, depending on your computer 
platform:

Windows Systems

Serial Deck Control Cable RS-232 to RS-422 ca-
ble, for serial time code and all other Machine-
Control functions.

Turnaround Adapter 9-pin adapter, used with RS-
232 to RS-422 cable, for Remote 9-Pin Deck Em-
ulation.

Macintosh Systems

Serial Deck Control Cable Male 8-pin mini-DIN 
to male 9-pin cable, for Deck Control.

Remote Deck Emulation Mode Cable Male 8-pin 
mini-DIN to female 9-pin cable, required for Re-
mote 9-Pin Deck Emulation.

Do not substitute 9-pin or serial adaptors 
for either MachineControl cable. Each cable 
is specifically wired for one operation mode.
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Serial Deck Control Mode

Serial Deck Control mode supports bi-direc-
tional communication between Pro Tools and a 
compatible external machine. Features include 
the ability to synchronize to serialized time 
code, arm tracks on the machine remotely, con-
trol multiple transports from Pro Tools, and 
configure machine settings and options.

Pro Tools|HD

On HD-series systems, you can use a Serial to 9-
pin connection or a 9-pin to 9-pin connection 
for Serial Deck Control mode.

CPU to Deck Connection This type of connec-
tion yields the best performance, especially with 
linear decks. Use the included Serial Deck Con-
trol cable for this type of connection.

SYNC I/O to Deck Connection This type of con-
nection is suitable for non-linear decks. If you 
are using a SYNC I/O, as many as two machines 
can be connected to the two 9-pin Out ports on 
the SYNC I/O. You can control one machine at a 
time, and switch between them from within 
Pro Tools. These ports support all Machine-
Control modes except Remote 9-Pin Deck Emu-
lation mode. For Remote Deck Emulation mode 
on Macintosh systems, a Keyspan USA28x USB 
serial adapter is required.

Pro Tools|24 MIX and Pro Tools|24

On Pro Tools|24 MIX and Pro Tools|24 systems, 
a Serial to 9-pin connection is required for Serial 
Deck Control mode. (Use of the 9-pin Out ports 
on the SYNC I/O is not supported with 
Pro Tools|24 MIX or Pro Tools|24 systems.)

If you are not using a SYNC I/O, you can use the 
included Serial Deck Control cable for Serial 
Deck Control mode.

Remote 9-Pin Deck Emulation 
Mode

This mode enables a form of deck emulation in 
Pro Tools. When the Remote 9-Pin Deck Emula-
tion Mode cable is used on a supported system, 
Pro Tools can respond to record-arming, trans-
port, and other standard 9-pin commands from 
an external machine. 

While in Remote 9-Pin Deck Emulation mode, 
Pro Tools always generates time code, and can 
be either the time code master or a slave device.

On Windows systems, Remote 9-pin Deck Emu-
lation mode uses an RS-232 to RS-422 cable and 
a Turnaround adapter connected to an available 
serial or COM port on the computer.

On Macintosh systems, use the Remote 9-Pin 
Emulation Mode cable. This mode requires a 
Keyspan USA28x serial adapter connected to a 
computer USB port, and a properly wired con-
figuration. See Chapter 5, “Remote 9-Pin Deck 
Emulation Mode (Configuration and Opera-
tion)” for details.
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Connecting Machines
Separate instructions follow for Pro Tools|HD 
and Pro Tools|24 MIX systems. Follow the in-
structions that correspond to your system. 

Pro Tools|HD Systems

Serial Control Mode

For Best Serial Deck Control

For best serial deck control, connect your deck 
as follows:

To connect a deck to a Windows computer:

■ Connect the computer’s COM port to the ma-
chine, using the provided 9-pin RS-322 to RS-
422 cable.

To connect a deck to a Macintosh computer:

1  Connect a Keyspan USA28x USB serial adapter 
(not provided) to a USB port on the computer.

2  Connect the provided male mini DIN-8 serial 
to male 9-pin D-sub Deck Control cable to the 
end of the adapter.

3  Connect the end of the cable to the machine.

For Limited Serial Deck Control (Non-Linear 
Decks Only)

◆ Connect a standard 9-pin cable from one of 
the 9-pin Out ports on the SYNC I/O to the 9-
pin input of the machine. Due to performance 
limitations, this configuration should be used 
primarily with non-linear decks.

Remote 9-Pin Deck Emulation Mode

To connect a machine for Remote 9-Pin Deck 
Emulation mode (Windows Systems):

■ Connect the Turnaround adapter to the RS-
322 to RS-422 cable, and connect them from an 
available serial or COM port on your computer 
to the 9-pin output of the machine.

Do not use the DigiSerial port on your HD Core 
card or the 9-pin ports on the SYNC I/O for Re-
mote 9-Pin Deck Emulation mode. The Digi-
Serial port should only be used for SYNC I/O 
connections, using a DigiSerial cable.

To connect a machine for Remote 9-Pin Deck 
Emulation mode (Macintosh Systems):

1  Connect a Keyspan USA28x USB serial adapter 
(not provided) to a USB port on the computer.

2  Connect the provided male mini DIN-8 serial 
to female 9-pin Deck Emulation cable to the end 
of the adapter.

3  Connect the end of the cable to the machine.

Do not use the DigiSerial port on your HD Core 
card or the 9-pin ports on the SYNC I/O for Re-
mote 9-Pin Deck Emulation mode. The Digi-
Serial port should only be used for SYNC I/O 
connections, using a DigiSerial cable.
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Pro Tools|24 MIX and Pro Tools|24 
Systems

Serial Control Mode

To connect a machine for Serial mode:

■ Connect the Serial Deck Control (male 9-pin) 
cable from an available serial or COM port (or 
serial adapter connected to a computer USB 
port) to the 9-pin input on the machine.

Remote 9-Pin Deck Emulation Mode

To connect a machine for Remote 9-Pin Deck 
Emulation mode:

■ Connect the Remote Deck Emulation Mode 9-
Pin cable (male 8-pin mini-DIN to female D9) 
from an available serial or COM port on your 
computer (or serial adapter connected to a com-
puter USB port) to the 9-pin output of the ma-
chine.

Do not use the DigiSerial port on your Pro Tools 
Core card for Remote 9-Pin Deck Emulation 
mode. 

Installing MachineControl 
Software 
To install MachineControl, use the Pro Tools In-
staller CD-ROM.

To install MachineControl (Windows):

1  Start Windows, logging in with Administrator 
privileges. For details on Administrator privi-
leges, refer to your Windows documentation.

2  Insert the Pro Tools Installer CD-ROM for 
Windows in your CD-ROM drive. Locate and 
open the Pro Tools Installer folder, and double-
click the Setup icon.

3  Click Next to begin installation.

4  Select the install location. For maximum reli-
ability, install MachineControl on your startup 
drive. Click Next.

5  From the list of optional items, click Machine-
Control.

Wait for the installer to finish installing all soft-
ware components, drivers, and PACE System 
files before proceeding to the next step.

6  Follow the on-screen instructions to complete 
installation.

7  When installation is complete, click Finish to 
restart your computer.

To install MachineControl (Macintosh):

1  Make sure you are logged in as an Administra-
tor for the account where you want to install 
MachineControl. For details on Administrator 
privileges in Mac OS X, refer to your Apple OS X 
documentation. 

2  Insert the Pro Tools Installer CD-ROM in your 
CD-ROM drive. Double-click “Install Pro Tools.”
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3  Enter your Mac OS X Administrator password 
and click OK to authenticate the installation. 

4  From the list of optional items, click Machine-
Control.

5  Click Install.

6  When installation is complete, click Restart.

Starting Up Your System
To ensure that the components of your 
Pro Tools system communicate properly with 
each other and your external machines, start 
them in a particular order.

Start up your Pro Tools system in this order:

1  For systems with an expansion chassis, turn 
on the chassis.

2  Turn on any external hard drives. Wait ap-
proximately ten seconds for them to come up to 
speed.

3  Turn on any external machines (VTR, ATR, 
synchronizer, and monitors). 

4  Turn on any MIDI interfaces, MIDI devices 
and synchronization peripherals.

5  Lower the volume of all output devices in 
your system.

6  Turn on Pro Tools audio interfaces. Wait at 
least fifteen seconds for your system hardware to 
initialize. 

7  Turn on your computer.

8  Launch Pro Tools. 

Machine Local and Remote Modes

Be sure to set your machine-controllable device 
to “remote” or “ext” mode to receive the 9-pin 
information (not “local” or front-panel mode). 
With some supported machines, if all other 
communication is established and the machine 
is not in remote mode, Pro Tools will indicate 
machine “local” mode.

Authorizing MachineControl
The MachineControl is authorized using the 
iLok USB Smart Key and License Card from 
PACE Anti-Piracy.

The iLok is similar to a dongle, but unlike a don-
gle, it is designed to securely authorize multiple 
software applications from a variety of software 
developers.

This key can hold over 100 authorizations for all 
of your iLok-enabled software. Once an iLok is 
authorized for a given piece of software, you can 
use the iLok to authorize that software on any 
computer.

License Cards are specific to each plug-in or soft-
ware option. You will receive the appropriate Li-
cense Cards for the plug-ins and options that 
you purchase. License Cards have a small 
punch-out plastic chip called a GSM cutout. 

The iLok USB Smart Key is not supplied 
with your MachineControl. Use the iLok 
that is included with Pro Tools|HD Core 
system, or purchase one separately.

For additional information about iLok tech-
nology and authorizations, see the elec-
tronic PDF of the iLok Usage Guide.
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To add an authorization to an iLok:

1  Insert the iLok into an available USB port on 
your computer.

2  Launch Pro Tools. You will be prompted to au-
thorize any installed unauthorized plug-ins or 
software options.

3  Follow the on-screen instructions until you 
are prompted to insert the License Card into the 
iLok.

4  Separate the GSM cutout from the larger pro-
tective card by pulling it up and out with your 
thumb. Do not force the cutout down with your 
finger.

5  Insert the GSM cutout into the iLok. Visually 
verify that the metal portion of the cutout 
makes contact with the iLok’s metal card reader.

6  Follow the on-screen instructions to complete 
the authorization process.

7  After the authorization has completed, re-
move the GSM cutout from the iLok. (If you 
have to remove the iLok from the computer to 
remove the cutout, be sure to re-insert the iLok 
in any available USB port on your computer 
when you are finished.)

Removing MachineControl
If you let a demo version of MachineControl ex-
pire, you should remove it from your system. 
Otherwise, each time you open Pro Tools you 
will be prompted with a message that it has ex-
pired.

Windows

To remove an expired version of a plug-in or 
software option:

1  From the Start menu, choose Settings > Con-
trol Panel and double-click Add or Remove Pro-
grams.

2  Select the expired plug-in or software option 
from the list of installed applications and click 
the Change/Remove button. 

3  When removal is complete, click OK to close 
the window. 

Mac OS X

To remove an expired plug-in or software option:

1  Open the Plug-Ins folder or Plug-Ins (Unused) 
folder on your Startup drive (Library /Applica-
tion Support/Digidesign/Pro Tools). 

2  Drag the expired plug-in or option to the 
Trash.

3  Empty the Trash.

If you are already using a demo version of 
the MachineControl, launch Pro Tools be-
fore you insert the iLok, then insert the iLok 
into any available USB port when prompted 
by Pro Tools.

iLok with License Card
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chapter 3

Setting Machine Control

Online and Offline Operation
Pro Tools can remotely control, or be controlled 
by, any approved enabled external source or de-
vice. That device is selected using the Transport 
Master selector in the Pro Tools Transport win-
dow. 

To trigger Pro Tools playback or recording from 
an external source, or to generate time code, the 
Pro Tools Transport needs to be online. There are 
four ways to put the Pro Tools Transport online:

• Click the Online button in the Transport 
window.

• Choose Operation > Online.

• Press Control+J (Windows) or Command+J 
(Macintosh).

• Press Alt+Spacebar (Windows) or Op-
tion+Spacebar (Macintosh). 

The Online button in the Transport window in-
dicates online status. It flashes while enabled 
and waiting for synchronization, and stays lit 
when lock is achieved. 

Transport Controls
With MachineControl, the Pro Tools Transport 
window becomes a multi-function controller. 

Counter Display

The Pro Tools Edit window counter displays the 
current machine (9-pin) or session time code lo-
cation, depending on which device is the trans-
port master, plus any current Session Start Time 
Offsets being applied. (See “Session Start Off-
sets” on page 24 for more information. 

The Incoming Time display in the Session Setup 
window always shows absolute incoming time 
code, without any offsets. 

To select a Transport Master:

1  Click the Transport Master selector (directly 
below the Online button in the Transport win-
dow) to display the Transport pop-up menu. 

Transport controls

Online button

Transport and machine Online selectors

Selecting the Transport master

Transport Master selector

Online button
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2  From the Transport pop-up menu, select 
Pro Tools, Machine, or Remote (or Remote/LTC.

Transport = Pro Tools

In this mode, the controls in the Transport win-
dow are focused on Pro Tools playback and re-
cording.

◆ When the transport is online, the machine 
slaves to Pro Tools, and the session locks to the 
machine’s time code. The machine follows Pref-
erences for Machine Chase and Online Record.

◆ When the transport is offline, the Pro Tools 
Transport window controls Pro Tools only.

Transport = Machine

In this mode, the controls in the Transport win-
dow are focused on the machine connected and 
enabled for Serial Deck Control mode. Record 
commands are sent to the machine only.

◆ When the transport is online, Pro Tools slaves 
to the machine. The Pro Tools Transport con-
trols the machine, and Pro Tools chases and 
locks to the machine.

In addition, when Auto Spot is turned on, re-
gions are spotted to the current machine time, 
and the Trimmer tool trims to the current ma-
chine time. 

◆ When the transport is offline, the Pro Tools 
Transport window controls the machine only. 

Toggling the Transport while Online

When the transport is online, toggling the 
Transport Master selector between Pro Tools 
and your machine will also toggle their mas-
ter/slave relationship.

Transport = Remote (or Remote LTC)

◆ In Remote 9-Pin Deck Emulation mode, when 
the transport is online, Pro Tools responds to 
commands sent by the master 9-Pin machine. 
Many Pro Tools commands, including transport 
controls, are inactive as controls are handed off 
to the machine controller when the Pro Tools 
transport is online. 

Pro Tools will generate time code when online 
and playing in Full Remote mode, but will chase 
time code when in Remote/LTC Chase. 

◆ In Remote 9-Pin Deck Emulation mode, when 
the transport is offline, Pro Tools operates in Lo-
cal mode and ignores commands from the 9-pin 
machine controller. Pro Tools responds only to 
requests from the 9-pin machine controller for 
machine type and status, and responds that it is 
in Local mode.

For more information, see Chapter 5, “Remote 
9-Pin Deck Emulation Mode (Configuration and 
Operation).”

You can also press Control+backslash (\) to 
toggle between Pro Tools, the Machine, and 
Remote transport (or, on a Digidesign con-
trol surface, press EXT TRANS). 

Refer to the Pro Tools Reference Guide for 
details on Auto Spotting.
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Online Display Information

Several display elements of the Edit and Trans-
port windows provide machine status informa-
tion. 

◆ When Pro Tools is online, the Transport on-
line button flashes. “Waiting for Sync” will be 
displayed in the status box in the lower left cor-
ner of the Edit window.

◆ The online button continues to flash until 
you click Play and time code lock occurs (all de-
vices locked and responding in sync). 

◆ The Time Code display in the Edit window 
shows the Machine Time when the machine is 
Master.

◆ Upon lockup, the display switches to show 
the session time.
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chapter 4

Serial Deck Control Mode 
(Configuration and Operation)

Serial Deck Control mode is available whenever 
MachineControl is connected using the Serial 
Deck Control cable. For more information about 
connecting Pro Tools for Serial Deck Control 
mode, see Chapter 2, “Installing Machine-
Control.” 

When connected for Serial Deck Control mode, 
MachineControl enables all Pro Tools track 
arming, synchronization, and transport fea-
tures, as available on your system. Serial Deck 
Control mode also supports 9-pin serial time 
code (see “Serial Time Code” on page 20). Some 
features require a SYNC I/O, as noted through-
out this chapter.

Configuring Pro Tools for Serial Deck 
Control (Overview)

To configure Pro Tools for Serial Deck Control, do 
the following:

1  Open an existing session, or create a new one, 
in order to have access to the Pro Tools Prefer-
ences and Session Setup windows.

2  Configure Pro Tools session settings in the Ses-
sion Setup window. (See“Session Setup Window 
and MachineControl” on page 22.)

3  Set up a MachineControl device. (See “Setting 
Up a MachineControl Device for Deck Control” 
on page 18.)

4  If desired, create your own deck profile. (See 
“Remote Track Arming” on page 29 for more 
information.)

5  Configure Pro Tools Machine Control prefer-
ences and Online Options in the Preferences 
window. (See“Preferences for Serial Deck Con-
trol Mode” on page 20.)

6  If desired, redefine the current time code or 
feet+frames position. (See “Additional Pro Tools 
Commands” on page 25.)

7  In the Pro Tools Transport window, select 
Pro Tools or Machine as the Transport master. 
(See “Machine Pre-Roll” on page 19.)

8  Use the transport to play back material. Select 
Transport = Pro Tools or Transport = Machine. 
(See “Playback in Serial Deck Control Mode” on 
page 27.)

You are now ready to begin machine playback.

For information on track arming, see “Re-
mote Track Arming” on page 29.
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Setting Up a MachineControl 
Device for Deck Control
This section covers the basic steps for setting up 
a MachineControl device for Serial Deck Con-
trol mode.

To set up a MachineControl device:

1  In Pro Tools, choose Setups > Peripherals.

2  Click the Synchronization tab.

3  Configure your synchronization peripheral 
(device) as necessary. If you are using a 
SYNC I/O, it is automatically detected and con-
figured by Pro Tools.

4  Click the Machine Control tab in the Periph-
erals window.

5  In the 9-pin Serial section, click Enable.

6  Use the Port pop-up menu to select the 9-pin 
MachineControl port. The available choices will 
depend on your platform and configuration. 

7  If necessary, select Sony 9-pin from the Ma-
chine Type pop-up menu.

After you select a port, Pro Tools automatically 
polls the port to see what kind of machine is 
connected. This process is referred to as auto de-
tection. One of the following will occur:

◆ If the machine is recognized, Pro Tools loads 
the corresponding Machine Type and Node. 
This includes the corresponding track layout 
and automatically enters the name of that ma-
chine into the Pro Tools Machine Track Arming 
window. 

◆ If the machine is not recognized, the 
“generic1” personality is automatically loaded. 

8  If you want to choose a different machine pro-
file (for example, to use a different track layout), 
choose it from the Node pop-up menu. 

9  Set machine pre-roll for use in Transport = 
Pro Tools. (See “Machine Pre-Roll” on page 19 
for more information.)

Configuring MachineControl for 9-pin Serial Deck 
Control

Pro Tools lets you define and save custom 
machine profiles. See “Remote Track Arm-
ing” on page 29 for more information. 

Machine pre-roll is set in the Machine Con-
trol window. This is different than the main 
transport pre-roll that is set in the Trans-
port window.
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10  If you are using a SYNC I/O with 
Pro Tools|HD, and if you have two machines 
connected to the two 9-pin Out ports on the 
SYNC I/O, repeat the above steps for the second 
machine. (See “Selecting Machines in Serial 
Deck Control Mode” on page 19 for more infor-
mation.)

11  Click OK to close the Peripherals dialog.

Machine Pre-Roll

You can set a variable amount of machine pre-
roll to account for the time it may take the ma-
chine to achieve servo lock. Shorter pre-roll val-
ues are usually better for non-linear machines. 
Longer pre-roll values are usually better for older 
tape transports.

The Machine pre-roll value is added to any pre-
roll specified in the Pro Tools Transport window.

To set MachineControl pre-roll:

1  In Pro Tools, choose Setups > Peripherals.

2  Click the Machine Control tab.

3  In the 9-pin Serial section, enter the number 
of frames of pre-roll.

4  Click OK. 

Selecting Machines in Serial Deck 
Control Mode

When using the Digidesign SYNC I/O with two 
machines connected to its 9-pin ports, use the 
Peripherals dialog to choose a deck to control. 

To choose machines for Serial Deck Control mode:

1  In Pro Tools, choose Setups > Peripherals, and 
click the Machine Control tab. 

2  In the 9-Pin Serial section, click Enable to en-
able 9-pin Serial Deck Control mode. 

3  Select the port for your first machine, if neces-
sary (9-pin #1 of the SYNC I/O). Machine-
Control will auto-detect and select the machine 
type it finds connected to the selected port. 

4  If necessary, select a different Machine Type 
that better matches your device. 

5  Repeat the above steps to auto-detect and se-
lect any machine connected to 9-pin #2 on the 
SYNC I/O (select 9-pin port #2 in the 9-Pin Serial 
Port selector). 

6  When the appropriate machine is enabled and 
selected, enable Use Serial Time Code for Posi-
tional Reference. 

Do not use the designated machine serial 
port for any other function (such as time 
code or MIDI metronome). Make sure that 
9-pin is the only communication on the se-
lected port. 

If you are using a Digidesign SYNC I/O con-
nected to your DigiSerial port, and your ma-
chine has time code reader capability, you 
can route less cables by checking the Use Se-
rial Timecode for Positional Reference op-
tion.
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Serial Time Code

If you are using a Digidesign SYNC I/O con-
nected to your DigiSerial port, and your ma-
chine has 9-pin time code reader capability, you 
can take advantage of serial time code to achieve 
faster lockup times. 

Serial time code can only be supplied by ma-
chines with built-in time code readers which 
can serialize the time code when Machine-
Control requests it. Most professional machines 
have such readers (such as Beta, DA-88, D2, 
Digi-Beta, and some 3/4-inch decks).

To enable Serial Time Code:

1  In Pro Tools, choose Setups > Peripherals and 
click Synchronization.

2  Make sure the SYNC I/O (or USD) and DigiSe-
rial port are the selected device and port.

3  Ensure that both the SYNC I/O (or USD) and 
the external machine are locked to the same 
video reference signal. 

4  Click the Machine Control tab in the Periph-
erals window to open the Machine Control 
page. 

5  Enable Use Serial Time Code for Positional 
Reference. 

Serial Time Code and SYNC I/O 
Settings

When Serial Time Code is enabled, the 
Pro Tools Clock Reference switches to Video 
Reference. Additionally, the Positional Refer-
ence pop-up is grayed out and displays Serial 
Time Code. (These controls are located in the 
SYNC I/O Settings section of the Session Setup 
window.)

Generate and Serial Time Code

Pro Tools automatically puts the SYNC I/O (or 
USD) in Generate mode and prohibits any 
changes to the Positional and Clock Reference 
settings. While Serial Time Code is being used, 
this Generate mode is engaged to calculate 
frame-edge accuracy in Pro Tools. 

Preferences for Serial Deck 
Control Mode
Preferences for online recording and Machine-
Control chase options are available while work-
ing with external time code (LTC).

In Pro Tools 6.4, online options are on the Ma-
chine Control page in the Preferences dialog.

In Pro Tools 6.2.x and lower, these options are 
on the Operation preferences page).

Serial TIme Code enabled in the Peripherals dialog

Online Options and Machine Control preferences, in the 
Operations tab (Pro Tools 6.2.x and lower)
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To set Serial Deck Control mode Machine Control 
options:

1  Open an existing session, or create a new one, 
in order to have access to the Pro Tools Prefer-
ences window.

2  Choose Setups > Preferences.

3  Click the Machine Control tab (Pro Tools 6.4) 
or the Operations tab (Pro Tools 6.2.x and 
lower). 

4  Select or set the following Machine Control 
options:

Machine Chases Memory Location The machine 
chases Pro Tools memory location selections. 
The machine will not locate with pre-roll, but 
will instead park on the desired frame for Auto 
Spotting. 

Machine Follows Edit Insertion/Scrub Pro Tools 
sends locate commands to the external deck 
whenever the timeline selection changes.

Machine Cues Intelligently When enabled, if you 
navigate to a cue point that is more than 10 sec-
onds from the current location, Pro Tools will 
command a connected transport to shuttle to 
the desired location at full speed, to within 10 
seconds of the cue point. Cueing will then slow 
to normal speed until the point is reached. 

Stop At Shuttle Speed Zero When enabled, 
Pro Tools sends a Stop command when shuttle 
speed equals zero. While most machines auto-
matically stop when shuttle speed is equal to 
zero (in other words, whenever you stop shut-
tling), some machines require an explicit stop 
command to park correctly. Consult the manu-
facturer of your machine if you need to deter-
mine its shuttle stop capability. 

Delay Before Locking to LTC Lets you enter a 
number of frames for Pro Tools to wait upon re-
ceiving incoming LTC, before attempting to 
lock to the incoming time code signal. This de-
lay gives a variable amount of frames for the 
LTC source to stabilize. This lets Pro Tools lock 
more accurately to any fluctuations that can oc-
cur when some LTC sources are first engaged. 

5  Click Done to close the dialog.

To set Serial Deck Control mode Online options:

1  Open an existing session, or create a new one, 
in order to have access to the Pro Tools Prefer-
ences window.

2  Choose Setups > Preferences.

3  Click the Machine Control tab (Pro Tools 6.4) 
or the Operations tab (Pro Tools 6.2.x and 
lower). 

4  Select or set the following Online options:

Record Online at Time Code (or ADAT) Lock On-
line recording begins as soon as Pro Tools re-
ceives and locks to time code.

Record Online at Edit Insertion/Selection  On-
line recording begins at the current Edit selec-
tion start or playback location. 

5  Click Done to close the Operations dialog.
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Session Setup Window and 
MachineControl 

The Session Setup window controls are orga-
nized into three sections. 

Session Information and Controls This section is 
always displayed at the top of the Session Setup 
window. Displays are provided for the sessions’ 
sample rate, bit depth, audio format, and 
Mac/PC compatibility status. Fields and pop-up 
menus are provided for setting Session Start 
time, Incoming Time, Clock Source, and Frame 
Rate (Pro Tools 6.2.x and lower). Pro Tools 6.4 
systems also includes pop-up menus to change 
System Delay, Fader Gain, Time Code Rate, and 
Feet+Frame Rate.

SYNC Setup & Session Offsets This section lets 
you configure controls of the Digidesign 
SYNC I/O. Settings are provided for Clock and 
Positional Reference, Video Format, and Vari-
able Speed Override.

Time Code Settings This section lets you config-
ure various Time Code settings, including Using 
SYNC Generator, Freewheel, and Audio and 
Video Pull Up/Down amounts.

Viewing SYNC Setup & Session Offsets or Time 
Code Settings

The Synchronization and Session Offsets section 
and the Time Code Settings section can be 
shown or hidden by clicking the corresponding 
show/hide buttons.

To show SYNC Setup and Session Offsets:

■ Click the SYNC Setup and Session Offsets 
show/hide button.

Figure 1.  Session Setup window

Clock Source

Session displays 
and settings

SYNC Setup

Time Code 
settings

Session Offsets

click to show/hide 

click to show/hide
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To show Time Code settings:

■ Click the Time Code Settings show/hide but-
ton.

Session Settings and 
MachineControl

Use the steps in this section to quickly configure 
the basic session settings for MachineControl. 
These include session settings (start time, frame 
rate, and video format), as well as synchroniza-
tion settings for clock and positional reference. 
Additional options include multiple time code 
display offsets, generator, freewheel, and pull up 
and pull down settings.

For additional settings see the Pro Tools Refer-
ence Guide

Basic Session Settings

Confirm the following settings for each session. 

To configure a session for MachineControl:

1  Open an existing session, or create a new one, 
in order to have access to the Pro Tools Session 
Setup window.

2  Choose Windows > Show Session Setup.

3  In the Status and Display section, do the fol-
lowing: 

• Set a Session start time. 

• Set the appropriate session Timecode Rate 
(Pro Tools 6.4) and Feet+Frames Rate 
(Pro Tools 6.4), or frame rate (Pro Tools 
6.2.x and lower).

4  In the SYNC Setup section, set the appropriate 
format for NTSC or PAL using the Frame Rate 
and Video Format selectors. 

Clock Source, Clock and Positional 
Reference

The Session Setup window provides selectors for 
the system Clock Source, as well as Clock and 
Positional Reference. These settings must be 
configured based on the signal connections be-
tween Pro Tools, the SYNC I/O, and external de-
vices. 

To configure Clock Source and Reference 
settings, do one of the following:

Pro Tools|HD In Session Setup, choose an appro-
priate Clock Source (the SYNC I/O, or an HD-se-
ries audio interface). Configure the Clock Refer-
ence and Positional Reference menus as 
appropriate. See the SYNC I/O Guide for more in-
formation.

Pro Tools|24 MIX Set the Ch 1–2 Input and ses-
sion Sync Mode as necessary. (Sync Mode must 
be set to analog for the SYNC I/O to be clock 
master.)

Basic session settings in the Session Setup window 
(Pro Tools 6.2.x)

Video Format selector

Incoming Time display

Session Start Time

Frame Rate

click to 
show/hide

Video Format
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Testing Basic Session Settings

To check your session and MachineControl set-
tings, place the machine in Local mode and 
manually start playback on the external ma-
chine. If Pro Tools is receiving time code, the 
current location will be shown in the Incoming 
Time display. Be sure to reset the machine to Re-
mote mode when finished. 

Session Start Offsets

With Pro Tools 6.x and higher, you can offset 
the display of incoming time code in the 
Pro Tools application. This is useful when you 
want to adjust the display of time code to match 
the start time of the session (such as with source 
material that starts at a different time), or com-
pensate for source material that is consistently 
offset by a fixed number of frames (such as with 
some color–corrected video masters). 

Pro Tools provides three different types of Ses-
sion Start Time Code Offset settings. These off-
sets include:

• MMC (MIDI Machine Control)

• 9-Pin (Serial machine control)

• Synchronization peripherals such as the 
SYNC I/O, USD, or other peripherals (for ex-
ample, MIDI interfaces that provide MIDI 
Time Code). 

Unique values can be defined for each of these 
three types offsets, or you can link all three to 
adjust in unison. 

Positive and negative offset values can be en-
tered to offset Pro Tools time code display later 
or earlier, respectively. 

Offsets and Time Code Displays

The SYNC I/O Time Code Display continues to 
display actual incoming time code, regardless of 
any Session Start Offset applied in Pro Tools.

To apply an offset to the session start time:

■ In the Session Setup window, enter a new Ses-
sion Start time in an offset field. 

To apply the same session start time to all 
devices:

■ In the Session Setup window, select Link to 
apply the same offset value to all devices. 

Time Code Settings

The Time Code settings control time code gen-
eration, Freewheel, and session Pull Up and Pull 
Down options.

Configure these settings as appropriate for the 
current project and situation. (For complete in-
structions, refer to the Pro Tools Reference Guide 
and the SYNC I/O Guide.)

Time Code Reader Offset

The Time Code Reader Offset lets you set a “trig-
ger offset” for incoming MIDI Time Code, in 
samples. (In previous versions of Pro Tools, this 
feature was called Sync Offset.) You can use Time 
Code Reader Offset to compensate for the la-
tency of a MIDI sound module or other MIDI de-
vice chain. 

Incoming Time display

Incoming Time display

Session Start Offsets in the Session Setup window
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Additional Pro Tools 
Commands
The following commands are available in all 
MachineControl operating modes. 

Redefine Current Time Code Position

Use this command to redefine the current time 
code position and session start time. By creating 
an insertion point (or selection), and then enter-
ing the desired new time code position for that 
location, the session start time will be recalcu-
lated based on the new, relative Time Code loca-
tion.

For example, if you place an insertion point at 
01:02:04:11, select Edit > Redefine Current Time 
Code Position, and enter 01:00:08:00 to corre-
spond to the first frame of film, this adjusts the 
session start time such that the insertion point 
location is now 01:00:08:00.

In Pro Tools 6.4, this command is located in the 
Setups menu. In Pro Tools 6.2.x, this command 
is located in the Edit menu.

To redefine the current time code location:

1  Enable Link Edit/Timeline. 

2  Locate Pro Tools to the beginning of the rele-
vant material (usually the first audio of a scene, 
a 2 pop, or similar). 

3  If appropriate, cue the external time code 
source to the appropriate location (this will be 
the location to which you want to align the cur-
rent Pro Tools insertion point). Note the time 
code location, or copy it to the clipboard. 

4  Choose Setups > Redefine Current Time Code 
Position (Pro Tools 6.4) or Edit > Redefine Cur-
rent Time Code Position (Pro Tools 6.2.x and 
lower).

5  Enter the new time code position.

6  Click OK. 

Redefine Current Feet+Frames Position

(Pro Tools 6.4 Only)

Use this command to redefine the current 
Feet+Frames position. By creating an insertion 
point (or selection), and then entering the de-
sired new Feet+Frames position for that loca-
tion, the session start time will be recalculated 
based on the new, relative Feet+Frames location.

Typically, this command is used for integrating 
test tones, pre-roll, and similar pre-program ma-
terial into the Pro Tools session ahead of the first 
hour time code position on the timeline. In 
most cases when working on reels of film, the 
user will want to set the first hour mark in the 
session to equal 0+0 feet and frames, to line up 
properly with the start of the Academy leader 
for each reel of film.

Redefining the current time code position
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To set a relative frame position for a session 
(Feet+Frames):

■ Choose Setups > Redefine Current 
Feet+Frames Position and enter a Feet+Frame 
position to correspond to the time code shown 
in the dialog.

Create Machine Track Arming Profile

The Create Machine Track Arming Profile com-
mand lets you create and save machine descrip-
tions as Machine Profiles. Profiles are provided 
for an ever-increasing list of common machines, 
or you can customize profiles for specific situa-
tions and requirements. Options include the 
ability to emulate a different machine type, 
remap and rename audio tracks, and choose to 
include or exclude the video and time code 
tracks, when available. For more information, 
see “Creating a Track Arming Profile” on 
page 30. 

Feet.Frames Command

(Pro Tools 6.2.x Only)

For sessions in which feet and frames are the 
time scale of reference, the Feet.Frame com-
mand (located in the Setups menu), lets you en-
ter a Start Frame based on an appropriate frame 
location at the beginning of your project tape. 
The Feet.Frame Ruler will then use this value as 
its start reference.

Selecting Pro Tools or the 
Machine as the Transport 
Master
In Serial Deck Control mode, the deck is always 
the time code master. However, the start of ma-
chine playback changes based on the transport 
master mode you are using. 

The setting of the Transport Master (located in 
the Pro Tools Transport window) determines 
where the deck will start playback when the 
Pro Tools transport sends a play command to 
the deck Control, as follows:

Transport = Pro Tools In this mode, the Trans-
port window controls the Pro Tools timeline po-
sition (playback and recording). When online, 
and Play is pressed in the Pro Tools transport, 
the deck locates relative to the current Pro Tools 
timeline.

◆ When the transport is online, the machine lo-
cates to a position ahead of the current timeline 
insertion point. This location ahead is equal to 
the sum of the machine pre-roll and the trans-
port pre-roll. Once the machine has located to 
this total pre-roll position, it plays, sending time 
code to Pro Tools which chases that incoming 
time code. The machine follows the Preferences 
settings for Serial Deck Control. (See “Prefer-
ences for Serial Deck Control Mode” on 
page 20.)

◆ When the transport is offline, the Pro Tools 
Transport window controls Pro Tools only.

◆ All record commands are sent to Pro Tools, 
not the deck.

Transport = Machine In this mode, the Transport 
window controls the machine connected and 
enabled for Serial Deck Control mode. Record 
commands are sent to the machine only. When 

Redefine Current Feet+Frame Position dialog
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online and a Play command is given, the ma-
chine plays from its current location, feeding 
time code to Pro Tools, which chases that in-
coming time code from the deck.

◆ When the transport is online, Pro Tools 
chases the time code coming from the machine. 
The Pro Tools Transport controls the machine, 
and Pro Tools chases and locks to the machine.

◆ All record commands in this mode are di-
rected to the deck only.

◆ In addition, when Auto Spot is turned on, re-
gions are spotted to the current machine time, 
and the Trimmer tool trims to the current ma-
chine time. 

◆ When the transport is offline, the Pro Tools 
Transport window controls the machine only. 

To select a Transport Master:

1  In Pro Tools, click the Transport Master selec-
tor (directly below the Online button in the 
Transport window) to display the Transport 
Master pop-up menu. 

2  From the Transport Master pop-up menu, se-
lect Pro Tools or Machine.

Toggling the Transport while Online

When the transport is online, toggling the 
Transport Master selector between Pro Tools 
and your machine will also toggle their mas-
ter/slave relationship.

Playback in Serial Deck 
Control Mode

To play or cue your machine independently of 
Pro Tools:

1  Select Transport > Machine in the Pro Tools 
Transport window. 

2  Make sure Pro Tools is not online (the Online 
button in the Transport window is not flashing). 

3  Click any of the buttons in the Pro Tools 
Transport window to control your machine.

Pro Tools always displays incoming LTC or 9-
pin time in the incoming time field in the Ses-
sion Setup window during fast-wind, and 
switches during playback to display the current 
positional reference. 

To automatically locate your deck to pre-roll into 
your current timeline insertion time each time you 
hit play:

1  Select Transport > Pro Tools in the Pro Tools 
Transport window. 

2  Put Pro Tools online.

3  Click Play in the Transport window.

Refer to the Pro Tools Reference Guide for 
details on Auto Spotting.

Selecting the Transport master

Transport Master selector

Online button

You can also press Control+backslash (\) to 
toggle between Pro Tools, the Machine, and 
Remote transport (or, on a Digidesign con-
trol surface, press EXT TRANS). 
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If the tape in the machine is striped with time 
code that matches your Session time, the ma-
chine will locate to the total pre-roll position 
ahead of the Pro Tools on-screen selection/in-
sertion point or memory location, and begin 
playing back. Pro Tools will chase its time code 
output.

Machine Remote Setting

If the Transport Master selector will not stay set 
to Machine, or if it suddenly switches to 
Pro Tools from Machine, check your machine’s 
Local/Remote setting. It should be set to Remote 
to receive commands from the Pro Tools trans-
port. 

Machine Cueing

MachineControl provides two Cue modes for re-
mote machine operation: Search and Hi-speed. 

◆ In Search mode, the tape remains laced during 
Fast Forward or Rewind. 

◆ In Hi-speed mode, the tape is unlaced before 
fast-forward/rewind. The Pro Tools Transport 
window indicates the status of the tape as de-
scribed below.

Search Mode

In Search mode, the tape is laced against the 
heads when the machine is paused or searching, 
and the Stop button stays lit (it does not flash) 
and the Play button flashes. When cueing in 
this mode, the Fast Forward or Rewind button 
also lights when searching in either direction.

To fast forward and rewind in Search mode: 

1  Select Transport > Machine in the Pro Tools 
Transport window.

2  Click Play in the Transport window or press 
the Spacebar to begin machine playback, then 
press the Spacebar again to pause the machine 
(this is to ensure that the tape is laced).

3  Click Fast Forward or Rewind in the Transport 
window to search the tape.

Hi-Speed Mode

In Hi-speed mode, the tape is unlaced, and all 
Transport buttons are dark. While cueing in this 
mode, only the selected Fast Forward or Rewind 
button lights.

To fast forward and rewind in Hi-speed mode:

1  Select Transport > Machine in the Pro Tools 
Transport window.

2  Press Command+period (.) or click Stop in the 
Transport window to unlace the tape.

3  Click Fast Forward or Rewind in the Transport 
window. The Pro Tools cursor indicates the cur-
rent machine location.

4  Press the Spacebar to pause the machine. 

Some devices, including several popular 
VHS decks, do not support a shuttle mode 
in which the tape stays laced. These decks 
unlace the tape before shuttling. Refer to 
your tape machine’s guide for more infor-
mation. 

Some devices may not support all shuttle 
modes, and may not accept the above shut-
tle commands. In these cases, the Fast For-
ward and Rewind buttons in the Pro Tools 
Transport window flash, and clicking them 
places the device in true Fast Forward /Re-
wind mode. 
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Spotting to the Machine

To spot regions to the machine’s current loca-
tion, use Pro Tools Spot mode and/or Auto Spot 
(if using VITC). Refer to the Pro Tools Reference 
Guide for information on using Spot and Auto 
Spot mode to spot regions to incoming SMPTE 
time code locations. 

Remote Track Arming
Pro Tools with MachineControl provides the 
ability to record-arm audio, video, or time code 
tracks on external decks. 

On MachineControl-equipped systems, the 
Show Machine Track Arming Window com-
mand is available in the Pro Tools Windows 
menu. The Track Arming window lets you con-
figure track arming during sessions, using the 
settings appropriate for the current Track Arm-
ing Profile. (See “Identifying Your Machine” on 
page 30.)

To display the Machine Track Arming window:

■ Choose Windows > Show Machine Track Arm.

Configuring Track Arming
Pro Tools provides automatic, direct support for 
track configuration of most common video 
decks. If your deck is supported, Machine-
Control identifies and displays your machine’s 
track layout. 

Even if your machine is not directly supported, 
the Track Arming window lets you arm tracks, 
set the Record Protocol and configure the 
Record mode for the machine. 

You can also define, save, and load customized 
device profiles. (See “Creating a Track Arming 
Profile” on page 30.)

Auto Spot mode uses incoming VITC for lo-
cation information. Therefore, Auto Spot 
mode will force the Region to be spotted to 
the current incoming machine time code lo-
cation, not the current insertion cursor loca-
tion. To spot your elements directly to the 
current cursor location, Control-drag (Mac-
intosh) or Right-click and drag (Windows) 
the elements.

Track Arming in Pro Tools 6 and higher

Not all machines support independent arm-
ing of their audio tracks locally or remotely, 
and some machines require a separate util-
ity menu selection. Pro Tools remote track 
arming cannot operate in these situations.

Protocol
and 
Mode

Record 
Arm 
buttons
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Identifying Your Machine

When you configure Pro Tools for Machine-
Control, it automatically loads the track arming 
profile for the identified machines. For more in-
formation on basic Pro Tools settings for 
MachineControl, see “Setting Up a Machine-
Control Device for Deck Control” on page 18.

If Pro Tools does not recognize your machine, or 
if you want your machine to emulate a different 
type of device (for example, to use a different 
track layout), you can load a generic machine 
profile. 

For maximum flexibility, use Track Arming Pro-
files to create, customize, and manage multiple 
machine descriptions (see “Creating a Track 
Arming Profile” on page 30). 

Creating a Track Arming 
Profile
The Create Track Arming Profile window pro-
vides extensive control over Pro Tools Track 
Arming. You can customize arming, track nam-
ing, and mapping, and save configurations for 
different machines as Track Arming Profile files. 
These Profiles can be imported to quickly recon-
figure Track Arming as needed for future 
projects. You can also test track mapping, and 
remap tracks if needed. 

Use the Create Track Arming Profile feature to 
create profiles for machines that may not be in-
cluded with Pro Tools, and to manage multiple 
profiles. 

To create a machine Track Arming Profile:

1  Choose Setups > Create Machine Track Arm-
ing Profile. 

If you are using a generic machine profile, 
be sure to double-check record behavior us-
ing non-essential tapes before using Machi-
neControl’s remote track arming functions.

When you create a new Track Arming Pro-
file, a Stop command is sent to any con-
nected machine to protect elements on tape.

Create Track Arming Profile

Load 
Profile

Track 
Arm 
buttons

Save ProfileMachine ID

Profile settings
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Choosing a Machine ID

To recognize your machine:

■ Click Identify Machine. 

MachineControl queries the connected ma-
chine for its machine ID, which is then dis-
played below the Identify Machine button. 

You can edit or replace the ID manually if 
needed. See “Entering a New Byte Code” on 
page 32 for more information. 

Configuring a Profile

The Create Track Arming window lets you spec-
ify track names and track mapping. 

Customizing Names for Track Arming 
Buttons

You can rename the Track Arm buttons dis-
played in each Track Arming Profile to better de-
scribes the recording taking place. For example, 
an eight track profile might be easier to use with 
tracks named Dx-L, Dx-R, FX-L, FX-R, Mx-L, Mx-
R, Lt, and Rt, for eight tracks comprised of stereo 
Dialog, stereo FX, stereo Music, and an Lt-Rt 
mix. 

To edit the name of a track arming button:

1  Double-click the Track Arm button you want 
to rename.

2  Enter a new track name in the dialog, and 
click OK.

Remapping Tracks

You can remap track buttons to target different 
tracks on the machine. 

To remap tracks:

1  Click the Track button you want to remap to 
display its remap pop-up menu. 

2  Choose a new target track.

– or –

Choose a different machine profile from the 
Load Configuration selector. 

Reassigning the Byte Value for a Track 

In a remote machine’s firmware, each record 
track on the machine has a unique hexadecimal 
byte code that tells the machine which track 
should be armed when an arm command is re-
ceived from a remote master. The standard pro-
file (the default setup) corresponds to the Sony 
P-2 protocol, but many decks have their own 
unique mapping of byte codes to track numbers 
for a particular deck. 

If an audio or video track, or the deck time code 
track do not arm when you click its correspond-
ing track arming button, you may need to assign 
a different hex value to the button.

To select a different hex value for an individual 
track arm button:

■ Select another hex value byte code from the 
Byte Code sub-menu for the appropriate track 
arm button. 

Entering a custom track name

Remapping a track arming button
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Entering a New Byte Code

As the Sony P2 protocol continues to expand, 
more manufacturers add specific byte code com-
mands that may be listed in the current byte 
code list. Pro Tools lets you create entirely new, 
custom byte codes. This lets you enter addi-
tional byte commands as needed to support new 
features as they are added to decks.

Choosing a Record Protocol 

The Machine Track Arming window provides 
the following two choices for configuring the re-
cording protocol of the target deck:

Auto Edit

This mode is a highly accurate way to ensure 
that the target deck will record only within the 
boundaries of an on-screen selection. (If your 
deck does not support Auto Edit, use Punch 
In/Punch Out, as explained below.) 

In Auto Edit mode, the record start/end times 
are downloaded to the target deck (along with 
any pre- or post-roll), and the deck is responsible 
for performing the insert punch in/out at the 
specified times (see “Rules for On-Screen Selec-
tions” on page 33 for details). 

Because this protocol removes the vagaries of 
CPU timing from the remote recording process, 
Auto Edit is frame-accurate. It is also the best 
way to ensure that your machine will punch out 
correctly and avoid accidental erasure of audio, 
even in the event of a CPU error.

Punch In/Out

This mode uses Pro Tools to control the process 
of punch in/out. Instead of downloading the 
punch points (as in Auto Edit), Pro Tools actu-
ally performs them during the record pass. Be-
cause serial communication has inherent de-
lays, timing with Punch In/Punch Out mode 
cannot guarantee frame-accuracy (though it will 
almost always be within 2 to 3 frames). 

Choosing a Record Mode 

The Machine Track Arming window provides 
two choices for Record mode:

Insert

Insert mode is used to perform insert editing 
(punching in individual tracks) where one or 
more audio tracks is replaced by new material 
and the video material is retained. 

Assemble

Use Assemble mode when you want to:

◆ Begin recording program onto a completely 
blank tape (unformatted)

– or –

◆ Append program to the remainder of a tape 
which already has program you want to keep

Assemble mode is not appropriate for audio lay-
backs to video masters.

Assemble mode should be used carefully be-
cause it arms all tracks on the target deck for re-
cording—including the video track, time code 
track and control track. When performing an 
Assemble edit, all material on all tracks after the 
edit in point will be replaced. Because a break in 
the control track will result at the edit out point, 
any remaining program material after an Assem-
ble edit may be unusable.

Entering a new byte code
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To avoid accidentally recording over program 
material, experiment with Assemble and Insert 
modes on a dispensable tape to familiarize your-
self with the edit capabilities of your deck.

Rules for On-Screen Selections

The Record Protocol buttons allow you to 
choose between the two different record proto-
col choices described above (Auto Edit and 
Punch In/Punch Out). Regardless of which 
choice is used, however, Pro Tools follows these 
rules for record selection:

◆ If there is an on-screen selection, recording 
will take place over the period of the selection 
and punch out at the end of the selection. 

◆ If pre- or post-roll is enabled, recording takes 
place only in the selection area, not during pre- 
or post-roll. 

◆ If there is no selection (only a start location), 
recording will continue until it is manually 
stopped.

◆ If you make a selection in Pro Tools that 
crosses the “midnight” boundary (00:00:00:00), 
make sure your deck can handle this situation. 
Experiment with a dispensable tape to familiar-
ize yourself with the crossover capabilities of 
your deck.

Arming Tracks Remotely for 
Layback
To arm tracks remotely for layback, you need to 
first configure Track Arming for your machine. 

To configure Track Arming:

1  Make sure your machine is properly con-
nected and configured to slave to Pro Tools. 

2  Open the Track Arming window.

3  Select a Record Protocol (Auto Edit or Punch 
In/Out).

4  Select a Record mode (Insert or Assemble).

To perform a layback:

1  In Pro Tools, select the audio to lay back, or 
place the playback cursor at a start point. 

2  In the Remote Track Arming window, arm the 
appropriate tracks on the machine.

3  Select Transport > Machine in the Pro Tools 
Transport window. 

4  Make sure the Pro Tools Transport is online. 

5  Click Record in the Transport window to arm 
recording.

6  Click Play in the Transport window.

Your machine will cue to the selection start mi-
nus all relevant pre-roll, then begin to play back. 
Pro Tools will then sync to the deck, and the tar-
get deck will record as determined by your set-
tings for Record Protocol and Record mode. If 
you did not create an on-screen selection, deck 
recording will continue until you manually stop 
playback.

Assemble mode replaces all the elements on
the target tape deck—audio, video and time
code. Use this mode with caution. 

Once the Track Arming options are config-
ured, you can change the Track Arming 
window to “small view” and still see the 
track arm buttons.
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chapter 5

Remote 9-Pin Deck Emulation Mode 
(Configuration and Operation)

Remote 9-Pin Deck Emulation mode makes 
Pro Tools operate as a virtual tape deck, support-
ing most standard Sony P2 9-pin commands. 
For a list of supported commands, see “9-Pin 
Commands” on page 40. 

By default, Pro Tools emulates a Sony BVW-75 
model video deck. You can also configure 
Pro Tools to emulate other machines. For more 
information, see “Alternate Machine Types” on 
page 38. 

Generating Time Code in Remote 9-Pin 
Deck Emulation Mode

Pro Tools with MachineControl and the 
SYNC I/O can generate frame-edge aligned time 
code at 1x play speed while in Remote 9-Pin 
Deck Emulation mode. 

Configuring Remote 9-Pin 
Deck Emulation Mode

To configure Pro Tools for Remote 9-Pin Deck 
Emulation mode:

1  Choose Setups > Peripherals.

2  Click the Synchronization tab. 

3  Choose SYNC from the Device pop-up menu 
(to select SYNC I/O as the synchronization de-
vice enabled on the DigiSerial port).

4  Click the Machine Control tab at the top of 
the Peripherals dialog.

5  In the 9-Pin Remote section, click Enable.

6  Choose the appropriate port from the Port 
menu.

7  Choose the appropriate machine profile from 
the Machine ID pop-up menu. 

8  If using Pro Tools as a remote time code slave, 
set Delay After Play as described in “Selecting 
Full Remote Modes or Remote/LTC Chase 
Mode” on page 36.

For instructions on connecting Pro Tools for 
Remote 9-Pin Deck Emulation mode, see 
Chapter 2, “Installing MachineControl.”

Remote 9-Pin Deck Emulation mode settings
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9  If you want Pro Tools to ignore time code mas-
ter/slave commands and just chase LTC, enable 
Chase LTC.

10  Click OK. 

11  In addition to the option to chase LTC, Re-
mote 9-pin Deck Emulation mode also provides 
a preference setting to follow or ignore remote 
track arming commands. For more information, 
see “Ignore Track Arming Commands” on 
page 40. 

12  Choose Windows > Show Session Setup.

13  In the Session Setup window, under Time 
code Settings, click the Generator Using SYNC 
option.

This is required for Pro Tools to lock to the video 
reference with frame edge accuracy. 

14  Under the SYNC Setup section of the Session 
Setup window, select Video Reference from the 
Clock Reference pop-up menu.

15  In the Pro Tools Transport window, select Re-
mote or Remote LTC as the Transport master.

16  Put Pro Tools online.

17  If you will be recording, select a Record mode 
by Right-clicking (Windows) or Control-clicking 
(Macintosh) the Record button in the Transport 
window.

18  Begin machine playback. 

Selecting Full Remote Modes or 
Remote/LTC Chase Mode

Remote 9-Pin Deck Emulation mode lets a mas-
ter device control Pro Tools track and transport 
arming. When the transport is online, Remote 
9-pin Deck Emulation operates in one of two 
Full Remote modes, or Remote/LTC Chase 
mode.

When the transport is offline, Pro Tools oper-
ates in Local mode and ignores commands from 
the 9-pin machine controller. Pro Tools re-
sponds only to requests from the 9-pin machine 
controller for machine type and status, and re-
sponds that it is in Local mode.

Full Remote Modes

In Remote 9-Pin Deck Emulation mode, when 
the transport is online and Chase LTC is not en-
abled, the Transport master selector shows 
Transport = Remote, and Pro Tools is in one of 
two Full Remote modes.

In Full Remote mode, Pro Tools or another ma-
chine is the time code master, while simulta-
neously responding to 9-pin transport and track 
arming commands from the machine control-
ler. 

If this option is grayed out, you need to open 
a new or old session first.

Remote 9-Pin Deck Emulation mode settings

Chase LTC enabled

 Chase LTC not enabled

See also “Optimizing Playback in Remote 9-
Pin Deck Emulation Mode” on page 39. 
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The time code master is defined by the machine 
controller. If Pro Tools is not the time code mas-
ter, it needs additional time to behave as a 
proper remote machine as time code slave. This 
time is defined using the Delay Before Play set-
ting:

• When Delay After Play is set to zero, 
Pro Tools is set up to function properly as 
the time code master. When online, Pro 
Tools locates, then plays when it gets a play 
command.

• When Delay After Play is set towards 30 
frames, another machine is the time code 
master. When online, Pro Tools locates, 
sends time code  position responses, and 
when its time code lines up with the time 
code master device, then goes into play in 
sync with the time code master device.

To set the time code master in Full Remote mode:

1  Choose Setups > Preferences.

2  Click the Machine Control tab (Pro Tools 6.4) 
or the Operation tab (Pro Tools 6.2.x and lower). 

3  In the Remote Mode section, do one of the fol-
lowing:

• Set Delay After Play is set to zero, to prepare 
Pro Tools to behave quickly as the time 
code master. 

• Set Delay After Play towards 30 frames, to 
set up Pro Tools to behave properly as a 
time code slave device by delaying play-
back until its time code can properly syn-
chronize first.

Chase LTC

When Chase LTC is enabled, Pro Tools can still 
respond to 9-pin locate, track arming, and 
record commands, but chase incoming LTC in-
stead of being the time code master or slave de-
vice under synchronization control of the ma-
chine controller. By slaving Pro Tools to the 
LTC source instead of slaving the machine to 
Pro Tools time code, you can avoid the waiting 
(and tape wear) that occurs while a machine 
transport locates and bumps tape to the cue 
point. 

In Remote 9-Pin Deck Emulation mode, when 
the transport is online and Chase LTC is en-
abled, the Transport master selector shows 
Transport = Remote LTC, and Pro Tools is now 
in Remote /LTC Chase mode. Pro Tools also 
communicates record status to the machine.

Receiving Commands While Chase LTC is 
Enabled

When Chase LTC is enabled, and the system is 
online, Pro Tools waits until it receives only spe-
cific transport record and track record com-
mands from the machine. When Chase LTC is 
not enabled, Pro Tools will listen to all transport 
commands arriving through the serial connec-
tion, including bump and crawl commands nec-
essary for a tape machine to locate.

Generally, delay should only be added if 
Pro Tools is having problems starting and 
locking to a machine during playback or 
record. For example, if Pro Tools tries to 
lock, and the transport lights go from play 
to shuttle or fast-forward to rewind many 
times before locking, you should increase 
the Delay After Play setting by a few 
frames.
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Scrubbing and Chase LTC

The Chase LTC option does not affect scrub-
bing. Pro Tools video playback will always re-
spond to locate and scrubbing command, even 
if Chase LTC is enabled. 

Alternate Machine Types

By default, MachineControl lets Pro Tools emu-
late a Sony BVW-75. If you use a machine that 
follows a different 9-pin command set, you can 
configure Pro Tools for its machine description.

To configure Pro Tools for an alternate machine:

1  Choose Setups > Peripherals.

2  Click the Machine Control tab.

3  Under 9-Pin Remote, select a Machine ID.

4  Click Ok.

Special settings have been created for specific 
machine controllers (such as the Soundmaster 
ION). When under the control of a specific ma-
chine controller, first check if there is a specific 
setting for that machine controller.

Remote 9-Pin Deck Emulation 
Mode Preferences
Pro Tools provides the following preference set-
tings to configure Remote 9-Pin Deck Emulation 
Mode options. 

To set Remote 9-Pin Deck Emulation mode 
preferences:

1  Choose Setups > Preferences.

2  Click the Machine Control tab (Pro Tools 6.4) 
or the Operations tab (Pro Tools 6.2.x and 
lower). 

3  Set any of the following options:

Punch In Frame Offset Sets an offset in frames to 
compensate for punch in timing advances or de-
lays. 

Punch Out Frame Offset Sets an offset in frames 
to compensate for punch out timing advances 
or delays. 

Delay After Play Command Sets a number of 
frames of delay for Pro Tools to wait before at-
tempting to lock, to compensate for the amount 
of time needed for the master machine to stabi-
lize. This setting determines whether Pro Tools 
or the machine is the time code master.

This setting can be especially useful in a multi-
machine environment.

Ignore Track Arming Lets you record-safe 
Pro Tools from machine track arming. When 
this option is selected, Pro Tools responds to all 
9-pin remote commands except track arming. 

4  Click Done to close the Preferences dialog.

Remote 9-Pin Deck Emulation Preferences

See “Selecting Full Remote Modes or Re-
mote/LTC Chase Mode” on page 36 for 
more information.
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Playback in Remote 9-Pin 
Deck Emulation Mode
Pro Tools will only play back audio when the re-
ceived command requires audio play back at 1X 
speed in the forward direction. Reverse playback 
and varispeed playback are not supported in 
Pro Tools. 

Online Status Display

When online in Remote 9-Pin Deck Emulation 
mode, the Online button flashes until Pro Tools 
and the machine establish communication. 
When MachineControl and Remote 9-Pin Deck 
Emulation Mode are enabled and communica-
tion is established, the Online button will re-
main highlighted. 

Optimizing Playback in Remote 9-Pin 
Deck Emulation Mode

Use the Delay After Play Command preference 
to optimize Pro Tools response in Remote 9-Pin 
Deck Emulation mode. (See “Remote 9-Pin Deck 
Emulation Mode Preferences” on page 38 for in-
structions on how to configure this preference.) 
This setting lets you enter a number of frames 
for Pro Tools to wait, before responding to lo-
cate and play commands. A small delay before 
play allows the time code master device to stabi-
lize before Pro Tools attempts to achieve lock. 
By delaying play in this manner, Pro Tools can 
avoid multiple nudge and bump messages while 
attempting to lock. 

Recording in Remote 9-Pin 
Deck Emulation Mode
MachineControl lets Pro Tools support Auto 
Edit (selection-based) and Punch-in/Punch-Out 
(QuickPunch) commands. 

Pro Tools must have QuickPunch or TrackPunch 
with tracks enabled when recording in Remote 
9-Pin Deck Emulation mode with an edit con-
troller. 
 

Auto Edit Recording

When a machine sends Auto Edit commands to 
Pro Tools in Remote 9-Pin Deck Emulation 
mode, the edit in and out points are converted 
to a Pro Tools Timeline selection. This selection, 
with offsets options, will then be used to record 
on all armed tracks when Pro Tools receives the 
Perform Auto Edit Record command. 

Punch In/Out Recording

Punch-In/Punch-Out Recording supports 
punch-on-the-fly, with Pro Tools in QuickPunch 
mode. In this mode, tracks are armed before the 
record pass, and recording begins and ends 
when Punch-In and Punch-Out commands are 
received form the master machine. 

QuickPunch must be enabled and the required 
voices must be available in Pro Tools for Punch-
In/Punch-Out recording commands to work. 
This mode must be set manually in Pro Tools.

Preview Edit and Record Rehearse modes 
are not supported by Pro Tools.
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Track Arming in Remote 9-Pin 
Deck Emulation Mode
In Remote 9-Pin Deck Emulation mode, 
Pro Tools can be configured to either respond 
to, or ignore, track arming (record enabling) 
commands. Pro Tools communicates track 
record status back to the control machine. 

Ignore Track Arming Commands

You can set Pro Tools to ignore incoming track 
arming (record-enable) commands. Use this to 
record-safe Pro Tools if, for example, you are us-
ing a master 9-pin transport controller to arm 
tracks on several other machines, but not 
Pro Tools tracks. You can still manually arm 
Pro Tools audio tracks, as needed. 

To have Pro Tools ignore remote track arming 
commands:

1  Choose Setups > Preferences, and click the Op-
eration tab. 

2  Click the Machine Control tab (Pro Tools 6.4) 
or the Operation tab (Pro Tools 6.2.x and lower). 

3  Under Remote Mode, select Ignore Track Arm-
ing. 

9-Pin Commands
In Remote 9-Pin Deck Emulation Mode, 
Pro Tools with MachineControl can respond to 
the following 9-pin commands from compatible 
workstations, synchronizers, and other devices:

• Play

• Stop

• Pause

• Rewind

• Forward

• Cue To

• Poll Time Code

• Record Arm Track

• Set In/Out Point (for Auto Edit)

• Set Pre/Post Roll (for Auto Edit)

• Perform Auto Edit Record

• Perform Punch-In/Punch-Out Record (re-
quires QuickPunch mode and voices)

• Return Status-Online, State, Tracks Armed

• Servo Lock

• Clear “In” Point
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Deck Control Key Commands

 

Command Macintosh Windows

Rewind Shift+< Shift+<

Fast Forward Shift+> Shift+>

Shuttle Backward Option+comma Alt+comma

Shuttle Forward Option+period Alt+period

Toggle Transport Master Command+\ Control+\

All Transport Buttons Off/Unthread Tape Command+period Control+period

Search Mode Toggle (Play-Pause/Stop) Spacebar/Com-
mand+period

Spacebar/Ctrl+period

When Transport = Machine:

Locate to Selection Start Command+Left Arrow Control+Left Arrow

Locate to Selection End Command+Right Arrow Control+Right Arrow

Locate to Selection Start Minus Preroll Option+Left Arrow Alt+Left Arrow

Locate to Selection End Minus Preroll Option+Right Arrow Alt+Right Arrow
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Troubleshooting

Installation

Problem:

MachineControl options are not available in 
Pro Tools. 

Possible Solution:

Make sure MachineControl is installed and au-
thorized correctly (see Chapter 2, “Installing 
MachineControl.”)

Machine Not Recognized

Problem:

The session was saved with MachineControl, 
but now opens without it being selected in the 
Transport window. When opening a session 
saved with MachineControl, a dialog warns that 
there were “problems initializing MachineCon-
trol.” When spotting a region, the “Capture Ma-
chine Time” button is grayed out.

Possible Solutions:

◆ Choose Setups > Peripherals, click the Ma-
chine Control tab, and confirm that the correct 
9-Pin Serial port is chosen for your Machine-
Control operating mode. Make certain that all 
cables are securely connected at both ends.

◆ Verify that the machine is powered on. 
Choose Setups > Peripherals, click the Machine 
Control tab. Reset the 9-Pin Serial port, and 
close the dialog. This causes Pro Tools to scan 
the serial port for 9-pin devices. 

Pro Tools Transport Not 
Controlling Machine

Problem:

Though the MachineControl dialog indicates 
that Pro Tools recognizes the machine, nothing 
happens when you use the transport in 
Pro Tools (the machine doesn’t respond to com-
mands). When spotting a region using the 
“Capture Machine Time” button, an incorrect 
time is entered.
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Possible Solutions:

◆ Most machine controllable transports need to 
be placed in a “Remote” or “Ext” mode to allow 
them to be slaved to other devices. Verify that 
the device is in this mode. Refer to the docu-
mentation that came with your device for more 
information on Remote and Local modes. 

◆ In the Transport window, check the status of 
the “Transport = Pro Tools” or 
“Transport = Machine” setting.

Time Code Inaccuracy

Problem:

The time code locations shown in the Selection 
and Position Indicator boxes do not match ma-
chine time code.

Possible Solutions:

◆ For best performance with Serial Deck Control 
mode, connect the machine to an available se-
rial or COM port (or serial adapter connected to 
a USB port) on the host computer. Use the 9-pin 
ports on the SYNC I/O for non-linear video 
decks only. 

◆ In some cases, the Time Code values reported 
by machines are not in sync with the time code 
that gets played out of their time code ports. 
(One example of this is when the machine's 
time code reader is looking at VITC while 
Pro Tools is chasing LTC.)

◆ If the values get progressively farther and far-
ther apart, check the frame rate. Make sure you 
have set Pro Tools to the same frame rate as the 
movie/machine frame rate. Also check the 
frame format (drop or non-drop). 

◆ If the values differ by a significant margin 
(such as an hour or more), the Start Frame num-
ber may be set incorrectly. Open the Session 
Setup window and check the Session Start Frame 
number.

Changing Session Start Time, and 
Dropped Frames

When you change the session frame rate from a 
non-drop to drop rate, or from drop to non-
drop, the session start time and material in the 
timeline may be affected. 

Non-drop Changed to Drop: The Session Start 
Time is changed to the next possible supported 
frame if the current one is not supported in DF. 
For example, changing from non-drop to drop 
frame in a session that starts at 00:59:00:00 will 
change the session’s start time to 00:59:00:02 
(due to the method by which frames are 
dropped in each rate and format). 

Every event in the timeline is moved back two 
frames, maintaining each event’s relative time 
code location (relative to the start of the ses-
sion). 

Drop Changed to Non-drop When going from 
drop to non-drop, no compensation is applied 
to the session start time. This is done because all 
frames in drop exist in a non-drop timeline (a 
drop rate timeline is a subset of its correspond-
ing non-drop rate timeline). So, when changing 
from a drop rate to a non-drop rate, Pro Tools 
keeps events at the same location relative to the 
start of the session. 
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Machine IDs

The following table lists the machine profiles 
supported in MachineControl by their Pro Tools 
hexadecimal ID. 

For special IDs to support 48-track arming, see 
“48 Track Profiles” on page 46. 

Machines and Hex ID Numbers

The first 0x signifies hex value. The next four 
numbers signify the machine ID. The name of 
the associated machine follows. 

Machines, by ID number

ID number Machine

0x0000 Generic

0x1000 BVU-800

0x101C BVU-950

0x1019 BVU-920

0x1080 BVU-900

0x104C VO-9850

0x1048 VO-9800

0x102C SVO-9600

0x2000 BVW-10

0x2001 BVW-40

0x2002 BVW-11

0x2003 BVW-15

0x2010 BVW-35

0x2020 BVW-60

0x2021 BVW-65

0x2022 BVW-95

0x2023 BVW-96

0x2024 BVW-70

0x2025 BVW-75

0x2125 BVW-75P

0x4000 DVR-10

0x4003 DVR-18

0x4002 DVRC-10

0x4020 DVR-20

0x4022 DVR-28

0xF019 AJ-D350 (D3)

0x3011 DVR-2100

0x3000 DVR-1000

0x0010 BVH-2000

0x0011 BVH-2000

0x0110 BVH-2000 PS

0x0111 BVH-2000 PS

0x0018 BVH-2180

0x0020 BVH-2500

0x0120 BVH-2500 PS

0x0030 BVH-2700

0x0040 BVH-2800

Machines, by ID number

ID number Machine
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48 Track Profiles

The following are special IDs to support 48-track 
arming. 

Machines

Pro Tools

0x0048 BVH-2830

0x0050 BVH-3000 (NTSC)

0x0060 BVH-3100 (NTSC)

0x0150 BVH-3000 PS

0x0160 BVH-3100 PS

0x2041 PVW-2800

0x1211 ASC Virtual Recorder

0x1011 Fostex D-10

0xF027 Otari R-DAT

0x7001 TASCAM DA-88

0xF01D TASCAM DA-88

0x7003 PCM-800

0x7000 PCM-7000

0xA088 AG-DS555

0x2051 UVW-1800

0xB000 DVW-500

0xB010 DVW-500

0xA050 V1

0x2124 BCB-70

0x2101 BVW-40P

0x2141 PVW-2800P

Tascam DA-88 and other decks can be set 
to emulate other machines. If a deck is set to 
emulate another type of machine, the ma-
chine type being emulated will be displayed. 

Machines, by ID number

ID number Machine

IDs for 48-Track Capable Machines

ID Machine

0x6007 3348HR

0x6005 3348HRV

0x6003 3324

IDs for 48-Track Pro Tools Arming

ID Machine

0xD0 E1 Pro Tools

0XD1 E1 Pro Tools

0XD2 E1 Pro Tools
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9-Pin Cable Pinouts

Serial Deck Control Mode Cable: D Sub 9-Pin Male to D Sub 9-
Pin Female (Windows Only)

This is a standard ESBus MachineControl Cable. 

• All pins wired should be wired straight 
through. 

• Pins 2 and 7 are a Twisted Pair with shield 
drain wire on Pin 6.

Pins 3 and 8 are a Twisted Pair with shield drain 
wire on Pin 4. 

1
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Serial Deck Control Cable: Mini DIN 8 Male to D Sub 9-Pin Male 
(Macintosh Only)
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Remote 9-Pin Deck Emulation Cable: Mini DIN 8-Pin to D Sub 9-
Pin Female (Macintosh Only)

Shielding

The outside shielding of the D-Sub 9-pin (fe-
male) should be wired to the outside shielding 
of the Mini DIN 8-pin (male).
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A
arming

safe (ignore) 40
Assemble mode 32
authorizing plug-ins 11
auto detection 18
Auto Edit 32

and Remote mode 39
Auto Spot 14, 27, 29

C
cables 1

wiring diagrams 47, 48, 49
CH 1-2 Input 23
Chase LTC 37
chasing

preferences 21
control track 32
Create Machine Track Arming Profile 30
cueing

hi-speed mode 28
preferences 21
search mode 28

D
delay

preferences 21
Delay After Play Command 38
Delay before Locking to LTC 21

E
emulation

of 9-pin deck 9, 10
ESBus cable 47

F
Feet+Frames Time Scale 26
frame rate 23
frame-edge

and serial time code 20

G
Generate

and serial time code 20
generic machine profiles 18

H
hi-speed mode 28

I
IDs

machine 45
Ignore Track Arming 38
Ignore Track Arming command 40
iLok 11

adding authorizations 12
iLok USB Smart Key 11
Incoming Time 24
Insert mode 32
installing MachineControl 10

L
layback 33
License Card 11
Local/Remote 28
locating

preferences 21
LTC

Chase LTC in Remote mode 37

index
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M
machine

pre-roll 19
profiles 45
transport master 14, 26

Machine Chases Memory Location 21
Machine Cues Intelligently 21
Machine Follows Edit Insertion/Scrub 21
machine IDs 45
machine profiles 30
memory locations

and machine chase 21
midnight boundary 33

N
NTSC 23

O
Online

button in Transport 13, 27
toggling 13

On-Screen Selections 33

P
PAL 23
preferences

Delay before Locking to LTC 21
Machine Chases Memory Location 21
Machine Cues Intelligently 21
Machine Follows Edit Insertion/Scrub 21
Record Online at Edit Insertion/Selection 21
Record Online at Time Code (or ADAT) Lock 21
Remote mode 38

pre-roll
compensating 19
machine 19
setting for machine from Pro Tools 19

Pro Tools
transport master 14, 26

Punch In Frame Offset 38
Punch In/Out 32
Punch Out Frame Offset 38

R
record mode 32
record modes

Assemble 32
Insert 32

Record Online at Edit Insertion/Selection 21
Record Online at Time Code (or ADAT) Lock 21
record protocol 32

Auto Edit 32
Punch In/Out 32

recording
preferences 21
Remote mode 39

Redefine Current Time Code Position 25
Remote 9-Pin Deck Emulation mode 11

connections 9, 10
Remote 9-pin Deck Emulation mode

Chase LTC 37
preferences 38
see also Remote mode

Remote LTC mode
transport master 14, 36, 37

Remote mode
and track arming 40
Auto Edit 39
commands 40
playback 39
recording 39
transport master 14, 36, 37

S
search mode 28

cueing 28
Serial Deck Control mode 11
serial time code 20

and Generate mode 20
servo lock 19
Setups menu

Feet+Frames Time Scale 26
start time 23
Stop At Shuttle Speed Zero 21
Sync Mode 23
system requirements 3
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T
time code

quick signal test 24
redefine current 25
track 32

track arming
48-track IDs 46
and Remote mode 40
create machine profile 30
IDs 45
ignore 40
remapping tracks 31

track layout 18
tracks

remapping 31
Transport

master 2
transport master 13, 26, 27

machine 14, 26
Pro Tools 14, 26
Remote 14, 36, 37
Remote LTC 14, 36, 37
selecting 13
toggling 14, 27

Trimmer
when Transport = Machine 14, 27

U
Use Serial Time Code for Positional Reference 20

V
Video Format 23
Video Reference

and serial time code 20
video track 32
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