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chapter 1

Introduction
This document is an overview of new features in 
Pro Tools TDM 6.4 for Pro Tools|HD systems on 
Windows XP or Mac OS X.

Digidesign can only assure compatibility and 
provide support for hardware and software it 
has tested and approved. 

For a list of Digidesign hardware systems, 
Digidesign-qualified computers, operating sys-
tems, and third party devices, refer to the latest 
compatibility information available on the 
Digidesign Web site (www.digidesign.com/com-
pato).
New Features
Pro Tools 6.4 includes the following new or en-
hanced features:

• Support for new Digidesign hardware:

• D-Control

• Command|8 control surface

• AVoption|V10 (Windows only)

• New recording and monitoring features:

• Automatic Delay Compensation

• Track position numbering

• +12 dB Fader Gain for increased mixer gain

• TrackPunch audio recording mode 

• TrackInput for input/disk monitoring per 
track

• Enhanced clipping indication

• Plug-in menus by category

• Post-production and timecode features:

• 23.976 fps session support

• Feet+Frames session setup improvements

• Pro Tools interface changes

• Transport controls can be displayed at the 
top of the Edit window

• New consolidated Machine Control and 
Remote Control preference page

• Renamed Features
Chapter 1: Introduction 1
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chapter 2

What’s New in Pro Tools 6.4
Support for New Hardware
Pro Tools 6.4 provides support for new Digide-
sign hardware:

• D-Control

• Command|8 control surface

• AVoption|V10 (Windows only)

D-Control

D-Control is a tactile worksurface for 
Pro Tools|HD systems that employs a familiar, 
intuitive channel strip–center section console 
layout.

Some of the main features of D-Control include:

• 16 channel strip main unit, expandable to 80 
physical faders and channel strips with op-
tional 16-channel Fader Packs.

• High-quality, touch-sensitive motorized 
Penny and Giles faders.

• Six touch-sensitive, multi-purpose rotary en-
coders per channel strip.

• Six 15-segment, multi-color LED rings dis-
playing encoder position, and send and plug-
in metering.

• Seven six-character alphanumeric, multi-
color LCD displays per channel strip.

For more information, refer to the D-Con-
trol Guide.
• 29 illuminated pushbuttons per channel strip 
for determining operation modes.

• Two 32-segment, bi-color LED bargraphs per 
channel strip for stereo metering.

• Comprehensive remote monitor control sec-
tion.

• Eight 32-segment bi-color LED bargraph 
meters for output metering.

• Dedicated editing panels for EQ and dynamics 
plug-ins.

• Full transport panel with a jog/shuttle wheel.

• Soft-key panel comprised of assignable but-
tons and accompanying alphanumeric LCD 
displays.

• Full-size, 104-key keyboard with a 10-key key-
pad and a 2-inch trackball, and other 
Pro Tools-specific controls.

Command|8 Control Surface

Command|8 is a low cost USB-based control sur-
face for Pro Tools, developed in a collaboration 
between Digidesign and Focusrite. Command|8 
is a compact, convenient, and flexible control 
surface for Pro Tools systems running on 
Windows XP or Mac OS X.

For more information, refer to the Com-
mand|8 Guide.
Chapter 2: What’s New in Pro Tools 6.4 3
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Some of the main features of Command|8 in-
clude:

• Eight fader strips, each featuring a motorized, 
touch-sensitive fader, rotary knob, LEDs, and 
solo, mute, and select switches.

• Analog monitoring section with level controls 
for mains and headphones. Two pairs of ana-
log inputs are provided, one for your main 
mix from Pro Tools, and one for alternate 
sources such as CD, Mini-Disc, and DAT play-
ers. 

• One MIDI In port and two MIDI Out ports 
providing 16 channels of MIDI input, and 32 
channels of MIDI output. 

• USB port for direct USB MIDI communication 
with Pro Tools.

• 1/4-inch Punch In port for footswitch control 
of recording.

• Transport controls and mode switches.

• Windows switches for Pro Tools display.

• Navigation and Zoom controls.

• Tactile control of track volume, pan, send 
level, send pan, and record status, as well as 
PRE gain. 

• Fast and convenient access to sends, inserts, 
plug-in pages, pan settings, and other track 
functions.

• Big, bright, 110 character LCD for data dis-
play.

• Five Function keys to access Utility, Fader 
Mute, and MIDI mapping functions.

• Stand-alone mode with snapshot save and re-
call, letting you use Command|8 to control 
any device that supports MIDI Continuous 
Controller messages. Custom MIDI mapping 
can be programmed as needed, and up to 
eight snapshots can be saved locally in Com-
mand|8. 
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AVoption|V10 

Pro Tools with AVoption|V10 hardware and 
software combines the powerful audio post-pro-
duction features of Pro Tools|HD with inte-
grated support for import and playback of Avid 
video media. Avid Media Station|V10 software is 
included with AVoption|V10, providing video 
capture and reconform, AAF/OMF render and 
export of Avid sequences, and professional au-
dio and video layback.

Pro Tools with AVoption|V10 lets you:

• Import and play back Avid video on the Pro 
Tools Movie track with near sample-accurate 
precision against audio tracks.

• Spot individual video clips to new locations in 
the Movie track.

• View video edits and clip definitions in the 
Movie track.

• View the Movie track as a series of picture 
frames.

• Play video on an external NTSC or PAL moni-
tor.

• Import mixed video resolutions to the Movie 
track.

• Import and play back true 24P and 25P (Pro-
gressive Scan) picture media created in Avid 
video workstations.

For more information, refer to the Pro Tools 
AVoption|V10 Guide.



                              
Delay Compensation
Pro Tools 6.4 introduces Delay Compensation 
for managing DSP delays that occur on audio 
tracks, Auxiliary inputs, or Master Faders be-
cause of plug-in use and mixer routing. 
Pro Tools maintains time-alignment between 
tracks that have plug-ins with differing DSP de-
lays, tracks with different mixing paths, tracks 
that are split off and recombined within the 
mixer, and tracks with hardware inserts. 

To maintain time alignment, Pro Tools adds the 
exact amount of delay to each track necessary to 
make that particular track’s delay equal to the 
delay of the track that has the longest delay.

Delay Compensation should be enabled during 
mixing and playback for optimal delay compen-
sated sound. In some case when recording, De-
lay Compensation should be turned off.

To enable Delay Compensation:

■ Choose Operations > Use Delay Compensa-
tion.

Delay Compensation Settings

There are three settings in the Playback Engine 
dialog for dedicating DSP resources for Delay 
Compensation: 

None Allocates no DSP resources for automatic 
delay compensation.

Short Allocates minimal DSP resources of delay 
compensation for each channel. This is the 
most efficient setting for Pro Tools|HD Accel 
systems.

Long Allocates maximum DSP resources of delay 
compensation for each mixer channel. Long de-
lay compensation uses the same DSP resources 
used by high DSP overhead plug-ins.
To configure the Delay Compensation Engine:

1  Choose Setups > Playback Engine.

2  From the Delay Compensation Engine pop-up 
menu, select a Delay compensation setting.

3  Click OK.

The delay compensation option will be saved as 
a session and system preference.

Delay Compensation View

The Delay Compensation View displays the to-
tal amount of plug-in delay on each track, lets 
you apply a user offset of track delay, and dis-
plays the total amount of delay that Pro Tools 
applies to each track. The Delay Compensation 
View can be shown in the Mix Window. 

To view Delay Compensation information: 

■ Choose Display > Mix Window Shows > Delay 
Compensation View.

Delay values can be specified in either samples 
or milliseconds, as determined in the Display 
page of the Preferences dialog.

Delay Compensation view

Plug-in

User Offset 

Track Compensation
indicator 

Delay indicator
Chapter 2: What’s New in Pro Tools 6.4 5
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Plug-In Delay (dly) Indicator

This indicator shows the total plug-in and hard-
ware insert delay on the track. This delay total is 
used by Pro Tools to calculate the delay applied 
to other tracks to keep them time-aligned. The 
track with the highest plug-in and insert delay 
displays delay information in orange.

Bypassing the track’s reported delay to Pro Tools 
can be useful if your total plug-in delay on a 
track exceeds the amount allowed in the Delay 
Compensation Engine setting. After bypassing 
the track’s reported delay, you must manually 
nudge your track earlier by the reported amount 
to achieve the proper delay compensation for 
that track, while continuing to use Delay Com-
pensation (see “User Offset (+/–) Field” on 
page 6.)

To bypass reporting plug-in delay to Pro Tools:

■ Start-Control-click (Windows) or Command-
Control-click (Macintosh) the Plug-in Delay in-
dicator. The track delay will appear greyed out, 
and Pro Tools will not use that track’s plug-in 
delay to calculate Delay Compensation for the 
other tracks. 

User Offset (+/–) Field 

This field lets you adjust track delays manually. 
In addition to the automatic delay, positive or 
negative delay times can be entered in the user 
offset (+/–) field. 

This is useful for changing the feel of a track or 
for time-aligning a track in case a plug-in is in-
correctly reporting its delay.

To change track delay using the User Offset field:

1  In the Delay Compensation view, click in the 
User Offset edit field.
What’s New in Pro Tools TDM 6.4
2  To set your delay value (in samples or millisec-
onds depending on your current preferences), 
do one of the following:

• Enter a positive number (with or without 
the “+” modifier) or negative number (with 
the “–” modifier.) 

• Control-drag (Windows) or Command-
drag (Macintosh) in the User Offset field to 
scroll to a new value.

• Press the Up and Down Arrow keys to in-
crease or decrease the numerical values. 

3  Press Enter.

To bypass the user delay:

■ Start-Control-click (Windows) or Command-
Control-click (Macintosh) the User Offset field. 
The user defined delay will appear greyed out, 
and it will no longer be applied to the track.

Track Compensation (cmp) Indicator 

This indicator shows the amount of compensa-
tion Pro Tools applies to each track. 

Delay that Exceeds the Compensation 
Limit

When the total delay on a track exceeds the 
amount of compensation available, Pro Tools 
applies the maximum available compensation, 
and displays the delay information in red (in the 
Delay Compensation View) for any tracks that 
cannot be fully compensated. The Delay Com-
pensation indicator in the Edit window also 
turns red to indicate that the track delay exceeds 
the delay compensation limit. In this case, you 
need to bypass the track’s reported delay (see 
“Plug-In Delay (dly) Indicator” on page 6), then 
manually nudge the track to maintain proper 
delay compensation (see “User Offset (+/–) 
Field” on page 6).



                      
Low Latency Monitoring During 
Recording

For recording, Pro Tools automatically suspends 
delay compensation to provide a low-latency 
monitor path through the main outputs of the 
record-enabled tracks. When an audio track is 
TrackInput-enabled, armed for recording (in 
stop), or punched in, the track’s delay compen-
sation is automatically suspended (and the 
Track Compensation indicator displays 0). 

Delay compensation can be intentionally ap-
plied to audio tracks regardless of input mode. 

To apply delay compensation to automatically 
bypassed tracks:

■ Start-Control-click (Windows) or Command-
Control-click (Macintosh) the Track Compensa-
tion indicator. Track delay will be applied to the 
track and the Track Compensation Indicator 
will display in blue. 

Track Compensation on Auxiliary Inputs

Delay compensation on Auxiliary Inputs can be 
bypassed to let you monitor outside sources 
(such as the audio tracks of a slaved videodeck) 
with minimal latency, while still reporting the 
track’s delay.

To bypass an Auxiliary Input’s delay 
compensation:

Start-Control-click (Windows) or Command-
Control-click (Macintosh) the Track Compensa-
tion indicator. The reported track delay will be 
zero, and will appear greyed out.
I/O Setup and Delay 
Compensation

The I/O Setup dialog includes options and pages 
for Delay Compensation.

Compensate for I/O Delays After 
Record Options

The I/O Setup dialog includes options for com-
pensating for I/O delays after recording.

Compensate for Input Delays After Record (Input 
Page) and Compensate for Output Delays (Output 
Page) When checked, Pro Tools automatically 
compensates for the latency of the Pro Tools|HD 
digital-to-analog and analog-to-digital convert-
ers. After a recording pass, the record track is ad-
vanced by the total Delay Compensation value 
(as shown by the Track Compensation indicator 
in the Mix window).

H/W Insert Delay Compensation

Pro Tools 6.4 introduces H/W Insert Delay Com-
pensation, which lets you specify the latency of 
outboard hardware (such as effects devices).

H/W Insert Delay Page

From the H/W Insert Delay page of the I/O 
Setup dialog, you can enter hardware insert la-
tency, in milliseconds, in a field that corre-
sponds to every input/output pair. These times 
will be used by the delay engine to time align in-
put paths when a hardware insert is used.

H/W Insert Delay dialog
Chapter 2: What’s New in Pro Tools 6.4 7
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To set an insert delay offset:

■ Enter a value, in milliseconds, in the field cor-
responding with the input where the hardware 
insert is connected.

Track Position Numbering
Track Position Numbering assigns each track a 
number corresponding to its position in the Mix 
and Edit Windows. When tracks are reordered, 
track numbers stay in positional sequence. A 
new keyboard command lets you scroll directly 
to any track by number.

To use track position numbering:

■ Choose Display > Display Track Position 
Numbers.

To navigate directly to any track:

1  Choose Operations > Scroll To Track Number

– or –

Press Control+Alt+G (Windows) or Com-
mand+Option+G (Macintosh).

2  In the Scroll To Track dialog, enter the track 
position number for the desired track.

3  Press OK.

Insert delay offsets only have an effect when 
the I/O is used for hardware inserts.

Scroll To Track dialog
What’s New in Pro Tools TDM 6.4
The track will be selected, and the windows 
scroll as follows:

• The Edit window tracks will scroll to bring the 
selected track as close to the top as possible. 

• The Mix window tracks will scroll to bring the 
selected track as close to the left as possible. 

Track Numbers and Hidden Tracks

There are two ways to display track position 
numbers when tracks are hidden, based on the 
setting of the Track Numbers Stay With Hidden 
Tracks option (located in the Display page of the 
Preferences window). 

• When Track Numbers Stay With Hidden 
Tracks is not enabled, numbers are only as-
signed to tracks that are shown. Active tracks 
are then numbered sequentially. Hidden 
tracks are un-numbered. 

• When Track Numbers Stay With Hidden 
Tracks is enabled in, tracks keep their track po-
sition numbers even when hidden.

“Scroll to Tracks” Banks Controllers 

When using a D-Control, Pro Control, or other 
supported control surface, check this option (lo-
cated in the Display page of the Preferences dia-
log) to bank faders to a numbered track when in-
voking the “Scroll to Track Number” command.



                          
+12 dB Fader Gain
With Pro Tools 6.4, you can select either a 6 dB 
over 0 dB or a 12 dB over 0 dB Fader Gain for all 
faders in the session. Fader Gain choices can be 
made when creating, opening, and importing 
sessions, and when saving a copy of a session.

To select a Fader Gain level when creating a new 
session:

1  Choose File > New Session.

2  In the New Session dialog, select the Fader 
Gain.

The Fader Gain setting is saved with the session, 
and is set as the default for new sessions. 

Selecting Fader Gain when Opening a Previously 
Recorded Session 

When opening a session created in a previous 
version of Pro Tools, you are given the choice of 
staying at +6 dB or updating the session to 
+12 dB. 

When opening a session created in the current 
version of Pro Tools, the session is opened with 
the session Fader Gain settings.

New Session dialog
To change Fader Gain settings: 

1  Choose File > Save Session Copy In. 

2  Select the Fader Gain level.

3  Click Save.

TrackPunch Audio Recording 
TrackPunch is a non-destructive recording 
mode that lets you instantaneously punch in 
(start recording) and punch out (stop recording) 
on individual audio tracks during playback. 
TrackPunch makes Pro Tools more useful for 
many recording workflows.

When a track is TrackPunch-enabled, Pro Tools 
starts recording a new file in the background for 
that track when playback begins. You can then 
punch in on that track at any time during play-
back by record enabling the track. 

Pro Tools automatically creates a region in the 
track playlist at each punch-in point. These re-
gions also appear in the Audio Regions List 
along with the complete audio file. Up to 200 of 
these “running punches” can be performed in a 
single pass.

When using Digidesign MachineControl soft-
ware in Remote 9-Pin Deck Emulation mode, 
TrackPunch can be controlled via P2 protocol. 
D-Control, ProControl, Control|24, and Com-
mand|8 support TrackPunch.

The +12 dB Fader Gain setting only affects 
the position of the fader (both in Pro Tools 
and on control surfaces) above the 0 dB 
mark. Fader positions below 0 dB remain 
unaffected.
Chapter 2: What’s New in Pro Tools 6.4 9



  

10

                               
TrackPunch and QuickPunch Modes

QuickPunch mode, which uses the master 
Record button in the Transport to simulta-
neously punch in on all record-enabled tracks, 
remains available on TDM systems. TrackPunch 
and QuickPunch mode cannot be enabled si-
multaneously. 

TrackPunch Usage Guidelines

TrackPunch and Dynamically Allocated Voicing

When using TrackPunch with a Pro Tools TDM 
system configured for maximum voices, make 
sure to set the voice assignment for each audio 
track to dyn for Dynamically Allocated Voicing 
(this mode was previously known as Auto Voice 
mode). This ensures that Pro Tools can automat-
ically manage voices most efficiently. 

Audio Files and TrackPunch

After a TrackPunch recording pass, the punched 
track’s playlist in the Edit window will display 
the regions created by punching. You can use 
the Trimmer tool after punch recording to open 
up the head or tail of TrackPunch (and Quick-
Punch) recorded regions, or to reveal the parent 
audio file that was recorded in the background. 
This lets you compensate for any late or missed 
punches (from as early as the start of playback, 
or the point at which the track was TrackPunch 
or QuickPunch enabled). 

Recording with TrackPunch 
Overview

This section explains how to use TrackPunch in 
Pro Tools sessions. 

Before using TrackPunch, configure Pro Tools 
and TrackPunch as follows: 
What’s New in Pro Tools TDM 6.4
To configure Pro Tools and TrackPunch: 

1  Configure TrackPunch preference settings as 
suggested in “TrackPunch Preferences” on 
page 10. 

2  If necessary, configure Pro Tools synchroniza-
tion settings for online recording and track arm-
ing (see “Configuring Synchronization and 
Track Arming” on page 11).

3  If necessary, program and configure the mas-
ter synchronizer for remote control of Track-
Punch and TrackInput switching (refer to the 
documentation from the manufacturer). 

TrackPunch Preferences

The following preference settings let you cus-
tomize TrackPunch performance. 

QuickPunch/TrackPunch Crossfade 
Length

This setting determines the length of the cross-
fade when punch recording in QuickPunch and 
TrackPunch modes. 

To set a crossfade length for QuickPunch and 
TrackPunch:

1  Choose Setup > Preferences, and click to dis-
play the Editing window. 

2  Enter a new crossfade length (10 ms is recom-
mended).

3  Click OK to close the Preferences dialog.

Transport and Track Record Settings

The Operation page of the Pro Tools Preferences 
dialog has been updated with new preferences 
for TrackPunch.



         
These preferences specify how track and Trans-
port record status should respond when the 
Transport is stopped (during playback and re-
cording), and let you optimize Pro Tools for 
film, video, and music production workflows as 
noted in the following sections.

Transport RecordLock

This setting lets the Transport Record be config-
ured to either emulate a digital dubber, or to 
maintain legacy behavior for the Transport mas-
ter Record. 

◆ When not enabled, the Transport Record dis-
arms when Pro Tools is manually stopped or 
stops due to a loss of time code. This replicates 
legacy Pro Tools recording behavior. 

◆ When enabled, the Transport Record remains 
armed when playback or recording stops. This 
saves having to re-arm the Transport between 
takes, emulating digital dubber behavior. 

TrackPunch Preferences

Punching out of record by pressing Record 
on the Transport will take the transport out 
of record enable.

TrackPunch 
Preferences
Destructive Recording and Transport RecordLock

As a precaution against accidentally recording 
over previous material, the Transport Record-
Lock preference is automatically disabled and 
greyed out when Destructive record mode is en-
abled. 

Audio Track RecordLock

This setting lets Pro Tools tracks be configured 
to either emulate a digital dubber, or to main-
tain legacy behavior for track record status. 

◆ When the Audio RecordLock preference is en-
abled, the record-enabled audio tracks remain 
armed when playback or recording stops. 

◆ When the Audio RecordLock preference is not 
enabled, record-enabled audio tracks are taken 
out of record enable when Pro Tools is stopped. 
This prevents tracks from remaining armed 
from pass to pass, emulating track record behav-
ior of a digital dubber.

Configuring Synchronization and 
Track Arming

For online recording and punching, configure 
the following Peripheral and Session Setup set-
tings. For best lockup times when synchroniz-
ing, it is recommended that no more than 16 
tracks be TrackPunch-enabled at a time.

To record online using TrackPunch and TrackInput 
switching:

1  Choose Setup > Peripherals, and make sure the 
SYNC I/O is the selected synchronization pe-
ripheral, and is communicating with Pro Tools. 
Chapter 2: What’s New in Pro Tools 6.4 11
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2  Choose Windows > Session Setup, and do the 
following:

• Select a Clock and Positional reference. 

– and –

• If you want Pro Tools to be the time code 
master, enable Using SYNC/USD. This op-
tion is located in the Generator controls in 
the Time Code Settings section of the Ses-
sion Setup window. 

3  If you are controlling Pro Tools via 9-pin pro-
tocol, do the following:

• Click the Machine Control tab to display 
the Machine Control page of the Peripher-
als dialog. 

• Configure Remote 9-pin Deck Emulation 
mode settings (see the MachineControl 
Guide for details).

• Click OK to close the Peripherals dialog.

4  Configure your master synchronizer as re-
quired to control Pro Tools track Record and In-
put switching through P2 commands. See the 
documentation for your controller for more in-
formation. 

Enabling TrackPunch Mode

Before you can enable individual audio tracks 
for TrackPunch recording, TrackPunch mode 
must be enabled in the Pro Tools transport.

To enable TrackPunch mode:

1  Make sure Pro Tools is not recording or play-
ing back (the Transport is stopped). 

Consult the manufacturer of your controller 
for the most recent machine profiles and up-
dates available for Pro Tools support. 
What’s New in Pro Tools TDM 6.4
2  Do one of the following:

• Select Operations > TrackPunch.

• Start-click (Windows) or Control-click 
(Macintosh) the Transport Record button 
to cycle through available Record modes 
until TrackPunch mode is selected (a “T” 
indicates TrackPunch mode). 

• Press Control+Shift+T (Windows) or Com-
mand+Shift+T (Macintosh).

Transport Display of TrackPunch 
Status

Transport Record Button

The Transport Record button indicates Track-
Punch and Record status as follows:

When TrackPunch mode is enabled:

◆ A “T” appears in the Transport Record button. 

◆ If at least one track is TrackPunch-enabled, 
the Transport Record button lights solid blue. 

Transport Record with TrackPunch mode enabled

TrackPunch and TrackInput status LEDs in the Transport 
window

Record LED
Input Status
LED

TrackPunch Enabled



When TrackPunch mode is enabled and the 
transport is armed for recording:

◆ If no tracks are TrackPunch-enabled, the 
Transport Record button flashes gray and red. 

◆ If at least one track is TrackPunch-enabled, 
the Transport Record button flashes blue and 
red.

◆ If at least one TrackPunch-enabled track is 
also record enabled, the Transport Record but-
ton flashes blue and red, and the record LED 
lights.

◆ Whenever at least one audio track is record-
ing, the Transport Record button lights solid 
red.

Record and Input Status LEDs

Record and Input LEDs next to the Transport 
Record button indicate track Record and Input 
status as follows, in all recording modes:

Record Status LED When lit (red), indicates that 
at least one audio track is currently record-en-
abled. When off (grey), no tracks are currently 
record-enabled. 

Input Status LED When lit (green), indicates 
that at least one audio track is currently set to 
Input Only monitoring (regardless of record en-
able status). When off (grey), all tracks are in 
Auto Input monitoring.

TrackPunch Enabling Tracks

You can TrackPunch enable tracks without 
record enabling them, which lets you punch in 
individual tracks after you start playback. 

Track record buttons also appear in blue to 
indicate that track is TrackPunch-enabled. 
See “Track Record Status Display” on 
page 14 for more information.
To TrackPunch enable or disable an audio track:

■ Start-click (Windows) or Control-click (Mac-
intosh) the track’s Record Enable button to tog-
gle the button to solid blue. 

To TrackPunch enable or disable all audio tracks: 

■ Alt-Start-click (Windows) or Option-Control-
click (Macintosh) a track’s Record Enable button 
to toggle the all Record Enable buttons to solid 
blue. 

To TrackPunch enable or disable all selected audio 
tracks:

■ Start-Alt-Shift-click (Windows) or Control-
Option-Shift-click (Macintosh) a track’s Record 
Enable button to toggle the Record Enable but-
tons for the selected audio tracks solid blue.

TrackPunch and Record Enabling 
Tracks

You can simultaneously TrackPunch enable 
tracks and record enable them, which starts re-
cording as soon as the transport is record-armed 
and the playback begins. 

To simultaneously TrackPunch enable and record 
enable an audio track:

■ Click the track’s Record Enable button to tog-
gle the track’s Record Enable button to flashing 
blue and red. 

Create track groups for each stem or set of 
tracks on which you plan to punch. Use the 
Groups List to quickly select all tracks in the 
group. This makes it easier and faster to 
take multiple tracks in and out of Track-
Punch enable simultaneously. 
Chapter 2: What’s New in Pro Tools 6.4 13
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To simultaneously TrackPunch enable and record 
enable all audio tracks:

■ Alt-click (Windows) or Option-click (Macin-
tosh) a track’s Record Enable button to toggle all 
Record Enable buttons to flashing blue and red.

To simultaneously TrackPunch enable and record 
enable all selected audio tracks:

■ Alt-Shift-click (Windows) or Option-Shift-
click (Macintosh) a track’s Record Enable button 
to toggle the Record Enable buttons for the se-
lected audio tracks solid blue. 

Track Record Status Display

Each track’s Record Enable button indicates its 
TrackPunch and record enable status as follows:

• When a track is both TrackPunch-enabled and 
record-enabled, its Record enable button 
flashes blue and red. 

• When a track is TrackPunch-enabled but not 
record-enabled, its Record Enable button 
lights solid blue. 

• When a track is record-enabled only, its 
Record Enable button flashes red. 

• While a track is recording (in any mode), its 
Record Enable button lights solid red.

TrackPunch status indication in an audio track in the 
Mix window 

Record Enable button
What’s New in Pro Tools TDM 6.4
TrackPunch Recording

After you have put Pro Tools in TrackPunch 
mode, and enabled tracks for TrackPunch re-
cording, you can record with TrackPunch in sev-
eral ways.

Punching In On Single Tracks

To punch in on single tracks:

1  Put Pro Tools in TrackPunch mode.

2  Start-click (Windows) or Control-click (Macin-
tosh) the Record Enable button for each track 
you want to punch in, so that the track is Track-
Punch-enabled only. The track’s Record Enable 
button should light solid blue. 

3  Click Record in the Transport window to enter 
the TrackPunch Record Ready mode. The Record 
button flashes blue and red.

4  Click Play in the Transport window to begin 
playback.

5  During playback, punch in and out on indi-
vidual TrackPunch-enabled tracks by clicking 
their Record Enable buttons.

6  Stop playback. When you are finished with 
the record pass, track Record Enable status and 
transport Record Arm status follow the current 
TrackPunch preference settings. 

Track Record status in the Edit window 

Red (not flashing) indicates recording
(all modes)



Punching In on Multiple Tracks

To punch in on multiple tracks simultaneously:

1  Put Pro Tools in TrackPunch mode.

2  Click the Record Enable button on each track 
you want to punch in, so that the track is both 
TrackPunch- and Record-enabled. The track’s 
Record Enable button should flash blue and red. 

3  Click Play in the Transport window to begin 
playback.

4  During playback, click Record in the Transport 
window to punch in and out on all TrackPunch-
enabled tracks simultaneously. 

5  Stop playback. When you are finished with 
the record pass, track Record Enable status and 
transport Record Arm status follow the current 
TrackPunch preference settings. 

Start Recording on All Tracks

1  Put Pro Tools in TrackPunch mode.

2  Click the Record Enable button on each track 
you want to punch in, so that the track is both 
TrackPunch- and Record-enabled. The track’s 
Record Enable button should flash blue and red. 

3  Click Record in the Transport window to enter 
the TrackPunch Record Ready mode. The Record 
button flashes blue and red.

4  Click Play in the Transport window to begin 
playback.

5  During playback, punch out and back in on 
individual TrackPunch-enabled tracks by click-
ing their Record Enable buttons.

6  Stop playback. When you are finished with 
the record pass, track Record Enable status and 
transport Record Arm status follow the current 
TrackPunch preference settings. 
File Management for TrackPunch

It is common to end up with a large amount of 
unused audio after using TrackPunch or Quick-
Punch. Unused audio files make sessions larger 
than may be necessary, which slows session 
loading, copying, transferring, archiving, and 
retrieval. 

The following describe how to manage files cre-
ated by TrackPunch and QuickPunch. 

Consolidating Tracks in a Region

After using TrackPunch, punched tracks will in-
clude any number of individual regions repre-
senting each of your final (or “keeper”) 
punches. Punched regions reference the whole 
file audio regions recorded in the background as 
part of TrackPunch and QuickPunch enabling 
(see “Audio Files and TrackPunch” on page 10). 

The Pro Tools Consolidate command lets you 
retain only the “keeper” punches as visible in 
the current track playlist. Consolidating regions 
in a track lets you extract the regions from their 
parent audio files in order to end up with a sin-
gle, consolidated audio file containing only the 
audio displayed in the playlist. 

To consolidate audio in a track:

1  Triple-click in a punched track (or any audio 
track) to select all regions and files in the cur-
rently displayed playlist. 

– or –

Make a selection in a track or tracks. 

To extract regions from their parent audio 
files without consolidating them into a sin-
gle track-based audio file, use the Compact 
Selected command in the Audio Regions List 
menu. 
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2  Choose Edit > Consolidate Selection.

– or –

Press Alt+Shift+3 (Windows) or Option+Shift+3 
(Macintosh). 

The new file name will be derived from the par-
ent track name. 

Removing Unused Audio

After consolidating, unused audio can be re-
moved from the session.

To remove unused audio after consolidating:

■ Choose Select Unused from the Audio Re-
gions List menu, and clear all unused regions. 
For more information on Select Unused, see the 
Pro Tools Reference Guide. 

TrackInput Monitoring 
TrackInput monitoring lets you toggle individ-
ual audio tracks between Auto Input and Input 
Only monitoring modes at any time, including 
during playback or recording. TrackInput pro-
vides the monitoring flexibility needed in dub-
bing and mixing, and is similar to “rehearse” 
mode on analog multitrack recorders and simi-
lar machines.

With the Digidesign MachineControl 2.0 op-
tion (available separately), TrackInput can also 
be remotely controlled from a SoundMaster and 
compatible devices through P2 protocol com-
mands (with support for pec-direct paddles as 
supported on the synchronizer or console). 

Be certain to create crossfades for edits be-
fore consolidating. The real-time AutoFade 
option does not create crossfades during 
consolidation.
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The TrackInput feature also makes it possible to 
toggle a track between Auto Input and Input 
Only monitoring mode regardless of whether or 
not the track is record enabled.

To toggle the monitoring mode of audio tracks do 
one of the following:

■ To toggle individual tracks, click the TrackIn-
put button for each track you want to toggle. 
The TrackInput button will light green.

■ To toggle all tracks in the session, Alt-click 
(Windows) or Option-click (Macintosh) a Track-
Input button. All the TrackInput buttons will 
light green.

■ To toggle all selected tracks in the session, Alt-
Shift-click (Windows) or Option-Shift-click 
(Macintosh) a selected track’s TrackInput but-
ton. All the TrackInput buttons for the selected 
tracks will light green. 

To change the monitoring mode of all record-
enabled tracks, do one of the following:

■ To change all record-enabled tracks to Auto 
Input monitoring mode, Choose Operations > 
Change Record Enabled Tracks to Auto Input.

■ To change all record-enabled tracks to Input 
Only monitoring mode, Choose Operations > 
Change Record Enabled Tracks to Input Only.

■ To toggle the monitoring mode of all record-
enabled tracks between Input Only monitoring 
mode and Auto Input monitoring mode, use 
Alt-K (Windows) or Option-K (Macintosh).

TrackInput buttons in the Edit Window

TrackInput Off (Auto Input)

TrackInput On (Input Only)



Monitoring Mode Preferences

The Operation page of the Pro Tools Preferences 
dialog has been updated with new preferences 
for TrackInput.

These preferences specify how track and Trans-
port record status should respond when the 
Transport is stopped (during playback and re-
cording), and let you optimize Pro Tools for 
film, video, and music production workflows as 
noted in the following sections.

Disable “Input” When Disarming Track (In 
“Stop”)

For flexibility, TrackInput can be customized to 
remain selected regardless of track record status, 
or to automatically switch to Auto Input moni-
toring after a recording pass. This lets you opti-
mize monitoring for a typical dubbing workflow 
(in which you might want tracks to remain in 
Input Only mode until explicitly switched to 
Auto Input monitoring) or a typical music track-
ing workflow (in which leaving a track in Input 
Only monitoring mode after recording can re-
sult in accidental double-monitoring. 

TrackInput Preferences

TrackInput 
Preferences
To customize TrackInput for recording:

1  Choose Setup > Preferences, and open the Op-
eration page. 

2  Configure the setting for Disable “Input” 
When Disarming Track (In “Stop”) setting as ap-
propriate. 

• When enabled, taking an audio track out of 
record enable (any mode) takes it out of In-
put Only mode, regardless of the global 
monitor mode, and switches it to monitor 
audio from disk only. 

• When not enabled, audio tracks will re-
main in Input Only monitoring mode until 
explicitly switched to Auto Input monitor-
ing. 

“Stop” Mutes Audio Inputs (When In Auto 
Input)

◆ When enabled, Pro Tools mutes tracks that 
are record-enabled when the Transport is 
stopped. Input can still be monitored while 
stopped using the TrackInput button.

◆ When not enabled, Pro Tools monitors audio 
input on tracks that are record-enabled.
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Clip Indication Enhancements
Pro Tools 6.4 provides clip indication enhance-
ments, new clipping settings, and clip clearing.

Clip Indication Enhancements

Clipping indication has been added to the fol-
lowing three locations in the Pro Tools inter-
face: 

• Plug-in window header

• Plug-in and Sends Insert button 

• Track names in the Show/Hide Tracks List

Plug-In Header Clip Reporting

In addition to clipping displays in the plug-in’s 
interface, plug-ins that display clipping also re-
port the clipping in the plug-in header.

To clear plug-in clips:

■ Click the clip LED in the plug-in header

Plug-In and Send Clip Reporting

When a plug-in or send clips, the Input or Send 
for the track displays in red to indicate clipping.

Show/Hide List Clip Reporting

When a track, plug-in, or send clips, the 
Show/Hide List displays the track’s name in red.

Plug-In Clipping indicator in the plug-In header

Clip
LED
What’s New in Pro Tools TDM 6.4
Clip Settings

Pro Tools 6.4 provides three options for display-
ing clip indication: 

• 3 Second

• Infinite

• None

To choose a clip setting:

1  Choose Setups > Preferences.

2  Click the Display tab.

3  Select a Clip Indication option.

4  Click Done.

Clearing All Clips

To clear all clipping, do one of the following:

■ Press Alt-C (Windows) or Option-C (Macin-
tosh).

■ Alt-Click (Windows) or Option-Click (Macin-
tosh) the clip LED in the Plug-in header.

■ Alt-Click (Windows) or Option-Click (Macin-
tosh) any track or send clip LED.

■ Choose Operations > Clear All Clips.



Plug-In Menus by Category
In Pro Tools 6.4, plug-ins are automatically or-
ganized by category (effect type). Plug-ins that 
do not fit into a standard category (such as the 
DigiRack Signal Generator), or third-party plug-
ins that have not been defined by their develop-
ers, appear in the Other category. Plug-ins can 
appear in more than one category. 

Plug in categories include:

• EQ

• Dynamics

• Pitch Shift

• Reverb

• Delay

• Modulation

• Harmonic

• Noise Reduction

• Dither

• Sound Field

• Hardware

• Instrument

• Other

• Wrapped Plug-Ins

To organize plug-ins by category:

1  Choose Setups > Preferences.

2  Click on the Display tab.

3  Select Organize Plug-In Menus By Category.

Plug-Ins by Category
Plug-in Favorites

For faster navigation to commonly used plug-
ins, a plug-in can now be designated a favorite. 
Favorite plug-ins are shown at the top of the 
plug-in menu.

To designate a plug-in favorite:

■ Control-click (Windows) or Command-click 
(Macintosh) on a plug-in Insert button, and se-
lect the plug-in that you want to designate as a 
favorite.

To remove a plug-in favorite:

■ Control-click (Windows) or Command-click 
(Macintosh) on a plug-in Insert button, and se-
lect the favorite plug-in that you want to re-
move.

Menu display of favorite plug-Ins

Favorite plug-ins

Plug-in categories
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23.976 FPS Support
Pro Tools sessions now support 23.976 fps for 
high-definition digital video and audio produc-
tion workflows. 23.976 fps, a production variant 
of 24 fps (sometimes referred to as 23.98 fps), 
has been added as a time code rate (frame rate) 
available in Pro Tools sessions.

23.976 fps is supported when using Bounce to 
Disk, when importing and exporting files, and 
when importing and exporting OMF/AAF se-
quences (requires DigiTranslator 2.0). All 
Pro Tools pull up and pull down factors are 
available at 23.976 fps. Set Feet+Frames to the 
appropriate film speed of your session.

Frame edge accuracy at 23.976 fps requires a 
Digidesign SYNC I/O.

In addition, Pro Tools and the SYNC I/O only 
provide near sample accurate lock to frame edge 
when the clock reference is video at 25 fps or 
29.97 fps, or when resolved to LTC input. 

For this reason, frame edge alignment is un-
available in the following configurations:

• When using serial time code and resolved to 
video reference and the session is 23.976 fps 
(or 24 fps, or 30 fps)

• When in Remote 9-Pin Deck Emulation mode 
and the session is 23.976 fps, 24 fps, or 30 fps)

• When resolved to NTSC or PAL video frame 
edge and the session is 23.976 fps (or 24 fps, 
or  30 fps)

To set a session to 23.976 fps:

1  Choose Windows > Session Setup.

2  Select 23.976 fps from the Time Code Rate se-
lector. 
What’s New in Pro Tools TDM 6.4
The time code Timeline Ruler displays 23.976 
fps, as will all location counters (when viewing 
time code). The Edit window grid, and all nudg-
ing can be configured to 23.976 fps increments 
and units. 

The SYNC I/O indicates 23.976 fps by flashing 
the 24 fps LED. 

In addition, 23.976 becomes an available choice 
for the Target project time code format in the 
Export Selected as Files, Bounce to Disk, and Ex-
port Selected Tracks as OMF commands. 

Projects at 23.976 fps can be imported into 
Pro Tools through the Import Session Data dia-
log, with support for offsets. 

Feet+Frames Enhancements

Feet+Frame Rate Selector 

A new Feet+Frame Rate selector has been added 
to the Session Setup window. This lets you select 
from three available feet+frame rates: 25, 24, 
and 23.976 fps. 

Redefine Current Feet+Frames Position 

The new Redefine Current Feet+Frames Position 
command enhances (and replaces) the previ-
ously available Feet+Frames command. Rede-
fine Current Feet+Frames Position command 
adds the ability to specify a Feet+Frames value 
based on the current Edit cursor time code loca-
tion. Typically, this feature lets test tones, pre-
roll, Academy leader, and similar pre-program 
material to be more easily integrated into 
Pro Tools sessions. 



Pro Tools Interface Changes

Transport Controls in the Edit 
Window

The Transport commands can now be displayed 
and operated in the Edit window (at the top 
right of the window). 

To show or hide Transport controls in the Edit 
window:

1  Choose Display > Edit Window Shows.

2  Select Transport View. 

New Location for Machine Control 
and Remote Mode Preferences

A new Machine Control page has been added to 
the Preferences dialog. This page contains pref-
erences for Machine Control and Remote Mode.

To access Machine Control and Remote Mode 
Preferences:

1  Choose Setups > Preferences.

2  Click on the Machine Control tab.

Transport controls displayed in the Edit window.

MachineControl Preferences
Renamed Features

Certain Pro Tools features have been renamed 
or changed. 

◆ Auto Voice mode has been renamed and is 
now Dynamic Voice Allocation (dyn) mode. 

• The names of Pro Tools input monitoring 
commands have changed, as follows:

• Auto Input Monitoring is now Change 
Record Enabled Tracks to Auto Input

• Input Only Monitoring is now Change 
Record Enabled Tracks to Input Only. 

• The Frame Rate selector in the Session Setup 
window has been renamed Time Code Rate. 
This selector lets you set a SMPTE format 
frame rate for the current Pro Tools session. 
Choices include 30, 29.97, 29.97 Drop, 25, 24, 
and 23.976 fps. 

• The Limit Pull Ups to NTSC/PAL Film Stan-
dards preference in the Operations dialog has 
been eliminated. All supported frame rates 
will be displayed in the Time Code window.

Voice options

Off
Dynamic Voice Allocation

Voices already assigned

Available voice assignments
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