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Introduction
This document is an overview of new features in
Pro Tools TDM 6.7 for Pro Tools|HD systems on
Windows XP or Mac OS X.

System Requirements
For complete system requirements, visit the
compatibility page of the Digidesign Web site
(www.Digidesign.com/compato).

Compatibility Information
Digidesign can only assure compatibility and
provide support for hardware and software it
has tested and approved.
For a list of Digidesign-qualified computers, operating systems, hard drives, and third-party devices, refer to the latest compatibility information on the Digidesign Web site
(www.digidesign.com/compato).

New Features
Pro Tools TDM 6.7 includes the following new
or enhanced features:
• New Tracks dialog improvements
• Color Coding for tracks, regions, markers, and
groups
• Memory Location comments
• Undo History window
• Plug-in interface changes
• Next and Previous settings buttons
• Plug-in Settings dialog, for recalling or auditioning presets
• MIDI Node display
• Multiple plug-in outputs for instrument plugins
• Support for RTAS instruments on Auxiliary Inputs
• Tick-based tracks (audio tracks, Auxiliary Inputs, and Master Faders)
• Sync Point improvements
• Song Start Marker
• Tap Tempo changes
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• Time Operations window
• Change Meter
• Insert Time
• Cut Time
• Move Song Start
• Tempo Operations window
• Constant
• Linear
• Parabolic
• S-Curve
• Scale
• Stretch
• Graphic Tempo Editor
• Improved Delay Compensation for MIDI
tracks
• Beat Detective MIDI analysis
• MIDI Step Input
• TCE Trimmer functionality on MIDI regions
• Automatic MIDI controller playlist assignments
• MIDI Studio Setup window (Windows only)
• MIDI Patch name support for Windows XP
• MIDI I/O support for Windows XP
• MIDI Time Stamping support for external devices (Windows only)
• Send Session via DigiDelivery command
(Windows only)
• Mac/PC session file conversion
(Windows only)
• Non-Administrator (Standard) account support
• Keyboard Shortcuts
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What’s New In Pro Tools 6.7
To create new tracks:

New Tracks Dialog
Improvements

1 Choose File > New Tracks.
2 Select the type of track you want to add from

Pro Tools 6.7 lets you create all of your new
tracks and track types at the same time. Multiple
new track fields can be added (or deleted) in the
New Tracks dialog to create different track type
combinations from a single dialog.
Number of new tracks
Track Format

Add/Delete
Track
Track Timebase

Track Type

the Track Type pop-up menu.

To auto-scroll the Track Type pop-up menu
in the New Track dialog, press Control
(Windows) or Command (Macintosh) and
use the Up/Down Arrow keys.
3 Select the track format (mono, stereo, or one

of the multichannel surround formats) from the
Track Format pop-up menu.

To auto-scroll the Track Format pop-up
menu, press Control (Windows) or Command (Macintosh) and use the Left/Right
Arrow keys.
New Tracks dialog

Tracks in the session appear in the order they are
specified in the New Tracks dialog as follows.
To insert new tracks next to a specific track in
a session, select that track by clicking the track’s
name in the Edit or Mix window before opening
the New Tracks dialog. The new tracks are added
immediately after the selected track.

◆

To insert new tracks after the last tracks in a
session, make sure that no track names are selected on-screen before opening the New Tracks
dialog.

◆

4 Select the timebase (samples or ticks) from the
Track Timebase pop-up menu.

For more information about Tick-based
tracks, see “Tick-Based Tracks
(Audio Tracks, Auxiliary Inputs, and Master Faders)” on page 10.
To auto-scroll the Track Timebase pop-up
menu, press Control-Alt (Windows) or
Command-Option (Macintosh) and use the
Up/Down Arrow keys.
5 Enter the number of new tracks.
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6 Do one of the following:

If you wish to add more tracks, create additional
New Track entry fields by clicking the Add button, then repeat steps 2 to 5 for each new field.
– or –
If you wish to remove the previous track entry
field, click the Delete Track button

To add or delete a Track Entry field in the
New Tracks dialog, you can press Control
(Windows) or Command (Macintosh) and
use the Plus (+) or Minus (–) key on the numeric keypad, or you can press ControlShift (Windows) or Command-Shift (Macintosh) and use the Up/Down Arrow keys.

Show/Hide Tracks List Track colors are displayed in vertical color bars that appear to the
left of each track name.
Groups List Track colors are displayed in vertical
color bars that appear to the left of each group
name.
Default colors are automatically assigned to
tracks, but you can override those colors by
choosing from a color palette of 96 possible colors. For more information, see “Color Palette”
on page 6.
To change color coding options:
1 Choose Setups > Preferences.
2 Click Display.

7 Click Create.

Color Coding for Tracks,
Regions, Markers and Groups
Separate colors can be assigned to audio and
MIDI regions, tracks, markers, and groups.
Regions shown in waveform and block views in
the Edit window are drawn in color. Tracks
shown in the Show/Hide list, in the Groups list,
and in the Mix and Edit windows have associated color bars.

Color Bars
Color Coding at the track level is displayed using color bars.

Display page in the Preferences dialog

Mix Window Track colors are displayed in horizontal color bars that appear above each channel strip, and below the track name.

4 Select a Default Region Color Coding option.

Edit Window Track colors are displayed in vertical color bars that appear to the left of each
track.
4
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3 Select a Default Track Color Coding option.

5 Click Done.

Display Page Preferences for
Color Coding
Color coding options determine how colors are
assigned to the display of tracks and regions.

Default Region Color Coding
These color coding options determine how colors are assigned to the display of regions.

Always Display Marker Colors
This setting lets you choose to view Marker colors in the Marker ruler, regardless of the settings
you choose for Default Region Color Coding.

Default Track Color Coding

Region Color Coding Choices

None Turns off default color assignment for regions. Regions are drawn as black waveforms or
black MIDI notes on a light gray background.
Tracks and MIDI Channels Assigns a color to
each region in the Edit window according to its
voice or MIDI channel assignment.
Track Color Coding Choices

None Turns off default color assignment for
tracks.
Tracks and MIDI Channels Assigns a color to
each track in the Edit or Mix window according
to its voice assignment or MIDI channel assignment.
Tracks and MIDI Devices Assigns a color to each
track in the Edit or Mix window according to its
voice assignment or MIDI device assignment.
Groups Assigns a color to each track according to
its group ID. If groups are suspended using the
Suspend Groups command, the tracks color bars
are not shown.

Tracks and MIDI Devices Assigns a color to each
region in the Edit window according to its voice
assignment or MIDI device assignment.
Groups Assigns a color to each region according
to the group ID of its track. If groups are suspended (using the Suspend Groups command)
all regions display black waveforms or MIDI
notes on a light gray background.
Track Color Assigns a region color based on the
color assigned to the track.
Marker Locations Assigns a color to data across
all tracks based on the nearest preceding marker.

Track Type Assigns a color to each track according to its type (audio, MIDI, Auxiliary Input, or
Master Fader).

Chapter 2: What’s New In Pro Tools 6.7

5

Color Palette

Memory Location Comments

The Color palette lets you make color selections
for tracks, regions, groups and markers.

Comments

Color Palette

Any of the three types of Memory Locations
(Marker, Selection, and None) can store and recall comments. You can enter a maximum of
255 characters to describe the Memory Location.

To apply a color from the Color Palette:
1 Select a region, track, marker, or group by do-

ing one of the following:
• To select a region, click the region with the
Grabber tool.
• To select a track, click the name of the track
in its track channel strip.
• To select a marker, click the marker in the
Markers window.
• To select a group, click to the left of the
group letter in the group bin. A black dot
shows that the group is selected.
2 Choose Windows > Show Color Palette.
3 Select a color from the palette, or select one of
the following:

Memory Location dialog

Default Removes any custom coloring and restores the color to the default color set in the
Display Preferences page.
None Turns off color assignment. Affected regions are drawn with black waveform or MIDI
notes on light gray background. Affected tracks
and groups no longer show their color bars.

Memory Locations
Comments can be shown in the Memory Locations window.

Comments in Memory Locations window

To show comments in the Memory Locations
window:
1 Choose Windows > Show Memory Locations.

6
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2 Click the Name button.

To undo operations in the Undo History window:

3 Choose Show Comments.

■ Click the operation you wish to undo in the
list.

When Comments is selected, a column appears
in the Memory Locations window that displays
the comments for each of the Markers.

All operations in the queue that were performed
after the operation you select will also be undone.
To redo operations in the Undo History window:

Undo History
Pro Tools keeps track of up to 32 of the last undoable operations, allowing you to return to a
previous editing state. The Undo operations in
Pro Tools are stored in a queue, in the order in
which they were invoked.

■ Click the operation you wish to redo in the
list.

All redoable operations in the queue that were
performed before the operation you select will
also be redone.

You can use the Undo History window to view
the queue of undo operations and return to any
previous state. The Undo History can show edit
creation times, enabling you to revert to the
state a session held at a particular time.

■ Click the Options pop-up menu and choose
Undo All.

Undoable operations are shown in bold, and operations that have already been undone are
shown in italic.

■ Click the Options pop-up menu and choose
Redo All.

To undo all the operations in the Undo Queue:

To redo all the operations in the Redo Queue:

Clearing the Undo Queue
Options selector

To clear the Undo Queue
Undoable
operations
Redoable
operations
Creation times
Undo History window

To show (or hide) the Undo History window:
■

Choose Windows > Show Undo History.

■ Click the Options pop-up menu and choose
Clear Undo Queue.

Other operations that will clear the Undo Queue
include:
• Deleting a track, or clearing a region from the
Audio or MIDI Regions List
• Selecting “Select Unused” in the MIDI Regions List pop-up menu
• Selecting “Select Unused Regions,” or “Select
Unused Regions Except Whole Files” in the
Audio Regions List pop-up menu
• Importing tracks or session data
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When the number of operations in the Undo
History reaches the maximum level of Undo (set
in the Edit page of the Preferences dialog), performing another undoable operation will remove the oldest operation at the top of the
Undo History queue. When the oldest operation
is one operation away from being pushed out of
the queue, it is shown in red.

Plug-In Settings Dialog
The Plug-In Settings dialog lists the settings files
for the current plug-in type. From this list, you
can select a new setting, or audition a series of
settings. Auditioning plug-in settings is especially useful for selecting patch names for virtual
MIDI instrument plug-ins or trying out different
effects types applied to your audio.

Plug-In Interface Changes

The Plug-In Settings dialog includes the following:

Pro Tools 6.7 offers new options within the
plug-in header for choosing plug-in settings (or
patches), and for showing MIDI nodes.

Folder This pop-up menu lets you switch between plug-in settings subfolders, or root and
session settings folders.

Previous setting

Patch Field This field displays the name of the
active (highlighted) setting.

Next setting

Settings
Select

MIDI node
Plug-in header options

Next (+) and Previous (–) Setting
Buttons
These buttons let you select the next or previous
setting of the Librarian menu.
To change plug-in settings using the +/– buttons:
Click the Plus (+) or Minus (–) buttons to select the next or previous plug-in settings file.
The next (or previous) settings file are enabled,
and the Librarian menu changes to reflect the
new setting.
■

Plug-in Settings dialog

To change plug-in settings using the Settings
dialog:
1 Click the Settings Select button.
2 Select a folder from the Folder pop-up menu.

To switch between settings folders, press
Control (Windows) or Command (Macintosh) and use the Up/Down Arrow keys.
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3 From the Settings dialog, select the desired

MIDI Node Display

plug-in setting.
– or –
Use the Arrow keys to scroll through the available settings.
4 Click Done.

Auditioning Plug-in Settings
When the Plug-in Settings dialog is open, you
can have Pro Tools automatically scroll through
and audition the settings files saved in the plugin’s root settings folder or in the current session’s Settings folder.
To audition plug-in settings:
1 Click the Settings Select button.
2 From the Settings dialog, click a setting—the

starting point from which you will scroll
through the settings files.
3 Enter a value for the number of seconds that

will elapse between each program change, and
press Enter.
4 Select the option for Increment Patch.

After the specified number of seconds, Pro Tools
selects the next setting.
5 When you are finished auditioning settings,

click Done to stop incrementing patches, and to
close the Plug-in Settings dialog.

The MIDI Node display displays MIDI node information for MIDI-enabled plug-ins. MIDI
nodes are virtual connections from Pro Tools to
software instruments and other MIDI-enabled
plug-ins. MIDI nodes are useful for routing multiple MIDI tracks to different channels of a single virtual MIDI device. MIDI node numbers are
also displayed in a track’s MIDI Output Selector.

Multiple Outputs for
Instrument Plug-Ins
Pro Tools 6.7 introduces the capability to route
the output of an instrument plug-in to the main
track outputs and to individual track inputs on
other tracks. This lets you route multiple samples or synth sounds through separate outputs
for individual processing.

For specific information about using multiple plug-in outputs with third-party plugins, consult the documentation from the
plug-in manufacturer.

Main and Auxiliary Plug-In Outputs
When a plug-in that has both main and auxiliary outputs is inserted on a track, the plug-in’s
main outputs are routed through the track that
the plug-in is inserted on, and the plug-in’s auxiliary mono or stereo outputs are available in the
track input pop-up menu on other tracks.

If none of the inserted plug-ins has auxiliary
outputs, the plug-in category in the track input pop-up menu is grayed out.
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RTAS Instrument Plug-Ins (and
Other RTAS Plug-Ins) on
Auxiliary Inputs

Tick-Based Tracks
(Audio Tracks, Auxiliary
Inputs, and Master Faders)

RTAS-based instrument plug-ins (and other
RTAS plug-ins) can be played through Auxiliary
Inputs, as follows.

In Pro Tools 6.7 you can choose to make audio
tracks, Auxiliary Inputs, and Master tracks either
sample-based or tick-based. Like MIDI tracks
(which are always tick-based), tick-based audio
is fixed to Bars|Beats, and moves relative to the
sample timeline when tempo and meter
changes occur.

• When using an RTAS instrument plug-in
(such as Native Instruments Kontakt) on an
Auxiliary Input, the instrument must be
the first plug-in in the signal flow.

Only instrument plug-ins are available in
the RTAS pop-up menu on the initial insert.

RTAS plug-in menu on the initial insert of an Auxiliary
Input

• Once you have added an RTAS instrument
to a Auxiliary Input, other RTAS processing
plug-ins may be inserted, but only after the
RTAS instrument plug-in.

In previous versions of Pro Tools, all audio is
sample-based, with all audio regions in a session
having an absolute location on the timeline. Audio stays fixed to the sample time, regardless of
where tempo or meter changes occur in a session.
This differs from MIDI notes, which are tickbased, and stay fixed to bar and beat locations.
When tempo changes, MIDI events move relative to sample-based, absolute time.
MIDI events, and tick-based audio respond differently to tempo changes in respect to duration. MIDI note events change length when
tempo or meter is adjusted, while audio regions
do not. With tick-based audio, meter and tempo
changes affect only the start point (or sync
point) for each audio region in a tick-based
track.
You can select whether a track is sample-based
or tick-based when you create it, or change timebases later.

Switching Timebases
Audio tracks, Auxiliary Inputs, and Master
tracks, can be switched between sample-based
timing and tick-based timing. MIDI tracks are always tick-based.

10
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To switch the timebase of an audio track:
If the track’s height is set to Small or larger,
click the Timebase Selector for the track and select the desired timebase from the pop-up
menu. The Timebase Selector changes to reflect
your choice.

To change the timebase for all audio playlists in a
track:

■

.

1 Verify that the “Selection Changes Alternate
Playlists” option is selected in the Timebase Selector pop-up menu.
2 Switch the timebase, using the Timebase Se-

lector.
.

Timebase Selector
(ticks)

Timebase Selector
(samples)

Timebase Selector on a track with a Medium height
Timebase Selector pop-up menu

Groups

Timebase Selector
(ticks)

Timebase Selector
(samples)

Timebase Selector on a track with a Small height

If the track’s height is set to Mini, click the
small arrow next to the Track View Selector to
get the Track Height pop-up menu, and select
the desired timebase from the Timebase submenu.

■

When you change the timebase for an audio
track that is part of an active group, all the audio
tracks in the group will change to the same
timebase.

Audio Region Location
In tick-based audio tracks, the location of an audio region is determined by the region’s start
point, unless the region contains a region sync
point.
If the region contains a sync point, the sync
point determines where the audio region is
fixed to the Bar|Beat grid.

Track Height pop-up menu

Alternate Playlists
When you change a track’s timebase, you can
choose to apply the timebase change to that
track only, or to that track and all the alternate
playlists for that track.

Automation Playlists and Drift
When an audio track is set to a sample-based
timeline, the track’s automation playlist is unaffected by changes in tempo.
When an audio track is set to a tick-based timeline, however, the automation breakpoints
change to match the changes in tempo.
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Since the length of each audio region in a track
is unaffected by changes in tempo, existing automation data is out of sync with the audio after
a tempo change is made to a tick-based audio
track.

When tempo changes on a tick-based audio track...

Fades
Fade-Ins and Fade-Outs
Although fades appear to be discrete regions,
fades cannot be separated from the regions in
which they were created.
When changing tempo in a tick-based audio
track, fade-ins and fade-outs remain with their
parent regions, and are unaffected by changes in
tempo.

Crossfades

...automation gets out of sync with audio.
Tempo changes applied to larger regions

In general, automation drift is more pronounced with larger audio regions. The effects
of automation drift can be minimized by creating smaller audio regions. This is because the
start points of each subsequent region change as
the tempo changes.

Using many smaller regions...

Crossfades are re-rendered after changing tempo
in a tick-based audio track. The new crossfade is
the same length as the crossfade prior to the
tempo change.
If there is not enough audio material to complete the crossfade, or if the new crossfade area
falls outside of valid region boundaries, the
crossfade is removed.

Importing Tracks
When importing tracks into your current session from another Pro Tools session, tick-based
audio tracks, Auxiliary Inputs, and Master tracks
are converted to a sample timebase, unless the
Import Tempo/Meter Map option is selected in
the Import Session Data dialog.
To import timebase information while importing
audio:

...keeps audio aligned with automation changes.
Tempo changes applied to small regions

1 Choose File > Import Session Data, select the
session to import data from, and click Open.
2 In the Source Tracks section, select tracks to

import by clicking the pop-up menu to the right
of each track name and selecting Import As New
Track.
3 Select the Import Tempo/Meter Map option.
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4 Click OK.

2 Choose Edit > Bring Region to Front to make

the region overlap the neighboring regions.

Playlists

– or –

An audio playlist’s timebase is saved with the
playlist. When you recall an unassigned audio
playlist and assign it to any audio track, the
track will change to the saved timebase of the
playlist.

Region Boundaries

Choose Edit > Send Region to Back to make the
region underlap the neighboring regions.
If multiple overlapping regions are selected,
Pro Tools will apply the command to each region as that region relates to the neighboring region on the right.

Region Overlap

Trim to Fill Gaps Commands

When a tick-based audio track has multiple regions, a tempo increase can cause neighboring
regions to overlap. Audio regions can be set to
display a small “dog-ear” corner to indicate
overlapping region boundaries.

The Trim to Fill Gaps commands let you automatically reveal underlying material in the gaps
between regions. You can choose to fill gaps by
revealing underlying audio from either the start
point of the following audio regions, or from
the end point of the preceding audio regions.

Overlap region

To trim from a start point to fill gaps:
1 With the Selector, select across at least one gap
between regions.
2 Choose Edit > Trim > Start to Fill Gaps.

Underlap region
Region overlap and underlap

To toggle the region order display:
■

The start point of the region behind the gap is
automatically trimmed to the next region, or as
far as possible if there is not enough underlying
material to cover the gap.

Choose Display > Display Region Overlap.

Changing Region Overlap/Underlap
After tempo changes and other edits, regions
may overlap in undesired ways. To correct this,
a region can be brought to the front, or sent behind neighboring regions as needed.
To change the region overlap or underlap:
1 In the Edit window, choose the region or re-

gions you want to re-order.

Region start trimmed to fill gap
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To trim from an end point to fill gaps:

Sync Point Display

1 With the Selector, select across at least one gap
between regions.

When you identify a sync point, a small down
arrow appears at the bottom of the region, with
a vertical, light grey line indicating the location
of the sync point.

2 Choose Edit > Trim > End To Fill Gaps.

The end point of the region in front of the gap is
automatically trimmed to the previous region,
or as far as possible if there is not enough underlying material to cover the gap.

Sync points

Sync Points

Dragging Sync Points
You can drag a sync point to another position in
the audio region.
To set the sync point by dragging:
1 If you want the sync point to snap to the cur-

Region end trimmed to fill gap

rent grid value, set the Edit mode to Grid.
2 Select the Grabber tool.

Sync Point Improvements
Pro Tools 6.7 provides the following improvements for sync points:
• Enhanced display of sync points in a region.
• Sync point dragging.
• Sync point scrubbing.
• New command for removing sync points
from regions.

3 Drag the sync point to a new location.

Scrubbing Sync Points
While viewing an audio waveform can be a good
way to set a sync point, a waveform display may
not always reveal the desired spot in the audio
material. By scrubbing while moving the sync
point over an audio waveform, you can listen
for the exact sync point.

• New command for hiding sync points in
regions.

Sync Point Scrub cursor
Scrubbing a Sync Point
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To scrub while dragging the sync point:
1 Select the Scrubber tool.

This marker defines the initial tempo for
Bar|Beat-based material. The Song Start Marker
is movable, but cannot be deleted.

2 Drag the sync point to a new location. The

sync point will scrub the audio as you move it.

To move the Song Start Marker by dragging:

Removing Sync Points

■ In the Tempo Ruler, drag the Song Start
Marker left or right.

To remove a sync point:
Select the area of the region that contains the
sync point and choose Edit > Remove Sync
Point.

■

– or –
Alt-Click (Windows) or Option-Click (Macintosh) the sync point to delete it.

■

Hiding Sync Points
Sync points in audio regions may hidden or displayed.

Dragging the Song Start Marker

If the Edit mode is set to Grid, the Song Start
Marker moves in increments of the current Grid
value.

The position of the Song Start Marker can
also be changed in the Time Operations
window. For more information, see “Move
Song Start Page” on page 21.

To hide sync points in audio regions:
Deselect Display > Display Sync Point In Regions.

■

To display sync points in audio regions:
Choose Display > Display Sync Point In Regions.

■

To move the Song Start Marker only, without moving the tick-based data, press StartShift (Windows) or Control-Shift (Macintosh) while dragging. When dragging the
Song Start Marker only, dragging is constrained to whole bar increments only.
To edit the initial tempo of the Song Start Marker:
1 In the Tempo Ruler, double-click the Song

Song Start Marker

Start Marker.

The Song Start Marker replaces the Default
Tempo marker.

2 In the Tempo Change dialog, enter a new BPM

value.
3 Click OK.

Song Start Marker

When a new session is created, the Song Start
Marker has no associated meter event. A meter
event at the Song Start Marker is created when a
meter event is created anywhere in the meter
ruler.
Chapter 2: What’s New In Pro Tools 6.7
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Tap Tempo

Time Operations Window

You can manually set the tempo for a Pro Tools
session by tapping on your computer keyboard
or a connected MIDI keyboard.

The Time Operations window lets you define
meter, click and song start options. This window
opens when choosing any of the following commands from the MIDI menu:

To manually set the tempo by tapping:

• Change Meter

1 To view the MIDI controls in the Transport

• Insert Time

window, select Display > Transport Window
Shows > MIDI Controls.

• Cut Time

2 In the Transport window, click the Conductor

button so it becomes unhighlighted. Pro Tools
switches to Manual Tempo mode. In this mode,
any tempo events in the Tempo Track are ignored.

Conductor button

To reconfigure the Time Operations window for
a different command, select the command from
from the pop-up menu at the top of the window, or choose the command from the MIDI
menu.

Change Meter Page
Tempo field

Manual Tempo mode enabled
3 Click in the Tempo field so it becomes highlighted and tap the “T” key on your computer
keyboard repeatedly at the new tempo.

– or –
Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note
repeatedly at the new tempo on your MIDI keyboard controller.
To compute the new tempo, Pro Tools averages
the last eight (or fewer) taps. The computed
BPM value appears in the Transport’s Tempo
field.

16
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The Change Meter page lets you specify complex meter changes for Bar|Beat-based material.
You can enter meter changes at a particular bar,
make a meter change over a selected area of
time, or add meter changes sequentially one bar
at a time.
To open the Change Meter page:
■

Choose MIDI > Change Meter.

Press Alt+1 (Windows) or Option+1
(Macintosh) on the numeric keypad to
open the Time Operations window and
display the last active Time Operations
page.

Pro Tools automatically calculates the nearest
whole bar number, or you can specify a number
of bars to be affected. Time is inserted or deleted
at the end of the selection, as necessary, on all
affected tracks when you override the calculated
range.

Realign

Change Meter page

Change Meter Options
Options for the Change Meter command include:
New Meter Lets you specify a new time signature. The first field lets you enter the number of
beats (up to 99) in a measure, and the second
field lets you enter the note length that counts
as one beat.
Click Lets you specify the note value that will
trigger the metronome click. For example, if an
eighth note is chosen, a click is played for every
eighth note, regardless of tempo.
Starting at Bar Sets the bar where the meter
change is added. Meter changes made in the
Change Meter page can only be made at the beginning of a bar.
Apply Change To Lets you apply the meter
change to the selected range, to the end of the
session, or until the next bar.
Change The Change fields let you specify the
number of bars of the new meter that you wish
to have replace the selected range.

The Realign controls let you choose which items
to realign after meter changes have been made.
You can choose to realign meter events, or
choose to realign meter and tempo events, tickbased markers and tracks, and all or none of the
sample-based tracks.
Meter Ruler Only Applies meter changes to the
meter ruler only. All other rulers and tracks are
unaffected.
Meter and Tempo Rulers, Tick-Based Markers and
Tracks, and Sample-Based Markers and Tracks
Applies meter changes to all rulers, tick-based
tracks, and your choice of either all or no sample-based tracks. Time is inserted or deleted as
needed at the end of the selection to preserve
whole bars.

Change Meter Examples
To change the meter over a range of bars:
1 Drag with the Selector to select a range of bars

to change.
– or –
◆ To have the meter change apply until the next
meter event, click where you want the meter
change to begin with the Selector. The meter
change will be made at the beginning the nearest bar.

2 Choose MIDI > Change Meter.
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3 Specify a new meter and click setting.
Pro Tools will automatically set the selection options to fit the new meter to the selected range
as closely as possible, adding or subtracting
beats a necessary.

Insert Time Page

4 Choose which rulers and tracks you wish to
realign after meter changes have been made.

To open the Insert Time page:

The Insert Time page lets you insert an amount
of blank time into conductor rulers, MIDI
tracks, and audio tracks.

■

Choose MIDI > Insert Time.

5 Click Apply.

To add a series of meter changes, one measure at
a time:
1 With the Selector, click where you want the
meter change to begin. The Meter change will
be made at the beginning the nearest bar.

Press Alt+1 (Windows) or Option+1
(Macintosh) on the numeric keypad to
open the Time Operations window and
display the last active Time Operations
page.

– or –
Enter the first measure number in the Starting
At Bar field.
2 Choose MIDI > Change Meter.
3 Specify a new meter and click setting.
4 Choose “Until the Next Bar” from the Apply
Change To pop-up menu.
5 Click Apply to enter the new meter and to
move the insertion point to the end of the new
measure.
6 Specify a new meter and click setting for the
next measure.
7 Repeat steps 5–6 for every additional meter

change you wish to insert.

Insert Time page

Insert Time Options
Options for the Insert Time command include:
Start, End and Length Sets the start and end
points for the selection, and the selection
length.
Set Meter If your main time scale is Bars|Beats,
Set Meter lets you specify a new meter for the inserted time. The selection is quantized to the
nearest bars, and the previous meter is inserted
after the selection.
If your main time scale is sample-based, Set
Meter is not available.
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Realign
The realign controls let you choose which items
shift when time is cut.
• If your main time scale is set to Bars|Beats, you
can choose to realign meter events, or choose
to realign a combination of meter and tempo
rulers together, all tick-based markers and
tracks, and your choice of either all or no sample-based tracks.
• If your main time scale is set to an absolute
timebase, you can choose to independently
realign conductor events, tick-based markers
and tracks, and your choice of sample-based
tracks.
Meter Ruler Only If your main time scale is
Bars|Beats, you have the option to insert time
into the meter ruler only. Meter events after the
start point of the selection are shifted past the
end point by the length of time selection.
If your main time scale is sample-based, Realign
Meter Ruler Only is not available.

Sample-Based Markers and Tracks Lets you shift
absolute time-based markers, and insert time
into sample-based tracks. Marker events and
sample-based tracks after the start point of the
selection are shifted past the end point by the
length of time inserted.
If the selection includes any audio regions on
sample-based tracks, the selected portions of the
audio regions are separated at the start point,
and the new region containing the previous selection is shifted to the end point.

Insert Time Example
To insert four empty measures of 4/4 time into a
session:
1 Set the

Main Time Scale to Bars|Beats.
2 Choose MIDI > Insert Time.
3 Enter the measure where you want to insert

the measures in the Start field.
4 Enter four measures in the Length field.

Meter and Tempo Rulers Lets you insert time
into the Meter and Tempo rulers. Meter and
Tempo events after the start point of the selection are shifted past the end point by the length
of time inserted.

5 Select the option to Realign meter and tempo
rulers, all tick-based tracks, and all sample-based
markers and tracks.
6 Click Apply.

Tick-Based Markers and Tracks Lets you shift
Bar|Beat-based markers, and insert time into
tick-based tracks. Marker events and tick-based
tracks after the start point of the selection are
shifted past the end point by the length of time
inserted.
If the time selection includes any audio regions
on tick-based tracks, the audio regions are separated at the start point, and the new region containing the previous selection is shifted to the
end point.
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Cut Time Page

Realign

The Cut Time page lets you cut a specified
amount of time from conductor rulers, MIDI
tracks, and audio tracks.

The Realign controls let you choose which items
shift when time is cut.

To open the Cut Time page:
■

Choose MIDI > Cut Time.

Press Alt+1 (Windows) or Option+1
(Macintosh) on the numeric keypad to
open the Time Operations window and
display the last active Time Operations
page.

• If your main time scale is set to Bars|Beats, you
can choose to realign meter events, or choose
to realign a combination of meter and tempo
rulers together, all tick-based markers and
tracks, and your choice of either all or no sample-based tracks.
• If your main time scale is set to an absolute
timebase, you can choose to independently
realign conductor events, tick-based markers
and tracks, and your choice of sample-based
tracks.
Meter Ruler Only If your main time scale is
Bars|Beats, you have the option to remove time
from the meter ruler only. Meter events within
the selection are removed, and meter events
that occur after the end point of the selection
are shifted to the selection start point.
If your main time scale is sample-based, Realign
Meter Ruler Only is not available.

Cut Time page

Cut Time Options
Options for the Cut Time command include:
Start, End and Length Sets the start and end
points for the selection, and the selection
length.

Meter and Tempo Rulers Lets you cut time from
the Meter and Tempo rulers. Meter and tempo
events within the selection are removed, and
the meter and tempo events that occur after the
end point of the selection are shifted to the selection start point.
Tick-Based Markers and Tracks Lets you shift
Bar|Beat-based markers, and delete time from
tick-based tracks. Marker events and tick-based
tracks within the selection are removed, and the
marker events and tick-based tracks that occur
after the end point of the selection are shifted
forward.
If the time selection includes any tick-based audio regions, the selected area of the audio region
is deleted, and the region following the selection is shifted forward.
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Sample-Based Markers and Tracks Lets you shift
absolute time-based markers, and cut time from
sample-based tracks. Marker events and samplebased tracks within the selection are removed,
and the marker events and sample-based tracks
that occur after the end point of the selection
are shifted forward.
If the time selection includes any sample-based
audio regions, the selected area of the audio region is deleted, and the region following the selection is shifted forward.

Move Song Start Page
The Move Song Start page lets you redefine the
location of the Song Start Marker.
To open the Move Song Start page:
■

Choose MIDI > Move Song Start.

Press Alt+1 (Windows) or Option+1
(Macintosh) on the numeric keypad to
open the Time Operations window and
display the last active Time Operations
page.

Cut Time Example
To cut thirty seconds from a session:
1 Set the Main Time Scale to Minutes:Seconds.
2 Choose MIDI > Cut Time.
3 With the Selector, click at the beginning of

the area that you want to cut.
4 Enter thirty seconds (0:30.000) in the Length

field.
5 Select the options to Realign both meter and

tempo rulers, all tick-based tracks, and all sample-based markers and tracks.

Move Song Start page

6 Click Apply.

Move Song Start Options
Options for the Move Song Start command include:
Timebase Lets you precisely redefine the position of the Song Start Marker measured by any
supported timebase.
Move Start To Sets the location for the Song
Start Marker in the chosen timebase.
Renumber First Bar To When enabled, this lets
you set the Song Start Marker to any bar number.
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Move
The move controls let you choose which items
shift when the Song Start is moved, as follows:
Song Start Only Moves the Song Start Marker
only. This option is only available when the
Timebase pop-up menu is set to Bars.
Meter and Tempo Rulers, Tick-Based Markers and
Tracks, and Sample-Based Markers and Tracks
Moves the Song Start Marker, tick-based tracks,
and your choice of all or no sample-based
tracks.

Tempo Operations Window
This window lets you define tempo events over
a range of time (or measures). The time range is
specified in the time format chosen for your
Main Time Scale. In addition, the Tempo Operations window lets you:
• Fit a specific number of Bars|Beats into a
precise time range.
• Create tempos that speed up or slow down,
both linearly and over various curves.
• Scale and stretch existing tempos.

Move Song Start Example

The Tempo Operations window has six pages,
one for each type of tempo operation.

To move the Song Start Marker to 15 seconds on
the timeline:

Constant Lets you create a constant tempo over
a selected range of time.

1 Choose MIDI > Move Song Start.
2 Select Minutes:Seconds from the Timebase
pop-up menu.
3 In the Move Song Start field, enter “0:15:000”

to move the song start forward by 15 seconds.
4 If you wish to renumber the bars so that the
Song Start Marker sits at a different bar, select
the Renumber Song Start option, and enter the
bar number in the Renumber Song Start field.
5 Choose the items you wish to move, if any.
6 Click Apply.

Linear Lets you create tempos that change
evenly over a selected range of time.
Parabolic Lets you create tempos that accelerate
or retard following a tempo curve, which
changes the tempo more rapidly or less rapidly
over the selection time.
S-Curve Lets you create tempos that accelerate
or retard following a tempo curve with a definable breakpoint that determines mid-curve
times and tempo values.
Scale Lets you scale tempos within the selection
by a percentage amount.
Stretch Lets you select a region of tempo events
and apply them to a larger or smaller selection
area.
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Constant Page
Use the Constant page to create a constant
tempo over a selected range of time.
To open the Constant page:
Choose MIDI > Tempo Operations > Constant.

■

Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Constant Page Advanced Options
Press Alt+2 (Windows) or Option+2
(Macintosh) on the numeric keypad to
open the Tempo Operations window and
display the last active Tempo Operations
page.

Advanced view of the Constant page

Calculate Lets you choose to calculate either the
tempo, or the selection end time.
Constant page

Advanced When the Advanced checkbox is selected, the selection range changes to the Main
Time Scale format, and additional and modified
options become available.

See “Constant Page Advanced Options” on
page 23.
Selection Start and End Specifies the start and
end point for the tempo change in Bars|Beats.
When an Edit selection is made, the Start and
End fields will display the selection boundaries.
Tempo Specifies the tempo to apply to the selected range.

Selection Start and End Displays the start and
end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or
end values changes the selection range.
End Time Displays the selection end time. When
the Main Time Scale is set to Bars|Beats, the end
time is displayed in the Sub Time Scale. When
the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in
Bars|Beats.
Changing the end time value causes the tempo
to change.
Chapter 2: What’s New In Pro Tools 6.7
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Tempo Displays the tempo, in beats per minute
(BPM), for the selected range. Changing the
tempo causes the end time value to change.
Resolution Lets you choose the BPM note value
for your tempo setting.

Choosing “Follow Metronome Click” will
set the tempo BPM note value to mirror the
click value set in the meter markers.
Preserve Tempo after Selection If selected, the
tempo setting in effect before the selection start
point is put at the selection end point. If unselected, the last tempo event created by the
tempo operation continues to the end of the session, or until the next tempo event beyond the
selected range.

Linear Page
Use the Linear page to create tempos that
change evenly over a selected range of time.
To open the Linear page:
■

Choose MIDI > Tempo Operations > Linear.

Press Alt+2 (Windows) or Option+2
(Macintosh) on the numeric keypad to
open the Tempo Operations window and
display the last active Tempo Operations
page.
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Linear page

Advanced When the Advanced checkbox is selected, the selection range changes to the Main
Time Scale format, and additional and modified
options become available.

See “Linear Page Advanced Options” on
page 25.
Selection Start and End Specifies the start and
end point for the tempo change in Bars|Beats.
When an Edit selection is made, the Start and
End fields will display the selection boundaries.
Tempo Start and End Specifies the start and end
tempos for the tempo change range.
Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Linear Page Advanced Options

Tempo Start and End Displays the tempo, in
beats per minute (BPM), for the start and end
points of the selected range. Changing the
tempo can causes the start tempo or the end
time value to change.
Resolution Lets you choose the BPM note value
for your tempo curve.

Choosing “Follow Metronome Click” will
set the tempo BPM note value to mirror the
click value set in the meter markers.
Density Lets you specify the density of the
tempo change events written to the Tempo
Ruler.
Advanced view of the Linear page

Calculate Lets you choose to calculate either the
selection end time, the start tempo, or the end
tempo.
Selection Start and End Displays the start and
end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or
end values changes the selection range.

Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

End Time Displays the absolute time for the selection end. When the Main Time Scale is set to
Bars|Beats, the end time is displayed in the Sub
Time Scale. When the Main Time Scale is set to
any absolute timebase, the end time is calculated and displayed in Bars|Beats.
Changing the end time value causes tempo values to change.
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Parabolic Page
Use the Parabolic page to create tempos that accelerate or decelerate, following a tempo curve
which changes the tempo more rapidly or less
rapidly over the selection time.
To open the Parabolic page:
Choose MIDI > Tempo Operations > Parabolic.
■

Press Alt+2 (Windows) or Option+2
(Macintosh) on the numeric keypad to
open the Tempo Operations window and
display the last active Tempo Operations
page.

Selection Start and End Specifies the start and
end point for the tempo change in Bars|Beats.
When an Edit selection is made, the Start and
End fields will display the selection boundaries.
Tempo Start and End Specifies the start and end
tempos for the tempo change range.
Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Parabolic Page Advanced Options

Parabolic page

Advanced When the Advanced checkbox is selected, the selection range changes to the Main
Time Scale format, and additional and modified
options become available.

See “Parabolic Page Advanced Options” on
page 26.
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Advanced view of the Parabolic page

Calculate Lets you choose to calculate the selection end time, the start tempo, the end tempo,
or the curvature of the tempo change.

Selection Start and End Displays the start and
end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or
end values changes the selection range.
End Time Displays the absolute time for the selection end. When the Main Time Scale is set to
Bars|Beats, the end time is displayed in the Sub
Time Scale. When the Main Time Scale is set to
any absolute timebase, the end time is calculated and displayed in Bars|Beats.
Changing the end time value causes the tempo
to change.

Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

S-Curve Page
Use the S-Curve page to create tempos that accelerate or decelerate, following a tempo curve
with a definable breakpoint that determines
mid-curve times and tempo values.
To open the S-Curve page:

Tempo Start and End Displays the tempo, in
beats per minute (BPM), for the start and end
points of the selected range. Changing the
tempo causes the end time value to change.
Curvature Specifies and displays a numerical
and graphic representation of the tempo curve.
Negative numbers indicate a more rapid tempo
change at the beginning of the time range, and
positive numbers indicate a more rapid tempo
change at the end of the time range. This value
can be set with the Curvature slider.

■

Choose MIDI > Tempo Operations > S-Curve.

Press Alt+2 (Windows) or Option+2
(Macintosh) on the numeric keypad to
open the Tempo Operations window and
display the last active Tempo Operations
page.

Resolution Lets you choose the BPM note value
for your tempo setting.

Choosing “Follow Metronome Click” will
set the tempo BPM note value to mirror the
click value set in the meter markers.
Density Lets you specify the density of the
tempo change events written to the Tempo
Ruler.

S-Curve page
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Advanced When the Advanced checkbox is selected, the selection range changes to the Main
Time Scale format, and additional and modified
options become available.

S-Curve Page Advanced Options

See “S-Curve Page Advanced Options” on
page 28.
Selection Start and End Specifies the start and
end point for the tempo change in Bars|Beats.
When an Edit selection is made, the Start and
End fields will display the selection boundaries.
Tempo Start and End Specifies the start and end
tempos for the tempo change.
Curvature Specifies and displays a numerical
and graphic representation of the tempo curve.
Negative numbers indicate a more rapid tempo
change at the start and end of the time range,
with a low rate of change around the midpoint.
Positive numbers indicate a low rate of change
near the start and end of the selected range,
with rapid tempo change around the midpoint.
This value can be set with the Curvature slider.
Mid Point Specifies the Bar|Beat location for the
curve mid point. This value can be set with the
Mid Point slider.
Mid Tempo Specifies the tempo at the mid point.
This value can be set with the Mid Tempo slider.
Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Advanced view of the S-Curve page

Calculate Lets you choose to calculate either the
selection end time, the start tempo, the end
tempo or the curvature of the tempo change.
Selection Start and End Displays the start and
end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or
end values changes the selection range.
End Time Displays the absolute time for the selection end. When the Main Time Scale is set to
Bars|Beats, the end time is displayed in the Sub
Time Scale. When the Main Time Scale is set to
any absolute timebase, the end time is calculated and displayed in Bars|Beats.
Changing the end time value causes the tempo
to change.
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Tempo Start and End Displays the tempo, in
beats per minute (BPM), for the start and end
points of the selected range. Changing the
tempo causes the end time value to change.

Scale Page

Curvature Specifies and displays a numerical
and graphic representation of the tempo curve.
Negative numbers indicate a more rapid tempo
change at the start and end of the of the time
range, with a low rate of change around the
midpoint. Positive numbers indicate a low rate
of change near the start and end of the selected
range, with rapid tempo change around the
midpoint. This value can be set with the Curvature slider.

To open the Scale page:

Use the Scale page to scale tempos within the selection by a percentage amount.

■

Choose MIDI > Tempo Operations > Scale.

Press Alt+2 (Windows) or Option+2
(Macintosh) on the numeric keypad to
open the Tempo Operations window and
display the last active Tempo Operations
page.

Mid Point Specifies the Main Time Scale location
for the curve mid point. This value can be set
with the Mid Point slider.
Mid Tempo Specifies the tempo at the mid point.
This value can be set with the Mid Tempo slider.
Resolution Lets you choose the BPM note value
for your tempo setting.

Choosing “Follow Metronome Click” will
set the tempo BPM note value to mirror the
click value set in the meter markers.
Density Lets you specify the density of the
tempo change events written to the Tempo
Ruler.
Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Scale page

Advanced When the Advanced checkbox is selected, the selection range changes to the Main
Time Scale format, and additional and modified
options become available.

See “Scale Page Advanced Options” on
page 30.
Selection Start and End Specifies the start and
end point for the tempo change in Bars|Beats.
When an Edit selection is made, the Start and
End fields will display the selection boundaries.
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Average Tempo Displays the average tempo, in
beats per minute (BPM), for the selected range.
Changing the tempo causes the Scale percentage to change.

Scale In combination with settings chosen in
the Calculate pop-up menu, the Scale pop-up
menu lets you choose to scale all tempos, the
start tempo, or the end tempo.

Scale Specifies the percentage change to apply
to the selected tempo events.

Selection Start and End Displays the start and
end points for the tempo operation in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or
end values changes the selection range.

Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Scale Page Advanced Options

End Time Displays the absolute time for the selection end point. When the Main Time Scale is
set to Bars|Beats, the end time is displayed in the
Sub Time Scale. When the Main Time Scale is set
to any absolute timebase, the end time is calculated and displayed in Bars|Beats.
Changing the end time value causes the tempo
to change.
Tempo Start and End Displays the tempo, in
beats per minute (BPM), for the start and end
points of the selected range. Changing the start
or end tempo causes the scale percentage to
change.

Advanced view of the Scale page

Calculate In combination with settings chosen
in the Scale pop-up menu, the Calculate pop-up
menu lets you choose to calculate the selection
end time, the average tempo, the start tempo, or
the end tempo.
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Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Stretch Page
Use the Stretch page to select a region of tempo
events and apply them to a larger or smaller selection area.
To open the Stretch page:
■

Choose MIDI > Tempo Operations > Stretch.

Press Alt+2 (Windows) or Option+2
(Macintosh) on the numeric keypad to
open the Tempo Operations window and
display the last active Tempo Operations
page.

Stretch To End Specifies a new end point for the
region that you wish to apply the selected
tempo events to. Changing the end point causes
the Stretch percentage to change.
Stretch Specifies the percentage of time for the
the selected tempo events to cover.
Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Stretch Page Advanced Options

Stretch page

Advanced When the Advanced checkbox is selected, the selection range changes to the Main
Time Scale format, and additional and modified
options become available.

See “Stretch Page Advanced Options” on
page 31.
Selection Start and End Specifies the range of
tempo events that you wish to modify. When an
Edit selection is made, the Start and End fields
will display the selection boundaries.

Advanced view of the Stretch page

Stretch Specifies which direction the selected
tempo events will be stretched. If you choose to
stretch the selection start, the selection end will
remain fixed, and the selection start will be adjusted based on the stretch percentage. If you
choose to stretch the selection end, the selection start will remain fixed, and the selection
end will be adjusted based on the stretch percentage.
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Selection Start and End Displays the start and
end points for the tempo operation in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or
end values changes the selection range.
Stretch to Start Time or End Time Displays the
Stretch start and end times, depending on the
Stretch percentage, and your choice in the
Stretch pop-up menu.
Stretch Specifies the percentage of time for the
the selected tempo events to cover.

Graphic Tempo Editor
The Tempo Editor, a resizeable window beneath
the Tempo Ruler in the Edit window, lets you
view and edit tempo information graphically.

Tempo Editor
The Tempo Editor is an expansion of the Tempo
Ruler, opening in the rulers section of the Edit
window.
Expand/Collapse triangle

Preserve Tempo after Selection If selected, the
previous tempo setting that was in effect at the
selection end point is preserved after the selection. If unselected, the last tempo event created
by the tempo operation continues to the end of
the session, or until the next tempo event beyond the selected range.

Tempo events
Tempo Editor

To display the Tempo Editor
■ Choose Display > Ruler View Shows > Tempo
Editor.

– or –
■ Click the Expand/Collapse triangle on the
Tempo Ruler name plate.
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Editing Tempo Events in the Tempo
Editor
Tempo events in the Tempo Editor can be edited
with any of the following methods:

Using the Pencil Tool
Tempo can be drawn in the Tempo Editor using
the Pencil tool, with the following shapes:

Individual tempo events can be dragged with
the Grabber to adjust their location or value.

◆

A group of selected tempos can be scaled up or
down with the Trimmer.

◆

New tempo events can be drawn in with the
Pencil tool to replace existing ones.

◆

These tool
shapes are
not functional
in the Tempo
Editor.

Tempo events can be copied and pasted,
nudged, and shifted.

◆

Using the Grabber
The Grabber lets you change tempo settings by
dragging tempo events in the Tempo Editor.
To remove a tempo event with the Grabber:
Alt-click (Windows) or Option-click (Macintosh) the tempo event with the Grabber.

■

To increase or decrease a tempo setting with the
Grabber:
Drag a tempo event up for a faster tempo setting, and down for a slower setting.

Pencil tool shape pop-up menu

Freehand This shape draws freely according to
the movement of the mouse. The shape is reproduced as a series of steps according to the Tempo
Density setting. (For more information, see “Selecting Edit Density” on page 34.)

■

Line This shape draws in a straight line from
click to release. Tempo values change in steps
according to the Tempo Density Resolution.
(For more information, see “Selecting Edit Density” on page 34.)

Using the Grabber to change a tempo event

Triangle This shape is disabled in the Tempo Editor.

To change the location of a tempo event with the
Grabber:

Square This shape is disabled in the Tempo Editor.

Drag a tempo event to the left or right to adjust the location of the tempo change.

■

Random This shape is disabled in the Tempo Editor.
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Parabolic This shape draws the possible curve to
fit your freehand drawing. The shape is reproduced as a series of steps according to the Tempo
Density setting.
S-Curve This shape draws a best possible fit of an
S-Curve to your freehand drawing. The shape is
reproduced as a series of steps according to the
Tempo Density setting.

A tempo curve can have different BPM values if
there are meter click changes within the selected
range.

Because it can be unnecessarily complicated
to set Meter events separately for each
Tempo event, Digidesign recommends
choosing Follow Metronome Click in most
cases.

Selecting BPM Rate
The Tempo Editor lets you specify the note
value that the BPM rate is based on for all tempo
events created when you draw a tempo curve
with the Pencil tool.

Quarter note
click

Dotted quarter
note click

Tempo curve with different click values

Selecting Edit Density

Resolution pop-up menu

The Tempo Editor lets you specify the density of
tempo events created in the Tempo Ruler when
you draw a tempo curve with the Pencil tool.

To select the BPM rate for Pencil tool edits:
■ Select a note value from the Resolution popup menu. Tempo events created by drawing
with the Pencil tool will have their BPM set to
the note value you choose.

– or –
■ Choose Follow Metronome Click. Tempo
events created by drawing with the Pencil tool
will have their BPM set to mirror the click values
set by meter events in the Meter ruler.

Density pop-up menu

To select the tempo event density for Pencil tool
edits:
■ Select a time value from the Density pop-up
menu. Tempo events created by drawing with
the Pencil tool will be placed in the tempo ruler
at the density that you choose.
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To Select a tempo event in the Tempo Editor:

Pressing Start (Windows) or Control (Macintosh) before drawing a pencil line conforms already created tempo events to the
drawn line rather than creating new tempo
events.

Using the Selector tool or Grabber tool, doubleclick on the horizontal tempo line.

Curve Adjustment Mode
Immediately after you draw new tempos using
the Pencil tool, a tempo curve appears in blue,
outlining the newly created tempo graph. Blue
adjustment handles on the curve let you adjust
the shape and size of the new tempo graph.
Tempo Curve Adjustment Handles

Selecting a single tempo event

To Select a tempo curve in the Tempo Editor:
■ Using the Selector tool or Grabber tool, tripleclick on a horizontal tempo line in the curve
that you wish to select.

Tempo curve adjustment
Selecting a tempo curve

-

All the new tempo events under the curve
will change as you move the Tempo Curve
Adjustment Handles. To adjust the curve
shape without the track data adjusting immediately, press Start (Windows) or Control
(Macintosh) while adjusting the curve.
Tempo events will change to fit the new
curve when you release the mouse button.

Extending Tempo Selections
You can extend Tempo selections to the next or
the previous tempo event.
To extend a tempo selection:
1 Select a portion of a region, or click anywhere

in the region.

The blue adjustment handles are only active until a new tool is selected or a new command is
executed.

2 Press Shift+Tab to extend the selection to the

Selecting Tempo Events

Press Shift+Control+Tab (Windows) or
Shift+Option+Tab (Macintosh) to extend the selection to the previous tempo event.

You can easily select a single tempo event, or an
entire tempo curve within the Tempo Editor.

next tempo event.
– or –
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Using the Trimmer
The Trimmer lets you scale all the tempo events
of the session, or within a time selection. the
trimmer tool also lets you stretch a region of
tempo events to cover a longer or shorter area in
the timeline.
To scale all the session’s tempo events with the
Trimmer:

To change the rate of tempo change with the
Trimmer:
1 Open the Tempo Editor.
2 Using the Selector tool, select the area you

wish to edit.
3 Select the Trimmer tool.
4 Click either the start or end handle for the selected range, and drag up or down.

1 Open the Tempo Editor.
2 Select the Trimmer tool.
3 Click above the tempo events and drag up or
down. Dragging up increases the tempo values;
dragging down decreases them.

Changing the rate of tempo change with the Trimmer

To stretch or shrink the tempo change range with
the Trimmer:
1 Open the Tempo Editor.
2 Using the Selector tool, select the area you

Changing tempos with the Trimmer

wish to edit.

To scale selected tempo events with the Trimmer:

3 Select the Trimmer tool.

1 Open the Tempo Editor.

4 Click at the start or end of the selection, and

2 Using the Selector tool, select the area you

drag horizontally. Tempo events will maintain
their relative spacing to each other but will be
spaced over a larger or smaller area.

wish to edit.
3 Select the Trimmer tool.
4 Click within the selected area, and drag up or

down. Dragging up increases the tempo values
of the selection; dragging down decreases them.

Changing the tempo change range with the Trimmer

Changing selected tempos with the Trimmer
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Moving, Cutting, Pasting and Nudging in the
Tempo Editor
To move a selected group of tempo events in the
Tempo Editor:
1 Open the Tempo Editor.
2 Using the Selector tool, select the area you

wish to move.
3 Click on any selected tempo event with the

grabber, and drag horizontally to move the
tempo events to a new location.

Press Alt (Windows) or Option (Macintosh)
while dragging to move a copy of the tempo
events.
To copy and Paste tempo events in the Tempo
Editor:
1 Open the Tempo Editor.
2 Using the Selector tool, select the area you

wish to copy.
3 Choose Edit > Copy.

Extending Tempo Selections
You can extend Tempo selections to the next or
the previous tempo event.
To extend a tempo selection:
1 With the Selector, select a portion of a region,
or click anywhere in the region.
2 Press Shift+Tab to extend the selection to the

next tempo event.
– or –
Press Shift+Control+Tab (Windows) or
Shift+Option+Tab (Macintosh) to extend the selection to the previous tempo event.

Changing the Timebase Display
You can choose to view the Edit window in either a Linear Tick (Bars|Beats) scale or a Linear
Tick (absolute) time scale. MIDI tracks, audio
tracks, and Tempo curves can appear and function very differently depending on the timebase
display settings.

4 Click in the Tempo Editor at the point where
you want to paste the tempo events.
5 Choose Edit > Paste. Your copied selection is

pasted from the insertion point, replacing any
existing tempo events.
Timebase Display pop-up menu

To nudge a selection in the Tempo Editor:
1 Open the Tempo Editor.
2 Using the Selector tool, select the area you

The Timebase Display pop-up menu determines
whether the Tempo Editor displays and creates
tempo events in a Bars|Beats or Absolute timebase.

wish to nudge.
3 On the numeric keypad, do one of the follow-

ing:
• Press Plus (+) to move the selected tempo
events forward by the Nudge value.

When set to Linear Tick Display, the tempo
events are tick-based and their Bar|Beat locations remain constant after the tempo curve is
drawn—though their relation to audio is scaled,
resulting in a new sample locations.

• Press Minus (–) to move the selection back
by the Nudge value.
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When set to Linear Sample Display, the display
of tempo events is sample-based and their bar
and beat locations can shift after the tempo
curve is drawn.

Drawing tempo events using the Linear
Sample Display can cause Bar|Beat based
material to move in non-intuitive ways.
Digidesign recommends that you use Linear
Tick Display when you draw tempo
changes.
To change the timebase display:
■ Select a timebase from the Timebase Display
pop-up menu.

Edit Density and Edit Display Timebases
When both the Density setting in the Tempo
Editor and the Timebase Display setting are set
to either a Bars|Beats time scale or to an absolute
time scale, Tempo edits will appear evenly
spaced. When the Density setting in the Tempo
Editor and the Timebase Display setting are set
so that one is set to an absolute time scale and
the other is set to a Bars|Beats time scale, the
number of Tempo edits will appear to increase
or decrease over time.

Low-Latency Recording with Virtual
MIDI Instruments
When a MIDI track that is routing MIDI data to
a virtual instrument is record enabled, Pro Tools
automatically suspends delay compensation
through the main outputs of the audio track or
Auxiliary Input that the virtual instrument is inserted on. This allows for latency-free monitoring of the virtual instrument during recording.

Delay Compensation for virtual MIDI instruments works only when all MIDI and
audio connections take place inside of
Pro Tools. For example, Pro Tools does not
suspend delay compensation when you are
using ReWire to connect software synthesizers and samplers.

MIDI and Audio Processing Plug-Ins
Some plug-ins, such as Bruno and Reso, process
audio while allowing MIDI data to control processing parameters. When you record enable a
MIDI track that is controlling an Audio processing plug-in, the track the plug-in is inserted on
will go into low-latency mode, effectively making the processed audio play early.
To keep audio time-aligned when using a MIDI
controlled plug-in on an audio track:

Improved Delay
Compensation for MIDI Tracks
Pro Tools 6.7 extends Delay Compensation to
MIDI tracks and virtual MIDI instruments.
When Delay Compensation is active, a MIDI
event that is recorded to sound “in time” with
delay compensated material actually is recorded
late by the length of total delay in effect.
To compensate, MIDI events are shifted back in
time by the total session delay following each
MIDI recording pass.
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■ Start-Control-click (Windows) or CommandControl-click (Macintosh) the Track Compensation indicator for the audio track to apply delay
compensation.

To keep audio time-aligned when using a MIDI
controlled plug-in on an Auxiliary Input:
1 Start-Control-click (Windows) or Command-

Control-click (Macintosh) the Track Compensation indicator for the Auxiliary Input to bypass
delay compensation.

2 Enter the total system delay into the User Offset field.

Beat Detective MIDI Analysis
Beat Detective MIDI analysis lets you to use
MIDI tracks to generate tempo and groove information. Groove information generated from
MIDI is interchangeable with groove information generated from audio, letting you apply
MIDI generated grooves to audio material or
vice versa.
MIDI analysis works in the following modes:
Bar|Beat Marker Generation Generates Bar|Beat
Markers corresponding to the location of notes
and chords in MIDI selections.
Groove Template Extraction Extracts the rhythmic and dynamic information from MIDI data,
and saves this information to the Groove Clipboard, or as a DigiGroove template.
To generate beat triggers from a MIDI selection:

6 Define the selection range. If the tempo and

meter of the audio selection do not match the
session’s default tempo and meter, enter the
Time Signature, and Start Bar|Beat and End
Bar|Beat locations. For a four-bar selection that
starts on beat 1, enter 1|1 and 5|1.
7 If your MIDI track contains chords, choose

one of the following MIDI chord recognition algorithms from the Analysis pop-up menu:
• Last Note
• First Note
• Loudest note
• Average location
• Highest Note
• Lowest
8 Click the Analyze button.

MIDI Chord Recognition
Since MIDI notes in a chord may be played at
slightly different moments, Beat Detective interprets notes that are close together (closer than
half the time value that is set in the Selection
Contains field) as a chord.

1 In the Edit window, set the MIDI track you

wish to use to Notes view.

Highest Note

2 Make a selection across a range of MIDI data.

Make certain that the selection start and end
points are at musically relevant locations, such
as barlines.

First
Note

Last
Note

3 Choose Windows > Show Beat Detective.
4 Select MIDI from the operation pop-up menu.
5 In the Beat Detective window, select one of

the following modes:
• Bar|Beat Marker Generation

Lowest Note
MIDI chord analysis

Beat Detective will use the criteria you set in the
Analysis pop-up menu to interpret the location
of the beat in relation to the chord.

• Groove Template Extraction
Last Note Sets the beat trigger to the start of the
last note played in the chord.
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First Note Sets the beat trigger to the start of the
first note played in the chord.
Loudest Note Sets the beat trigger to the start of
the note in the chord played with the highest
velocity.

Preserving tick position emulates Beat Detective
behavior from previous Pro Tools releases. Preserving sample position is useful for creating
tempo maps for MIDI or tick-based audio performances without altering the performance itself.

Average Note Sets the beat trigger to a point that
represents the average between the start of the
first note played in the chord, and the last note
played in the chord.
Highest Note Sets the beat trigger to the start of
the highest note played in the chord.
Lowest Note Sets the beat trigger to the start of
the lowest note played in the chord.

Realign Session
Beat Detective’s Realign Session function lets you
generate Bar|Beat markers without tick-based
material shifting.
Generating Bar|Beat markers in sessions with
tick-based material, such as MIDI tracks and
tick-based audio tracks, can cause the tick-based
material to shift in absolute time.
When you generate Bar|Beat Markers in a session that contains tick-based audio or MIDI
tracks, Beat Detective gives you the option to
preserve the position of the session’s tick-based
material, or to allow the material to shift.

Realign Session dialog

To generate Bar|Beat Markers with Beat
Detective in a session with tick-based tracks:
1 In the Edit window, make an audio or MIDI se-

lection.
2 In the Beat Detective window, select Bar|Beat

Marker Generation mode.
3 Define or capture the selection as described in
the Beat Detective chapter of the Reference
Guide.
4 Set the Detection resolution to Bars or Beats.
5 Click the Generate button.
6 In the Realign Session dialog, choose Preserve
Tick Position if you wish to let the tick-based
material shift in absolute time.

– or –
Choose Preserve Sample Position if you wish to
have the tick-based material maintain its absolute position.
7 Click OK.
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MIDI Step Input
Step Input lets you use a MIDI controller to enter notes individually, one step at a time. This
gives you precise control over note placement,
duration, and velocity. With MIDI step input
you can also create musical passages that might
be difficult to play accurately, or at a fast tempo.

Step Input Window

3 Select the Enable option.

When Step Input is enabled, each previously record-enabled MIDI track is taken
out of record enable, and if a Default Thru
Instrument is defined in the MIDI page of
the Preferences window, it is disabled.
4 Choose the MIDI track you wish to record on
from the Destination pop-up menu.
5 Choose the note value you wish to enter from
the Step Increment section.

To enter MIDI notes with Step Input (using an
external MIDI Instrument):

6 Play a note or chord on your MIDI instru-

1 Make certain your external MIDI keyboard is

ment. This enters the note and moves to the
next step of the insertion point.

properly connected and working with Pro Tools.
2 Choose MIDI > Step Input.

To increase a note’s length while using Step Input:
1 Play and hold a note on your MIDI instru-

ment.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment.”
2 Choose the note value that you would like to
add and press the Increment button.

Release the note on your MIDI keyboard to
move to the next step insertion point.

Step Input Controls
The Step Input window has the following controls:

Step Input window

Enable When selected, MIDI events are added to
the destination track when you play your external MIDI keyboard. Additionally, each previously record-enabled MIDI track is taken out of
record enable.
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If a Default Thru Instrument is defined in the
MIDI page of the Preferences window, it is disabled when Step Input is enabled, and is re-enabled when Step Input is no longer disabled.

Set Velocity To When selected, MIDI notes are
recorded with the velocity that you specify in
the Velocity field. This value can be set with the
Velocity slider.

Destination Lets you select the destination track
for the Step Input from a pop-up list of all the
MIDI tracks in your session.

Enable Numeric Keypad Shortcuts When selected, Step Input options can be selected from
the numeric keypad. See “Numeric Keypad
Shortcuts” on page 43.

Step Increment
Undo Step, Next Step, and Redo Step
The options in the Step Increment section let
you set the spacing and duration of MIDI events
entered using the Step Input operation. You can
select any size from whole notes to sixty-fourth
notes (including dotted values).
Tuplet Lets you input irregular note groupings
(such as triplets or quintuplets). The tuplet
length is calculated from the note spacing selection and the Tuplet values. For example, an
eighth note equals 480 ticks, so tuplet eighth
notes with 3 in time of 2 would yield a note
spacing of 320 ticks (480 ticks / 3 * 2).
Note Length Lets you select the note length as a
percentage of the spacing value. For example, an
eighth note equals 480 ticks, so an eighth note
with an 80% duration would be 384 ticks long.

100%

80%

120%

Note length percentages

Options
Use Input Velocity When selected, MIDI notes
are recorded using the velocity that you play on
your MIDI keyboard.
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Use the Undo Step and Next Step buttons to do
the following:
• Move the step insertion point, by either removing the previous note or by advancing
the insertion point by the Step Increment
value.
• Lengthen and shorten notes that are being
held on the MIDI controller, by adding or
removing Step Increment values. The Step
Increment value can be changed mid-note
to create a note with a hybrid note length.
Use the Redo Step button to sequentially redo
any previously undone steps.
Undo Step When the previous note has been released from the MIDI keyboard, and the insertion point has moved forward to the next note,
Undo Step will remove the entire last note.
When a note is being held on the MIDI keyboard, Undo Step changes to read “Decrement,”
and removes the last Step Increment length that
was added to the held note.
Next Step When no note is being held on the
MIDI keyboard, Next Step moves the insertion
point by the Step Increment value, essentially
inserting a musical rest.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment”
and adds the Step Increment value to the held
note, increasing its length by the Step Increment value.

Numeric Keypad Shortcuts

While the note is being held, the Step Increment
value can be changed, allowing you to create
notes of any musical length.

:

When Enable Numeric Keypad Shortcuts is selected, you can choose many of the controls in
the Step Input window, as well as several selection controls using the numeric keypad.
Step Input Shortcuts

Key

Whole Note

1

1/2 Note

2

1/4 Note

4

1/8 Note

5

1/16 Note

6

1/32 Note

7

1/64 Note

8

Dotted note

. (decimal key)

Toggle Tuplet On/Off

3

Next Step

Enter

Selecting the Next Step field

Undo Step

0

3 Play the MIDI event you wish to use as a trig-

Nudge Forward

+

Nudge back

–

Select Main Location Indicator

=

Edit Selection Indicators

/

Redo Step Reinserts the last note that was removed by the Undo Step operation.
To set Undo Step, Next Step and Redo Step MIDI
triggers:
1 Choose MIDI > Step Input.
2 Locate the button you want to assign a MIDI

event to, and click in the field below the button.

ger.

If you use a continuous controller such as
Pitch Bend as a trigger, you should make
certain to use an extreme controller value to
avoid erroneous data input.

Next Step field triggered by pitch bend
4 Press Enter to confirm the MIDI trigger assign-

ment.
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TCE Trimmer Functionality on
MIDI Regions
The TCE Trimmer is a convenient tool for
matching a MIDI region to the length of another region, a tempo grid, or any other reference point.

Using the Time Trimmer in Grid Mode
The Time Trimmer can be used in Grid mode to
match a region to the tempo of a session or a
section of a session, or to create “double time”
or “half time” performances.
To use the Time Trimmer in Grid mode:
1 Set the Edit mode to Grid.
2 Set the Track View of the MIDI track to Re-

Trimmer set to TCE

With the TCE Trimmer, you can move the MIDI
region’s start or end point to expand or compress the region, scaling the MIDI data accordingly.

gions.
3 Select TCE Trimmer from the Trimmer pop-up
menu.
4 With the Time Trimmer, drag the MIDI region’s start or end point to compress or expand
the region to the Grid (for example, by quarter
notes). A new region is automatically created,
which appears in the playlist and in the Regions
List.

Using the Time Trimmer in Slip Mode
To use the Time Trimmer in Slip mode:
1 Set the Edit mode to Slip.

Before trimming

2 Set the Track View of the MIDI track to Re-

gions.
3 Select TCE Trimmer from the Trimmer pop-up
menu.
4 With the Time Trimmer, drag the MIDI region’s start or end point to compress or expand
the region freely. A new region is automatically
created, which appears in the playlist and in the
Regions List.

After trimming
Scaling a MIDI region with the TCE Trimmer
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Using the Time Trimmer in Spot Mode
In Spot mode, clicking with the Time trimmer in
a region opens the Spot dialog. You can specify
the location you want the region to start or end
at, or the duration of the region, and the region
is automatically compressed or expanded as
specified.

Automated MIDI Controller
Assignment
In Pro Tools 6.7, when you record continuous
controller information from an external MIDI
device, the controller is automatically added to
the MIDI Controllers list.

To use the Time Trimmer in Spot mode:
1 Set the Edit mode to Spot.
2 Set the Track View of the MIDI track to Re-

gions.
3 Select TCE Trimmer from the Trimmer pop-up
menu.
4 Click the MIDI region near its start or end

point. The Spot dialog opens. Using any Time
Scale, enter a new start or end time (or duration)
for the region, then click OK. A new region is automatically created, which appears in the playlist and in the Regions List.

Using the Time Trimmer in Shuffle Mode
In Shuffle mode, the trimmed region will always
begin at the original region’s start point regardless of whether you trim from the front to the
rear or from the rear to the front.
To use the Time Trimmer in Shuffle mode:
1 Set the Edit mode to Shuffle.
2 Set the Track View of the MIDI track to Re-

gions.
3 Select TCE Trimmer from the Trimmer pop-up
menu.

MIDI Controllers pop-up menu

For more information about MIDI recording
MIDI controller information, see the
Pro Tools Reference Guide.

MIDI Studio Setup
(Windows XP Only)
MIDI Studio Setup (MSS) lets you configure the
MIDI controllers and sound modules that are
connected to your system, and control the routing of MIDI data between your MIDI equipment
and Pro Tools.
MSS automatically finds MIDI interfaces, and
lets you specify a custom name for each of the
MIDI ports within the MIDI studio setup document.

4 With the Time Trimmer, drag the MIDI region’s start or end point to compress or expand
the region freely. A new region is automatically
created, which appears in the playlist and in the
Regions List.
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MSS also supports XML-based patch file names
for storing and importing patch names for your
external MIDI devices.

Internal MIDI ports, such as the Microsoft
MIDI Mapper and built-in wavetable synthesizers are filtered from the list of available MIDI output ports. They are, however,
accessible directly from a MIDI track’s output popup.
Entire MIDI Studio Setup configurations created
within MSS can be imported and exported.

MIDI Studio Setup Window
The MIDI Studio Setup window is organized
into three sections. Interface controls are at the
top of the window. All the currently defined instruments are displayed in the Instrument
Name list on the left side of the window. A detailed view of MIDI parameters is shown in the
Properties section on the right.

Export This button lets you export the current
MIDI studio setup file.
Show Duplicate Emulated Outputs If you are using a MIDI interface that supports timestamping
(such as MIDI I/O), when the Show Duplicate
Emulated Outputs option is selected, the MIDI
Studio Setup window shows both the DirectMusic time-stamped output ports, and nonstamped duplicate emulated output ports.

Some MIDI Interfaces will not properly load
or unload their drivers unless you quit and
re-launch Pro Tools. Check the documentation that came with your MIDI interface for
more information.

Instrument List
The Instrument list contains all the currently
defined instruments. Selecting an instrument in
the list displays that instrument’s properties in
the properties section of the window.

Properties Section
The Properties section lets you edit information
for new instruments, or instruments currently
displayed in the Instrument Name list.

MIDI Studio Setup window

Interface Controls
Create This button adds a new instrument to
the Instrument Name list.
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Delete This button deletes the instrument or instruments selected in the Instrument Name list.

MIDI Studio Setup Properties section

Import This button lets you import existing
MIDI studio setup files.

When a previously defined instrument is selected in the Instrument Name list, the Properties section changes to reflect the properties of
the selected instrument.
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To define an instrument with MIDI Studio Setup:

Model

1 Choose Setups > MIDI Studio Setup.

The Model pop-up menu provides a list of MIDI
devices, filtered by the manufacturer name. This
list is derived from the XML-based MIDI device
files provided with your Pro Tools installation.

2 Click Create.
3 In the Instrument Name field, type the name
of your instrument, and press enter.

If you do not enter an instrument name, the
Instrument Name field will automatically
inherit information from the Manufacturer
and Model pop-up menu.
4 Set a manufacturer and model for the new de-

vice from the corresponding pop-up menus. If
the Manufacturer and Model pop-up menus do
not provide a name for your particular device,
choose None.
5 From the Input pop-up menu, choose the in-

put port on your MIDI interface that is connected to the MIDI Out of your instrument.
6 From the Output pop-up menu, choose the

output port on your MIDI interface that is connected to the MIDI In of your instrument.
7 Enable the appropriate MIDI channels (1–16)

for the Send Channels and Receive Channels
options (These determine which channels send
and receive MIDI.)

Instrument Name
The Instrument Name field shows the user-definable instrument name for the currently selected instrument.

Manufacturer
The Manufacturer pop-up menu provides a list
of MIDI equipment manufacturers. This list is
derived from the XML-based MIDI device files
provided with your Pro Tools installation.

For more information, see “Patch Name
Support for Windows XP” on page 48.

For more information, see “Patch Name
Support for Windows XP” on page 48.

Input Port
The Input Port pop-up menu displays a list of
available MIDI interface input ports. The MIDI
interface port that is set and displayed here is
the port through which MIDI data is sent from
the external MIDI device specified in the Instrument Name field into your MIDI interface.

If you set the input port to None, the defined
instrument will not appear as a choice in a
MIDI Input Selector.

Output Port
The Output Port pop-up menu displays a list of
available MIDI interface output ports. The port
set and displayed here is the port through which
MIDI data is sent from your MIDI interface to
the MIDI device specified in the Instrument
Name field.

If you set the output port to None, the defined instrument will not appear as a choice
in a MIDI Output Selector.

Send Channels
The Send Channels grid sets the send channels
for the MIDI device specified in the Instrument
Name field.

Receive Channels
The Receive Channels grid sets the receive channels for the MIDI device specified in the Instrument Name field.
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Patch Name Support for
Windows XP
Pro Tools supports XML (Extensible Markup
Language) for storing and importing patch
names for your external MIDI devices. Pro Tools
installs MIDI patch name files (.midnam) for the
factory default patch names of many common
MIDI devices. These files reside in directories,
sorted by manufacturer, in Program Files\
Common Files\Digidesign\MIDI Patch Names\
Digidesign.
To import MIDI patch names into Pro Tools:
1 Verify the MIDI Device name in the MIDI Stu-

dio Setup window (Setups > MIDI Studio Setup).

For more information about MIDI Studio
Setup, see “MIDI Step Input” on page 41.
2 Verify the MIDI track’s output is correctly assigned to the MIDI device.
3 Click the MIDI track’s Program button.

4 In the Patch Select dialog, click the Change

button.

Change button
Patch Select dialog
5 In the Open dialog, navigate to Program

Files\Common Files\Digidesign\MIDI Patch
Names\Digidesign\<name of manufacturer>,
and select the MIDI Patch Name file (.midnam)
for the MIDI device.
6 Click Open.

The Patch Select dialog is populated with patch
names and the Patch Name Bank pop-up menu
appears in the upper left hand corner of the window.

Program button

Program button, Edit window

Program button

Patch Select dialog with patch names

Program button, Mix window
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Once patch names have been imported into
Pro Tools, they are available for that MIDI device in all sessions.

Pro Tools will not let you import a patch
name file that does not match the model
and manufacturer information that you
have selected in the MIDI Studio Setup window.
To clear patch names:
In the Patch Select dialog, click the Clear button, and click Done.

■

MIDI patch name files (.midnam) can be
edited in any text editor, or you can use
third party patch librarian and editor software to create your own custom patch
names.

MIDI I/O Support for
Windows XP
Pro Tools 6.7 introduces Windows XP support
for Digidesign’s USB (Universal Serial Bus) MIDI
interface, the MIDI I/O.

MIDI I/O Capabilities
• Provides ten MIDI input and ten MIDI output
ports for a total of 160 MIDI channels per interface
• Up to four MIDI I/Os can be connected together for a total of 40 ports and 640 MIDI
channels

• Supports programmable MIDI Thru mode
when offline (not in use by a MIDI application) or not connected to a computer

Send Session Via DigiDelivery
(Windows XP Only)
DigiDelivery is Digidesign’s system for efficient
and reliable transfer of digital media files over
the Internet. Send Session Via DigiDelivery lets
you send a Pro Tools session and all of its related
files using DigiDelivery from within Pro Tools.
Anyone can send and receive files from a
DigiDelivery system, even if they do not own a
DigiDelivery network appliance, as follows:
To send a delivery, senders must have an Internet connection, an account on a DigiDelivery
network appliance, and the DigiDelivery client
application.

◆

To receive a delivery, recipients only need an
Internet connection and the DigiDelivery client
application; an account on the network appliance is not needed.

◆

For more information, see the DigiDelivery
Guide, or refer to the DigiDelivery Web site
(www.digidesign.com/digidelivery).
To Send a session from Pro Tools using
DigiDelivery:
1 Choose File > Send Session Via DigiDelivery.

• Fully compatible with MSS on Windows XP,
MIDI I/O will work with Pro Tools and other
compatible MIDI applications on Windows
XP
• Powered from USB with a direct connection to
your computer or a powered USB hub
• Supports MIDI Time Stamping

Send to DigiDelivery menu
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2 If the DigiDelivery client is not installed on
your system, Pro Tools will launch your Web
browser, and connect to the DigiDelivery site
where you can download the current DigiDelivery client.

– or –
If the DigiDelivery client is installed on your system, the Include in Delivery dialog will open.
3 In the Include in Delivery dialog, select which
files to include, and click OK.

Mac/PC Session File
Conversion
(Windows XP Only)
This feature lets Windows XP users save a valid,
Windows-compatible copy of a Pro Tools session when you try to open a session that was
created on a Macintosh system and saved without the “Enforce Mac/PC compatibility” option
selected.

This feature does not let you open sessions
containing double byte characters (such as
Asian language characters).
To open a Macintosh session on a Windows
system when the “Enforce Mac/PC compatibility”
option was not originally selected:
1 When you attempt to open the session,

Include in Delivery dialog

Pro Tools will prompt you to choose a new location for the session.

You have the option to include:
• Video files
• Audio files
• Fade files
• Plug-in settings files
• Timeline files only (files that are referenced
in the current session timeline)
4 The DigiDelivery client will launch, and the

Login page will open.
5 Send the file, following the instructions that
came with the DigiDelivery client software.

Unenforced Mac/PC Compatibility dialog
2 Choose OK to save the session to a new loca-

tion.
– or –
Choose Cancel to cancel without opening the
session.
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3 In the Save New Session As dialog, choose a

destination and enter a name for the new session file.

Non-Administrator (Standard)
Account Support

\

Pro Tools 6.7 supports both administrator and
non-administrator (standard) accounts. Allowing Pro Tools to work with a non-administrator
accounts provides more flexibility to schools
and other facilities where multiple Pro Tools users share workstations. Multiple engineers or
students can work extensively with Pro Tools,
while being restricted from installing software
or accessing local hard disk and server locations
that should remain restricted.

For more information about the non-administrator (standard) user accounts, see
the Windows NonAdmin Guide (Windows), or the OS X Standard Accounts
Guide (Macintosh).
Save New Session As dialog

Installation and Operation

4 Set the Audio File Type to AIFF or BWF (.WAV).

Installation and operation of Pro Tools with a
non-administrator user account follows the
same procedures that are covered in the
Pro Tools Reference Guide, and other documentation. Keep in mind the following:

These file formats are compatible with either
platform.
5 Set the Sample Rate for the session.
6 Select the Items to Copy to the new session.
7 Click Save.

If the session previously used SDII files, the files
are converted to the new audio file format.

• Pro Tools requires an Administrator for installation.
• Pro Tools lets users save their Pro Tools User
Preferences individually. If users alter the
existing Pro Tools Preferences, a separate
version of Pro Tools Preferences is stored in
Documents and Settings\<username>\
Application Data\Digidesign (Windows) or
in the Home directory (Macintosh).
• As with previous Pro Tools releases, users
still have global Read/Write privileges on
all Pro Tools related files and settings. However, users of non-administrative accounts
can have their file Read/Write privileges
limited by the system administrator.
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Configuring a Non-Administrator
(Standard) Account for Pro Tools
Users
Non-administrative (standard) user accounts
need to be properly configured to let users run
Pro Tools without limits.
To configure a non-administrator user account on
Windows XP:
During the installation of Pro Tools, the installer will create a user group called “Pro Tools
Users”. By default, all Pro Tools users are part of
the “Pro Tools Users” group, which enables full
use of the Pro Tools system.
■

For more information about the non-administrator user account settings, see the
Windows Non-Administrator Accounts
Guide.
To configure a standard user account on
Mac OS X:
1 Log in to Mac OS X with an administrator account.
2 Under the Apple menu, choose System Prefer-

ences.
3 In the System Preferences pane, select Ac-

counts.
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4 Select the Standard account you wish to modify.

For information about how to create a user
account, or more information about user
accounts in general, see the documentation
that came with your computer.
5 Select Limitations.
6 Choose No Limits.
7 Close the pane.

For more information about the standard
user account settings, see the OSX Standard
Accounts Guide.

Saving Files With a NonAdministrator (Standard) Account
Pro Tools non-Administrator account users may
be limited to saving sessions and audio files to
folders within their Home directory.
A typical workflow for non-administrator account users is to write their Pro Tools files to
their My Documents folder (Windows) or their
Documents folder (Macintosh).
Saving files, or recording to an internal drive
can work well for small to medium-sized sessions. For larger sessions requiring many tracks
and higher sample rates, external Firewire or
SCSI drives may be required. Users requiring external drive access will need to ensure they have
Read/Write permissions set to use these drives if
logged in using a standard account.

Keyboard Shortcuts
For increased ease-of-use, Pro Tools 6.7 includes keyboard shortcuts for the following commands:

Command

Windows

Macintosh

Bring selected region to the front

Alt+Shift+F

Option+Shift+F

Send selected region to the back

Alt+Shift+B

Option+Shift+B

Open the Time Operations window

Alt+1 on the numeric
keypad

Option+1 on the numeric
keypad

Open the Tempo Operations window

Alt+2 on the numeric
keypad

Option+2 on the numeric
keypad

Open the MIDI Operations window

Alt+3 on the numeric
keypad

Option+3 on the numeric
keypad

Scroll to selection start/end

Left/Right Arrow

Left/Right Arrow

Play by pre-roll value up to selection start/end

Alt+Left/Right Arrow

Option+Left/Right Arrow

Play by post-roll value up to selection start/end

Control+Left/Right Arrow

Command+Left/Right
Arrow

Play by pre- and post-roll value through selection start/end

Control+Alt+Left/Right
Arrow

Command+Option+
Left/Right Arrow

Show the previous/next automation playlist for
all selected tracks

Control+Start+Left/Right
Arrow

Control+Command+
Left/Right Arrow

Show the previous/next automation playlist for
all tracks

Control+Start+Alt+
Left/Right Arrow

Control+Option+Command+Left/Right Arrow

Cycle through the Track Type choices in the New
Track dialog

Control+Up/Down Arrow

Command+Up/Down
Arrow

Cycle through the Track Format choices in the
New Track dialog

Control+Left/Right Arrow

Command+Left/Right
Arrow
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Command

Windows

Macintosh

Cycle through the Track Timebase choices in
the New Track dialog

Control+Alt+Up/Down
Arrow

Command+Option+
Up/Down Arrow

Add or delete a Track Entry field in the New
Tracks dialog

Control+Plus/Minus (+/–)

Command+Plus/Minus
(+/–)

Switch between Librarian settings subfolders in
the Plug-in Settings dialog

Control+Up/Down Arrow

Command+Up/Down
Arrow

Move the only the Song Start Marker, without
moving any tick-based data

Start-Shift-drag the Song
Start Marker

Control-Shift-drag the
Song Start Marker
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